Repository 32bit  Forum
Repository 64bit  Wiki

"Risolto" attivare scheda wifi TL-WN951N

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:03

hey ci sei?
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:07

Non voglio insistere ma credo sia un problema di riconoscimento della scheda. Facciamo un passo indietro.
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:08

dai dal terminale ifconfig -a
e dimmi cosa esce
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:11

Codice: Seleziona tutto
bash-4.1# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:19:66:96:42:C0 
          inet addr:192.168.1.109  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::219:66ff:fe96:42c0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25346 errors:0 dropped:1 overruns:0 frame:0
          TX packets:22263 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25660743 (24.4 Mb)  TX bytes:2918257 (2.7 Mb)
          Interrupt:23 Base address:0xe800

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8992 (8.7 Kb)  TX bytes:8992 (8.7 Kb)

bash-4.1#
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:12

Ok dai ifconfig wlan0 up
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:14

Codice: Seleziona tutto
# ifconfig wlan0 up
wlan0: unknown interface: No such device
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:17

Ok dai
ls -1 /etc/modprobe.d/
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:18

Codice: Seleziona tutto
# ls -1 /etc/modprobe.d/
blacklist.conf
bluetooth.conf
isapnp.conf
ndiswrapper.conf
nvidia-installer-disable-nouveau.conf
psmouse.conf
usb-controller.conf
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:21

per adesso rimuovi ndiswrapper
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:23

solo il pacchetto?
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:24

Non mi torna lspci il: NON VGA
Codice: Seleziona tutto
03:04.0 Non-VGA unclassified device: Atheros Communications Inc. AR5008 Wireless Network Adapter (rev 01)
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:28

Aspetta riproviamo prima con ndiswrapper

blacklista i driver ath9k
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:31

Dove e come?
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

Re: attivare scheda wifi

Messaggioda vitosky » sab dic 17, 2011 23:34

Vai nella directory /etc/modprobe.d/blacklist.conf
assicurati che il modulo ath_pci non sia in blacklist
apri blacklist.conf con un editor di testo e a fine pagina aggiungi


blacklist ath9k
salva e riavvia
vitosky
Linux 1.0
Linux 1.0
 
Messaggi: 84
Iscritto il: mer feb 10, 2010 20:55
Slackware: 13.37
Kernel: 2.6.37.6 huge.s

Re: attivare scheda wifi

Messaggioda maxmo » sab dic 17, 2011 23:44

Fatto
Avatar utente
maxmo
Linux 2.4
Linux 2.4
 
Messaggi: 336
Iscritto il: lun feb 28, 2005 0:00
Slackware: 14.1
Kernel: 3.10.17-smp
Desktop: xface

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron