Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] no nouveau su centos

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] no nouveau su centos

Messaggioda daniele50 » sab dic 31, 2011 11:16

Ciao a tutti,
scusate se scrivo qui cose riguardanti alla distro CentOS, se c'è qualcuno che ne sa bene, altrimenti pazienza...

Sto cercando di installare i driver nvidia su CentOS 6.2 ma prima devo disattivare i driver nouveau.
L'altro giorno ci sono riuscito ma poi ho rifatto tutto da zero ed ora non riesco più...
Ecco quello che ho fatto:

Codice: Seleziona tutto
rpm -e xorg-x11-drv-nouveau --nodeps

poi ho creato il file /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
Codice: Seleziona tutto
# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

e poi ho creato un initramfs senza driver nouveau
Codice: Seleziona tutto
dracut -o "nouveau" initramfs-2.6.32-220.2.1.el6.x86_64-no_nouveau.img

Mi sembra esattamente quello che ho fatto un paio di giorni fa, ma evidentemente non è così perché continua a caricarmi i moduli nouveau
Codice: Seleziona tutto
# lsmod |grep nouveau
nouveau               708412  2
ttm                    70328  1 nouveau
drm_kms_helper         33236  1 nouveau
drm                   230675  3 nouveau,ttm,drm_kms_helper
i2c_algo_bit            5762  1 nouveau
i2c_core               31276  5 i2c_piix4,nouveau,drm_kms_helper,drm,i2c_algo_bit
mxm_wmi                 1925  1 nouveau
video                  21032  1 nouveau


idee ???
Ultima modifica di daniele50 il sab dic 31, 2011 13:30, modificato 1 volta in totale.
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 939
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.10.17
Desktop: Xfce 4.10

Re: no nouveau su centos

Messaggioda hashbang » sab dic 31, 2011 12:16

Avviare il kernel col parametro "nomodeset"?
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1842
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: no nouveau su centos

Messaggioda daniele50 » sab dic 31, 2011 13:30

atomix600 ha scritto:Avviare il kernel col parametro "nomodeset"?

Non so come fare, quasi tutti usano il parametro rdblacklist=nouveau nouveau.modeset=0 in grub.conf, ma io uso lilo e questi parametri non vengono accettati.

Comunque ho risolto rifacendo l'initramsf con dracut -o nouveau no-nouveau.img ed ora, dopo aver riconfigurato lilo, funziona.
Non ho ancora capito perché ho ricreato l'immagine initramsf tre volte con lo stesso comando, e per tre volte ha creato un file con diverse dimensioni...

Ciao e grazie... e auguri!
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 939
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.10.17
Desktop: Xfce 4.10


Torna a Libera

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite