Repository 32bit  Forum
Repository 64bit  Wiki

Dual Boot LILO con Debian?

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Dual Boot LILO con Debian?

Messaggioda Fabio Vianello » ven gen 13, 2012 23:23

Scusate... vorrei una mano per configurare LILO.
Avevo dentro una partizione Windows e Debian quando ho installato slackware current 32 bit. Ovviamente con l'installazione di Slackware mi è scomparso Debian come voce del Boot loader.
Vorrei rimetterla. Ho visto qualche guida ma non ho capito bene cosa inserire a lilo.conf .

Questo è lilo.conf
Codice: Seleziona tutto
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# Normal VGA console
vga = normal
# Ask for video mode at boot (time out to normal in 30s)
#vga = ask
# VESA framebuffer console @ 1024x768x64k
#vga=791
# VESA framebuffer console @ 1024x768x32k
#vga=790
# VESA framebuffer console @ 1024x768x256
#vga=773
# VESA framebuffer console @ 800x600x64k
#vga=788
# VESA framebuffer console @ 800x600x32k
#vga=787
# VESA framebuffer console @ 800x600x256
#vga=771
# VESA framebuffer console @ 640x480x64k
#vga=785
# VESA framebuffer console @ 640x480x32k
#vga=784
# VESA framebuffer console @ 640x480x256
#vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sda1
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda7
  label = Linux
  read-only
# Linux bootable partition config ends




Questo è il risultato di "ls /boot"
Codice: Seleziona tutto
README.initrd                        config-huge-2.6.37.6
System.map                           config-huge-smp-2.6.37.6-smp
System.map-generic-2.6.37.6          diag1.img
System.map-generic-smp-2.6.37.6-smp  diag2.img
System.map-huge-2.6.37.6             map
System.map-huge-smp-2.6.37.6-smp     slack.bmp
boot.0800                            vmlinuz
boot_message.txt                     vmlinuz-generic-2.6.37.6
config                               vmlinuz-generic-smp-2.6.37.6-smp
config-generic-2.6.37.6              vmlinuz-huge-2.6.37.6
config-generic-smp-2.6.37.6-smp      vmlinuz-huge-smp-2.6.37.6-smp



questo è il risultato di "fdisk -l"
Codice: Seleziona tutto
bash-4.1# fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xd69bd69b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   204814333   102407135+   7  HPFS/NTFS/exFAT
/dev/sda2       204828811   976768064   385969627    f  W95 Ext'd (LBA)
/dev/sda5       204828813   208925324     2048256   82  Linux swap
/dev/sda6       208925388   331806509    61440561   83  Linux
/dev/sda7       331806573   444454289    56323858+  83  Linux
/dev/sda8       444454353   555270659    55408153+   7  HPFS/NTFS/exFAT
/dev/sda9       555284480   771971071   108343296    7  HPFS/NTFS/exFAT
/dev/sda10      771971508   976768064   102398278+   7  HPFS/NTFS/exFAT

Le partizioni NTFS finali contengono solo dati. non c'è windows.


Se avete bisogno di altro ditemi.

un'ultima cosa: quando digito "/sbin/lilo" mi viene fuori questo:
Codice: Seleziona tutto
bash-4.1# /sbin/lilo
Warning: LBA32 addressing assumed
Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/sda1' -> '/dev/sda1'
part_nowrite check:: Input/output error


Era già così...spero non sia un errore preoccupante (warning dovrebbe dire avvertimento)
Fabio Vianello
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: mer gen 04, 2012 13:08

Re: Dual Boot LILO con Debian?

Messaggioda sya54M » sab gen 14, 2012 13:17

un esempio di come aggiungere debian è:
Codice: Seleziona tutto
image = /mnt/debian/boot/vmlinuz-2.6.32-5-i686
  root = /dev/sda6
  label = Debian
  read-only

volendo puoi mettere l'UUID al posto di /dev/sda6 come fa stesso debian.
/mnt/debian è il percorso in cui monti su slackware la partizione di debian
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1441
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: Dual Boot LILO con Debian?

Messaggioda Fabio Vianello » lun gen 16, 2012 16:33

Ok, è più o meno quello che facevo io.
Ma quando do il comando "/sbin"lilo" da root mi fa:
Codice: Seleziona tutto
bash-4.1# lilo
Warning: LBA32 addressing assumed
Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/sda1' -> '/dev/sda1'
part_nowrite check:: Input/output error
come ho già citato prima.

Ho provato anche a cambiare l'immagine (slack.bmp) che sta su /boot con un'altra con pari dimesioni e sempre .bmp per vedere se me la cambiava.

Il risultato è che non succede nulla... non mi si aggiunge la voce di Debian e nemmeno si cambia l'immagine. Penso che il problema stia nel dare il comando "lilo". Oppure c'è qualche altro comando che serve per aggiornare le nuove configurazioni che sono state fatte a lilo.
Fabio Vianello
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: mer gen 04, 2012 13:08

Re: Dual Boot LILO con Debian?

Messaggioda sya54M » lun gen 16, 2012 16:44

sembra che non hai i file dispositivo nella directory /dev, il che è strano...
comunque prova a crearlo tu così:
Codice: Seleziona tutto
# mknod /dev/sda b 8 0

e poi vedi se lilo da ancora l'errore.

sicuro che siano installati i pacchetti fondamentali di slackware?
in /etc/fstab cosa c'è? da cui ne segue: /proc è montato?
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1441
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: Dual Boot LILO con Debian?

Messaggioda Fabio Vianello » mar gen 17, 2012 15:13

Codice: Seleziona tutto
bash-4.1# mknod /dev/sda b 8 0
mknod: `/dev/sda': File exists

Ho provato a dare quel comando ma mi dà fa quellìoutput. E ancora LILO non va.
Fabio Vianello
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: mer gen 04, 2012 13:08

Re: Dual Boot LILO con Debian?

Messaggioda Fabio Vianello » mar gen 17, 2012 22:14

sya54M ha scritto:sicuro che siano installati i pacchetti fondamentali di slackware?
in /etc/fstab cosa c'è? da cui ne segue: /proc è montato?


All'installazione di Slackware ho installato tutto quello che si poteva installare (eccetto KDEI...le lingue di kde). Quindi penso che i pacchetti fondamentali siano installati.

Però ricordo che l'unica cosa un po' ambigua nell'installazione è stata proprio riguardo la configurazione del file fstab. Infatti mi pare di ricordare che avevo selezionato di aggiungere windows e anche l'altra partizione di debian...ma poi tipo...ho fatto indietro per riscegliere e mi è andata avanti l'installazione chiedendomi la roba successiva. Boh...sono andato avanti e chissene.... Spero non sia un problema riconfigurare fstab dopo l'installazione.

comunque questo è fstab:
Codice: Seleziona tutto
bash-4.1$ cat /etc/fstab
/dev/sda5        swap             swap        defaults         0   0
/dev/sda7        /                ext4        defaults         1   1
/dev/sda6        /dev/sda6        ext4        defaults         1   2
/dev/sda1        /dev/sda1        ntfs-3g     fmask=177,dmask=077 1   0
/dev/sda10       /dev/sda10       ntfs-3g     fmask=177,dmask=077 1   0
/dev/sda8        /dev/sda8        ntfs-3g     fmask=177,dmask=077 1   0
/dev/sda9        /dev/sda9        ntfs-3g     fmask=177,dmask=077 1   0
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0


Non so bene cosa sia fstab...ditemi se è da sistemare.

Mi hai anche chiesto se /proc è montato. Penso che volevi il file fstab ma ho postato anche il comando "mount" in caso serva:
Codice: Seleziona tutto
bash-4.1# mount
/dev/root on / type ext4 (rw,relatime,barrier=1,data=ordered)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/sda1 on /dev/sda1 type fuseblk (rw,allow_other,blksize=4096,default_permissions)
/dev/sda10 on /dev/sda10 type fuseblk (rw,allow_other,blksize=4096,default_permissions)
/dev/sda8 on /dev/sda8 type fuseblk (rw,allow_other,blksize=4096,default_permissions)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda9 on /dev/sda9 type fuseblk (rw,allow_other,blksize=4096,default_permissions)
Fabio Vianello
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: mer gen 04, 2012 13:08

Re: Dual Boot LILO con Debian?

Messaggioda zoros » mar gen 17, 2012 22:41

Fabio Vianello ha scritto:Ok, è più o meno quello che facevo io.
Ma quando do il comando "/sbin"lilo" da root mi fa:
Codice: Seleziona tutto
bash-4.1# lilo
Warning: LBA32 addressing assumed
Warning: '/proc/partitions' does not match '/dev' directory structure.
    Name change: '/dev/sda1' -> '/dev/sda1'
part_nowrite check:: Input/output error
come ho già citato prima.

...

nel caso dovresti copiare la /dev "Slackware" su quella "Debian" con il comando "cp -Rpdf source dest" ... e poi "lilo" ;) ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)

Re: Dual Boot LILO con Debian?

Messaggioda Fabio Vianello » mer gen 18, 2012 17:17

zoros ha scritto:nel caso dovresti copiare la /dev "Slackware" su quella "Debian" con il comando "cp -Rpdf source dest" ... e poi "lilo" ;) ...


Scusami, non ho ben capito...potresti spiegarti meglio?
Prima ho postato il mio "fdisk -l".
la partizione di slackware è /dev/sda7
la partizione di debian è /dev/sda6

al posto di "source dest" cosa devo mettere?
Fabio Vianello
Linux 1.0
Linux 1.0
 
Messaggi: 16
Iscritto il: mer gen 04, 2012 13:08

Re: Dual Boot LILO con Debian?

Messaggioda zoros » mer gen 18, 2012 22:46

Fabio Vianello ha scritto:la partizione di slackware è /dev/sda7
la partizione di debian è /dev/sda6

al posto di "source dest" cosa devo mettere?

lilo controlla i devices (in /dev) di ogni partizione che si intende avviare ... la /dev viene "riempita" dinamicamente all'avvio di ogni sistema ... a quanto pare tra distro diverse anche la mappatura dei devices è diversa (a parità di nome) ... devi in qualche modo sovrascrivere la /dev della partizione Debian con la /dev su cui ti gira Slackware ... potrebbe essere:
Codice: Seleziona tutto
cp -Rpdf /dev/* /puntodimountDebian/dev/

quindi puoi finalmente dare il comando "lilo"
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot], Yahoo [Bot] e 3 ospiti

cron