Repository 32bit  Forum
Repository 64bit  Wiki

problema con NFS (RISOLTO)

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problema con NFS (RISOLTO)

Messaggioda creppolo » dom gen 15, 2012 9:59

ho provato a condividere una directory tra due macchine con slackware 13.37 in entrambe (con fluxbox e thunar, sono due vecchi P3 con circa 700Mhz di processore e 256mb di ram) ho seguito il solito iter (modifica dei files /etc/exports e /etc/fstab) come ho fatto più volte ma stavolta ho sbagliato qualcosa, perchè mi da un errore: "mount.nfs: Protocol not supported"... non l'ho mai trovato prima e cercando in rete non ho trovato nulla che mi aiuti ... qualcuno mi da una mano??? :cry:
Ultima modifica di creppolo il mar gen 17, 2012 18:29, modificato 1 volta in totale.
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: problema con NFS

Messaggioda creppolo » lun gen 16, 2012 17:59

non è mai capitato a nessuno? nessuno può dirmi cosa ho sbagliato?
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: problema con NFS

Messaggioda Naitso » mar gen 17, 2012 9:08

Ciao gentilmente puoi postare i file di configurazione, così se qualcuno può ha una base dalla quale partire...
Ciao
Avatar utente
Naitso
Linux 2.0
Linux 2.0
 
Messaggi: 194
Iscritto il: lun nov 10, 2008 15:09

Re: problema con NFS

Messaggioda krisis » mar gen 17, 2012 10:22

Non hai caricato il modulo nel kernel o se hai un kernel monolitico non hai compilato la componente nfs.

P.s. Hai cercato male : http://www.linuxquestions.org/questions/linux-embedded-78/protocol-not-supported-error-after-mount-692466/ è il primo risultato cercando
Codice: Seleziona tutto
mount.nfs: Protocol not supported
.
Avatar utente
krisis
Linux 3.x
Linux 3.x
 
Messaggi: 1120
Iscritto il: mar gen 25, 2005 0:00
Località: Roma
Distribuzione: debian

Re: problema con NFS (RISOLTO)

Messaggioda creppolo » mar gen 17, 2012 18:30

grazie mille a tutti e due per la risposta, nel frattempo ho risolto proprio seguendo la guida indicata anche da krisis... grazie, risolto!
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: problema con NFS (RISOLTO)

Messaggioda creppolo » mer gen 18, 2012 18:21

per tutti quelli che hanno il mio stesso problema: basta caricare nf con "modprobe nfs" da utente root
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 6 ospiti