Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Problema con hplip

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Problema con hplip

Messaggioda yAri » gio gen 26, 2012 9:17

Salve. Non sono un esperto di slackware, poichè non ci dedico tanto tempo ma usandolo pian piano si impara, quindi se sareste così gentili da descrivere tutti i passaggi necessari per risolvere il problema vi sarei molto grato :D :D
Ho una stampante wireless HP Deskjet 3070A.
Il problema è che quando stampo (senza usare programmi, driver e cose varie, cioè semplicemente aggiungendola come una stampante di rete) stampa malissimo, caratteri sovrapposti ecc. Stampa "bene" soltanto la prima pagina.
Ho naturalmente pensato che il problema sono i driver.. e "casualmente" (si intente quanto sono inesperto :shock: ) ho visto "HP Device Manager".
Ma ho avuto un problema. Non si avviava. Ho fatto una ricerca e ho provato a reinstallare il pacchetto "hplip". Ho una Slackware 13.37 a 64 bit.
Ma non si avvia lo stesso.
Lanciando il comando hp-toolbox ricevo questo output:

Codice: Seleziona tutto
root@localhost:~/Downloads# hp-toolbox
Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 39, in <module>
    from base import status, tui, module
  File "/usr/share/hplip/base/status.py", line 45, in <module>
    import hpmudext
ImportError: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib64/libhpmud.so.0)


Spero di trovare una risoluzione a questo problema, poichè voglio disinstallare windows (sul quale la stampante funziona benissimo..). Grazie il vostro aiuto.
Ultima modifica di yAri il sab mar 08, 2014 17:12, modificato 1 volta in totale.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 11:22

yAri ha scritto:
Codice: Seleziona tutto
ImportError: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib64/libhpmud.so.0)
Posta l'output di
Codice: Seleziona tutto
ldd /usr/lib64/libhpmud.so.0

e

Codice: Seleziona tutto
ls /var/log/packages | grep glibc
ls /var/log/packages | grep hplip


PS: Da dove hai preso HPLIP? Come mai ti richiede GLibc 2.14, se Slackware 13.37 usa GLibc 2.13? Il ramo -current usa il 2.14.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 13:40

Hplip l'ho preso dal questo sito suggerito a qualche utente in una discussione, ma con un altro problema:

Meskalamdug ha scritto:http://reteprivata.dyndns-ip.com/pacchetti/

Se sei su slack64 ecco il pacchetto.


l'ouput di ldd /usr/lib64/libhpmud.so.0
Codice: Seleziona tutto
root@localhost:~# ldd /usr/lib64/libhpmud.so.0
/usr/lib64/libhpmud.so.0: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /usr/lib64/libhpmud.so.0)
        linux-vdso.so.1 =>  (0x00007fff761ff000)
        libusb-0.1.so.4 => /usr/lib64/libusb-0.1.so.4 (0x00007fc8ea6a5000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fc8ea487000)
        libnetsnmp.so.25 => /usr/lib64/libnetsnmp.so.25 (0x00007fc8ea1d4000)
        libcrypto.so.0 => /lib64/libcrypto.so.0 (0x00007fc8e9e4b000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fc8e9aa5000)
        libusb-1.0.so.0 => /usr/lib64/libusb-1.0.so.0 (0x00007fc8e9897000)
        librt.so.1 => /lib64/librt.so.1 (0x00007fc8e968e000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fc8eabbb000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fc8e948a000)
root@localhost:~#


l'output di ls /var/log/packages | grep glibc
Codice: Seleziona tutto
root@localhost:~# ls /var/log/packages | grep glibc
glibc-2.13-x86_64-4
glibc-i18n-2.13-x86_64-4
glibc-profile-2.13-x86_64-4
glibc-solibs-2.13-x86_64-4
glibc-zoneinfo-2.13-noarch-4
root@localhost:~#


l'output di ls /var/log/packages | grep hplip
Codice: Seleziona tutto
root@localhost:~# ls /var/log/packages | grep hplip
hplip-3.11.12-x86_64-1
root@localhost:~#
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 14:35

yAri ha scritto:Hplip l'ho preso dal questo sito suggerito a qualche utente in una discussione, ma con un altro problema:

Ciò che hai postato, conferma ciò che ho detto. Quel pacchetto richiede una versione di Glibc diversa dalla tua. Probabilmente, è per current.

Ho controllato in giro. A quanto pare, sembra, che il tuo modello sia supportato da HPLIP 3.11.10+. Quindi devi aggiornare la tua versione di HPLIP.
Scarica tutto (eccetto il sorgente, da qui).

Il sorgente (in tar.gz) prendilo da qui
Compilalo dando
Codice: Seleziona tutto
# chmod a+x hplip.SlackBuild
# ./hplip.SlackBuild


E installalo con
Codice: Seleziona tutto
# upgradepkg --reinstall hplip-3.11.12-x86_64-1.txz
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 17:12

Ok. L'ho fatto. Ora l'output è questo:
Codice: Seleziona tutto
root@localhost:~# hp-toolbox
warning: hp-toolbox should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 3.11.12)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Reportlab not installed. Fax coverpages disabled.
warning: Please install version 2.0+ of Reportlab for coverpage support.
error: dBus initialization error. Exiting.
root@localhost:~#
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 17:21

Avviandolo da utente normale, hai lo stesso problema?
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 17:29

No.. ma esiste un modo per avviarlo da root?
da utente normale hp-toolbox si apre ma dovrei installare la stampante con hp-setup
quando do hp-setup e voglio installare la stampante wireless, chiede di collegarla al pc con usb. L'ho fatto ma non la trova comunque..
Codice: Seleziona tutto
root@localhost:~# hp-setup

HP Linux Imaging and Printing System (ver. 3.11.12)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching on USB bus...
error: No devices found on bus: usb

Done.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 17:42

yAri ha scritto:No.. ma esiste un modo per avviarlo da root?
da utente normale hp-toolbox si apre[/code]

Lo immaginavo.

Cosa usi per loggarti come root? "su" o "su -"? (Mi pare che una volta lessi che quel problema derivava dall'uso di su senza il "-").

Comunque,
hp-toolbox ha scritto:warning: hp-toolbox should not be run as root/superuser.
HP Toolbox va aperto da utente normale.

ma dovrei installare la stampante con hp-setup
quando do hp-setup e voglio installare la stampante wireless, chiede di collegarla al pc con usb. L'ho fatto ma non la trova comunque..

Fai parte del gruppo lp? HPLIP lo necessita.

Codice: Seleziona tutto
cat /etc/group | grep lp
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 17:43

Changes_and_hints.txt of Slackware 13.37 ha scritto:HP multifunction printer/scanners require that your user account be a member
of the "lp" group for hp-toolbox to work properly, and to use the scanner
portion of some (all?) units, you'll need to be a member of the "lp" group.
This is because hplip's udev rules set the device with group "lp" ownership.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 17:44

Codice: Seleziona tutto
root@localhost:~# cat /etc/group | grep lp
lp:x:7:lp
root@localhost:~#
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 17:48

Manca il tuo utente al gruppo lp

Codice: Seleziona tutto
# gpasswd -a <tuonomeutente> lp


Poi, sloggati e riloggati.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 18:00

Ok. La stampante quando è connessa con il cavo USB, viene riconosciuta.
Ma quando la voglio collegata tramite wireless sempre qui stiamo:
Codice: Seleziona tutto
yari@localhost:~$ hp-setup

HP Linux Imaging and Printing System (ver. 3.11.12)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching on USB bus...
error: No devices found on bus: usb
Searching on USB bus...
error: No devices found on bus: usb

Done.
yari@localhost:~$ su 
Password:
root@localhost:/home/yari# hp-setup

HP Linux Imaging and Printing System (ver. 3.11.12)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

No protocol specified
hp-setup: cannot connect to X server :0
root@localhost:/home/yari#
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 18:04

Quando ti logghi come root, usa
su -

e non il semplice "su".

Prova ad usare hp-wificonfig per la configurazione wireless.
È la utility apposita.

Se non dovesse funzionare, bisogna provvedere alla configurazione manuale.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Problema con hplip

Messaggioda yAri » gio gen 26, 2012 18:07

No.. non va..
Codice: Seleziona tutto
yari@localhost:~$ hp-wificonfig

HP Linux Imaging and Printing System (ver. 3.11.12)
Wifi Configuration Utility ver. 1.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching on USB bus...
error: No devices found on bus: usb

Done.
yari@localhost:~$ su -
Password:
root@localhost:~# hp-wificonfig
warning: hp-wificonfig should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 3.11.12)
Wifi Configuration Utility ver. 1.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

No protocol specified
hp-wificonfig: cannot connect to X server :0
root@localhost:~# exit
logout
yari@localhost:~$ hp-wificonfig

HP Linux Imaging and Printing System (ver. 3.11.12)
Wifi Configuration Utility ver. 1.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching on USB bus...
error: No devices found on bus: usb
Searching on USB bus...
error: No devices found on bus: usb
Searching on USB bus...
error: No devices found on bus: usb

Done.
yari@localhost:~$
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Problema con hplip

Messaggioda hashbang » gio gen 26, 2012 18:10

Per accedere da root, dovrebbe bastare questo
Codice: Seleziona tutto
# xhost +
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: TurnitinBot [Bot] e 3 ospiti