Repository 32bit  Forum
Repository 64bit  Wiki

Usare chiavetta usb in scrittura

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » gio feb 02, 2012 18:47

:) va bene miklos, adesso provo anche io così.
Il problema è sorto solo con la formattazione NTFS della chiavetta usb, perchè se uso invece la formattazione fat32 non si hanno questi problemi.
Allora se ho capito bene da root digito il comando
Codice: Seleziona tutto
chmod 4755 /bin/ntfs-3g
poi eseguo esco da root e da utente normale digito
Codice: Seleziona tutto
mount /mnt/chiavetta
?
Lascio invariati invece la mia regola per udev ed il file /etc/fstab ?
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » gio feb 02, 2012 19:15

Allora, ho fatto la prova con
Codice: Seleziona tutto
chmod 4755 /bin/ntfs-3g
e non è cambiato nulla.
A proposito non ho controllato prima quali erano i permessi sul /bin/ntfs-3g prima della modifica, tu sai quali erano ? Secondo me bisognerebbe fare una cosa un pò più pulita. Bisognerebbe decidere su cosa lavorare: /etc/fstab o mia regola udev ? Più che altro non vorrei che i 1 escludesse l'altro.
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda miklos » gio feb 02, 2012 19:59

arrivati a questo punto c'e' qualcosa che mi sfugge.. non capisco dove sta l'inghippo perchè

- la regola udev non fa altro che creare un link simbolico
- l'fstab in casi normali è una specie di file di configurazione per il comando mount.. ma come indicato anche nella faq che ti ho allegato non ha molta valenza con ntfs-3g riguardo al fatto che tu possa montare un device da root oppure no.. quindi nel tuo caso qualunque cosa ci scrivi in tal senso nn serve
- il mountpoint ha i permessi corretti(?) per il gruppo users

per quanto riguarda i permessi originari erano (in rappresentazione ottale) 0755 quindi per tornare come prima devi dare il comando
Codice: Seleziona tutto
chmod 0755 /bin/ntfs-3g


ma ti dà sempre lo stesso errore?!?! ovvero che user non ha accesso in scrittura al mountpoint oppure è cambiato qualcosa?

EDIT: l'unica cosa che mi viene in mente è che tu abbia cambiato i proprietari della directory /mnt/chiavetta ma non i diritti di scrittura con qualcosa tipo chmod 666 /mnt/chiavetta
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1212
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » gio feb 02, 2012 20:28

Ho fatto una ulteriore scoperta e cioè:
1) nel file /etc/fstab ho messo così:
Codice: Seleziona tutto
/dev/chiavetta1   /mnt/chiavetta   ntfs-3g    users     0  0

2) lascio la chiavetta usb inserita
3) riavvio il pc

Eseguendo da bash (in ambiente non KDE) come utente normale
Codice: Seleziona tutto
mount
mi dice che è montata /dev/chiavetta1 su /mnt/chiavetta. Bene, allora faccio
Codice: Seleziona tutto
cd /mnt/chiavetta
è mi trovo finalmente dentro la chiavetta. Eureka =D> \:D/
Ora rifaccio le stesse cose ma riavviando il pc senza la chiavetta inserita e ... risultato: solo il root può montare la chiavetta usb #-o

Quindi cosa manca nelle mie configurazioni ?
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda Vito » gio feb 02, 2012 20:50

Hai provato a fare così?
viewtopic.php?f=2&t=35312#p314313
Io avevo un tuo analogo problema (con un hard disk esterno formattato in ntfs) ed ho risolto.
Con il tool di KDE4 ora riesco a montare tranquillamente l'hard disk esterno.



Offtopic: Da quel che sono non bisognerebbe mai utilizzare ntfs su chiavette,poichè questo è un file system Journaled.
Infatti è per questo che di solito vengono formattate in fat32.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4134
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » gio feb 02, 2012 21:09

Ciao Vito, grazie per il link, lo avevo già visto qualche giorno fa. Il mio caso è un pò diverso perchè la chiavetta viene comunque vista, ma solo il root può montarla e scrivere se ho inserito la chiavetta dopo aver avviato Slackware a runlevel 3 (cioè solo testo). Se invece avvio Slackware con la chiavetta già inserita (sempre a runlevel 3, ossia non KDE), l'utente normale (non root) può usarla anche lui e pure in scrittura.
Il problema è quindi nella mia regola per udev (guarda questa discussione nella 2a pagina, dove riporto tale regola) che non effettua il mount anche per utente non root quando inserisco la chiavetta usb dopo aver caricato Slackware.

Qualcuno è esperto nelle regole di udev ?
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda miklos » ven feb 03, 2012 2:14

la tua regola per udev non fa alcun mount, ma semplicemente quando inserisci la tua chiavetta(e manco una generica, ma quella prodotta dalla jetflash) ti crea un link simbolico chiamato /dev/chiavetta.
il tuo problema è un altro.. ovvero che l'utente normale non riesce a montare un filesystem ntfs perchè non ha i permessi in scrittura sul mountpoint(quindi in teoria il mount è permesso ma la directory pare sia inaccessibile).. se la chiavetta la formati con fat32 o qualunque altra cosa.. i consigli dati da spina e 414n ti consentono di fare il mount da utente normale senza problemi
in altre parole con o senza regola il tuo problema rimane tale e quale.. tant'è vero che sinceramente nn vedo la necessita di una regola udev, visto che se spulci quelle predefinite che stanno sotto /lib/udev/rules.d (la 65-permissions.rules) vedrai che già viene fatta una cosa simile per tutti i device rimovibili.. solo che i permessi vengono assegnati al gruppo plugdev(che fra l'altro è uno dei gruppi che ho associato al mio utente regolare)
andando quindi per esclusione il problema non sta nè nella regola.. nè nell'fstab.. ma proprio nel tool ntfs-3g

quindi secondo me le strade sono due.. o riusciamo a capire cosa non piace a ntfs-3g.. oppure installi pmount(il programmino che ti ho consigliato un po' di post fa) e risolvi in modo definitivo e sicuro.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1212
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Usare chiavetta usb in scrittura

Messaggioda targzeta » ven feb 03, 2012 2:45

giorgik ha scritto:Ho fatto una ulteriore scoperta e cioè:
1) nel file /etc/fstab ho messo così:
Codice: Seleziona tutto
/dev/chiavetta1   /mnt/chiavetta   ntfs-3g    users     0  0

2) lascio la chiavetta usb inserita
3) riavvio il pc

Eseguendo da bash (in ambiente non KDE) come utente normale
Codice: Seleziona tutto
mount
mi dice che è montata /dev/chiavetta1 su /mnt/chiavetta. Bene, allora faccio
Codice: Seleziona tutto
cd /mnt/chiavetta
è mi trovo finalmente dentro la chiavetta. Eureka =D> \:D/
Ora rifaccio le stesse cose ma riavviando il pc senza la chiavetta inserita e ... risultato: solo il root può montare la chiavetta usb #-o

Quindi cosa manca nelle mie configurazioni ?
Il fatto che così funzioni è normale, dato che non gli hai detto nulla, mount ti ha montato il device all'avvio. E' vero che vedi i tuoi dati, però è anche vero che non hai la possibilità di eseguire l'umount.

Il problema è un altro. Ora però non ho troppo tempo per indagare, comunque se, come dice miklos, il problema è su ntfs-3g la cosa mi rassicura un po'. Anche se non ho ancora capito come mai la mia directory /mnt/pendrive è sempre di proprietà di root:root, però quando eseguo il mount della pennina, allora me la trovo come spina:users. Però c'è da dire che il filesystem che monto è un reaiserfs o un ext e tutti i file in quel filesystem sono miei, magari è per questo.

Ho notato che mount ha il suid settato.

Si possono usare sia 'user' che 'users' nell'fstab, comunque sono differenti. Dal man di mount:
Codice: Seleziona tutto
...
Normally, only the superuser can mount filesystems.  However, when fstab contains the user option on a line, anybody can mount the corresponding system.
...
Only the user that mounted a filesystem can unmount it again. If any user should be able to unmount, then use users instead of  user  in  the fstab line.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Usare chiavetta usb in scrittura

Messaggioda miklos » ven feb 03, 2012 2:55

io credo che la differenza fondamentale dall'usare ntfs-3g rispetto ai classici filesystem(ext3 e compagnia bella) sta nel fatto che il primo si appoggia al modulo fuse del kernel.. gli altri invece sono driver che sono parte integrante del kernel

un'altra cosa da non sottovalutare (e sinceramente non so ancora come scavalcare visto che l'ntfs lo scanso come la peste) è il fatto che se su un filesystem ntfs, che a differenza del fat32, ha lo stesso concetto di utenti e permessi dei sistemi unix, ho un file scritto dall'utente pippo sul sistema windows.. quando lo monto con l'utente pluto sul sistema linux e provo a modificarlo siamo sicuri che non faccia storie?!?!?!
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1212
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Usare chiavetta usb in scrittura

Messaggioda 414N » ven feb 03, 2012 9:43

miklos ha scritto:un'altra cosa da non sottovalutare (e sinceramente non so ancora come scavalcare visto che l'ntfs lo scanso come la peste) è il fatto che se su un filesystem ntfs, che a differenza del fat32, ha lo stesso concetto di utenti e permessi dei sistemi unix, ho un file scritto dall'utente pippo sul sistema windows.. quando lo monto con l'utente pluto sul sistema linux e provo a modificarlo siamo sicuri che non faccia storie?!?!?!

Occhio che qui ti sbagli. Le ACL Windows vengono completamente ignorate da ntfs-3g, tanto che è necessario agire con le opzioni umask, fmask ecc. quando si monta la partizione per poter modificare i permessi.
@giorgik: hai provato la regola udev che avevo linkato? Come ti avevo già scritto, ti permette il mount automatico di dispositivi ntfs tramite ntfs-3g sotto /media/ ma non ti è possibile smontare tali device se non sei root (a meno che non agisci di suid su umount come hai provato a fare su mount).
Resta il fatto che, come già suggerito da miklos, forse pmount fa al caso tuo.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Usare chiavetta usb in scrittura

Messaggioda miklos » ven feb 03, 2012 11:35

414N ha scritto:Occhio che qui ti sbagli. Le ACL Windows vengono completamente ignorate da ntfs-3g
si e no :D spulciando la documentazione ho letto che esiste pure un file di mapping che puoi indicare per associare un uid linux ad un uid windows
414N ha scritto:Resta il fatto che, come già suggerito da miklos, forse pmount fa al caso tuo.
soprattutto perchè si fa carico di tante cose, tipo la creazione del mountpoint, gli puoi indicare una label alternativa(e di conseguenza avere un mountpoint tipo /media/tua_label), non hai bisogno di definire alcuna regola fstab(quindi è ottimo per situazioni impreviste tipo 2-3 device usb collegati contemporaneamente)
insomma per me è diventato tipo "toglietemi tutto, ma non pmount :D"
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1212
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » ven feb 03, 2012 13:18

Grazie per le risposte, miklos, 414N e spina :thumbright: Mi sa che faccio prima (per il momento) ad usare pmount. In ogni caso lascio ancora aperta questa discussione perchè sarebbe interessante capire come fare usando ntfs-3g. Il motivo per cui uso ntfs e non fat32 è che così posso usare tutti gli 8 GB (mi pare che con fat32 non riesce a vederli) e che posso usarla al lavoro (quando riuscirò ad averne uno, visto che sigh sono disoccupato ora) usando ahimè Windows.
Aspetto da spina qualche sua dritta se riesce a scoprire qualche cosa. Ovviamente anche da voi miklos e 414N.
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda miklos » ven feb 03, 2012 13:52

giorgik ha scritto:Il motivo per cui uso ntfs e non fat32 è che così posso usare tutti gli 8 GB (mi pare che con fat32 non riesce a vederli) e che posso usarla al lavoro (quando riuscirò ad averne uno, visto che sigh sono disoccupato ora) usando ahimè Windows.

occhio che il fat32 pone un limite tecnico sulla dimensione del singolo file (i famosi 4gb) e non sulla dimensione della partizione..io ho harddisk da 500gb formattati con fat32..se lavori con file piu' grossi di tali dimensioni e non è un opzione perseguibile la compressione in archivi anche spezzetati.. allora l'ntfs è l'unica
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1212
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Usare chiavetta usb in scrittura

Messaggioda giorgik » ven feb 03, 2012 17:47

miklos hai ragione, mi sono accorto subito della stupidaggine che ho detto appena ho riformattato la chiavetta usb come fat32 e poi l'ho inserita e ovviamente anche da utente non root ho potuto leggere/scrivere su di essa da bash in ambiente testuale (runlevel 3) e non KDE.
A quanto pare come dicevate tutti voi il problema è di ntfs-3g che per il momento ho lasciato perdere.
giorgik
Linux 1.0
Linux 1.0
 
Messaggi: 52
Iscritto il: lun giu 21, 2010 12:40
Località: Torino
Slackware: 13.37
Kernel: 2.6.37
Desktop: KDE

Re: Usare chiavetta usb in scrittura

Messaggioda targzeta » sab feb 04, 2012 12:03

Quindi alla fine non abbiamo capito cosa c'è che non va con gli NTFS?

Con l'entry che ho postato prima non ho nessun problema a montare partizioni fat32 o ext o reiserfs. Sembra che il punto di mount non debba essere necessariamente di proprietà dell'utente che monta il filesystem:
Codice: Seleziona tutto
$> ls -ld /mnt/pendrive/
0 drwxr-xr-x 2 root root 48 apr  8  2009 /mnt/pendrive/

$> mount /mnt/pendrive

$> ls -ld /mnt/pendrive/
16K drwxr-xr-x 2 spina users 16K gen  1  1970 /mnt/pendrive/
più che altro, ovviamente, l'importante è che l'utente abbia i diritti di lettura/scrittura nel filesystem montato. Nessun problema di sorta con i filesystem FAT, i problemi magari possono sorgere con quelli, passatemi il termine, "unixiani".

Come ho detto prima, mount ha il suid attivo, quindi lui può gestire tutto con i diritti di root. In particolare, l'opzione 'users' invece che 'user' nell'fstab potrebbe essere utile per far si che udev monti automaticamente la partizione secondo una sua regola interna ed in contemporanea lasciare la possibilità a chiunque di "smontarla".

Se però, come ha detto miklos, il mount con un filesystem di tipo ntfs è semplicemente un wrapper per il programma ntfs-3g, allora il problema dovrebbe stare proprio in quel programma.

Detto questo, alla fine l'importante è che tu abbia risolto il tuo problema :),
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6168
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

PrecedenteProssimo

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron