Repository 32bit  Forum
Repository 64bit  Wiki

installazione 13.37 cfdisk non scrive la partizione

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » gio feb 02, 2012 19:50

Un saluto a tutti. Premetto che non sono un esperto, anche se sono un paio di anni che uso ubuntu. Oggi avevo deciso di installare slackware 13.37, ma arrivato al partizionamento del disco, dopo aver preparato le partizioni, al momento della scrittura "yes or no" digitando "yes" non succede niente, cioè non scrive.
Nella macchina ho due dischi: uno da 120 GB con installato XP, e unaltro da 500. All'avvio del cd di slackware cfdisk entrava in quello da 120 con XP, quindi mi sono spostato con "cfdisk /dev/sdb1" in quello da 500. Il disco è SATA.
C'è qualcuno che sappia dirmi dove è il problema?
Grazie
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » ven feb 03, 2012 13:03

lenzetta2 ha scritto:ma arrivato al partizionamento del disco, dopo aver preparato le partizioni, al momento della scrittura "yes or no" digitando "yes" non succede niente, cioè non scrive.
Se non scrive, avrà dato un output di errore. Giusto? Se si, qual è?
Se dai
Codice: Seleziona tutto
fdisk -l /dev/sdb
trovi le partizioni che hai creato?

mi sono spostato con "cfdisk /dev/sdb1" in quello da 500. Il disco è SATA.
/dev/sdb1 è una partizione, non un disco.
Se vuoi usare cfdisk sul disco SATA, dovresti dare cfdisk /dev/sdb.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » ven feb 03, 2012 14:34

Hai ragione, scusa. Effettivamte ieri notte, provando ad installarlo piu volte, ho ripartizionato il disco da 500 in 2000 swap /dev/sdb5 e il resto ext4 /dev/sdb2.
Ho proseguito l'installazione; ho caricato lilo ma niente dafare; ho provato ha configurarlo, neanche così. Ho tentato di istallare lilo non nell'mbr ma in root, quindi /dev/sdb2, credo, ...niente. Al riavvio l'errore è sempre lo stesso: non trova il device n. una sfilza di lettere e numeri, e sotto: grub rescue>
Scusa il ritardo nella risposta ma ho degli orari un po' incasinati.
Io credo che il problema sia nell'istallazione di lilo: non lo mette nell'hd da 500. Può essere?
ciao
P.S. Non ci si crede... mentre scrivevo ho cercato di installarlo per l'ennesima volta... e questa volta è andata! Il problema è che non ho istallato nessun programma tanto ero sicuro di non farcela per la centesima volta.
Piu tardi lo provo, e non è detto che non sia costretto a scrivere un'altro post... anzi, è sicuro.
Comunque grazie per avermi risposto.
ciao
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » ven feb 03, 2012 15:01

lenzetta2 ha scritto:Hai ragione, scusa. Effettivamte ieri notte, provando ad installarlo piu volte, ho ripartizionato il disco da 500 in 2000 swap /dev/sdb5 e il resto ext4 /dev/sdb2.
Ho proseguito l'installazione; ho caricato lilo ma niente dafare; ho provato ha configurarlo, neanche così. Ho tentato di istallare lilo non nell'mbr ma in root, quindi /dev/sdb2, credo, ...niente. Al riavvio l'errore è sempre lo stesso: non trova il device n. una sfilza di lettere e numeri, e sotto: grub rescue>
Perdonami...hai installato LILO e al boot entri nella console di emergenza di GRUB? :shock:
Scusa la domanda, ma è necessaria: quanti bootloader hai installato?
Se hai già GRUB, non c'è bisogno di usare LILO (e viceversa). Ti basta inserire l'entry di Slackware ed è fatta.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » ven feb 03, 2012 19:40

Ciao atomix, come avevo predetto sono di nuovo qui. Allora, durante il setup, a un certo punto, c'è la schermata con tre opzioni dove istallare lilo; diopo aver provato a installarlo nell'mbr senza successo, ho provato ad installarlo in root, la opzione in alto, che dovrebbe essere la mia root, credo. Per quanto riguarda grub rescue...anch'io non ci ho capito niente dato che sapevo che slackware usa ancora lilo. Per questo ho anche pensato che mi avesse installato lilo nell'altro disco, quello con window per intenderci, però l'errore all'avvio era quello: "grub rescue>".
Ora sono riuscito a installarlo, e seguendo la stessa guida iniziale, proprio quella che prima non funzionava(sic), e ho installato lilo nell'mbr.
Tutto perfetto....senonche in kde > configurazioni > localizzazione ho trovato solamente: "lingua e paese" e "correttore ortografico", quindi non ho potuto configurare la tastiera. E poi kde mi sembra un tantino lento se teniamo di conto che l'istallazione è stata fatta in un desktop, non nuovissimo però....
Poi ho provato ad entrare in windows, ma quello che mi da è il recovery system, che poi appena appare la schermata celeste si riavvia.
Si può riconfigurare la tastiera tramite terminale, immagino, ma resta il problema che non riesco ad entrare in windows.
Qualche idea in proposito? Ah, ricordo che ho seguito la guida, passo passo, di megalab, in rete.
ciao
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » ven feb 03, 2012 22:39

lenzetta2 ha scritto:Tutto perfetto....senonche in kde > configurazioni > localizzazione ho trovato solamente: "lingua e paese" e "correttore ortografico", quindi non ho potuto configurare la tastiera.
Non uso KDE, quindi, per la sua configurazione, ti risponderà chi ne saprà di più.

E poi kde mi sembra un tantino lento se teniamo di conto che l'istallazione è stata fatta in un desktop, non nuovissimo però....
KDE richiede un computer moderno per girare decentemente. Se hai un desktop non più nuovissimo puoi comunque usare XFCE o gli altri Window Manager messi a disposizione dal DVD.
Sul nostro repository (e in giro per la rete), comunque, troverai anche altre GUI (come AfterStep ed e16) che potrai installare.

Poi ho provato ad entrare in windows, ma quello che mi da è il recovery system, che poi appena appare la schermata celeste si riavvia.
A questo punto dovresti postare il file /etc/lilo.conf per capire come il bootloader gestisce la partizione di Windows.

Si può riconfigurare la tastiera tramite terminale,
Se stai in una sessione grafica, la tastiera la puoi settare via terminale con
Codice: Seleziona tutto
setxkbmap it
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » sab feb 04, 2012 18:17

Ciao atomix, ecco le ultime novità: dopo una estenuante ricerca in rete sono riuscito a risolvere il problema della mappatura: la configurazione della suddetta non
si trova più in "localizzazione" bensì in "dispositivi di immissione"; per quanto riguarda la lentezza, istallando il s.o. ho usato il vesa, e probabilmente è questo il problema. In attesa di trovare un driver adatto ho disattivato gli effetti del desktop.
Ora sono alle prese con altri problemi, inevitabili per un principiante, temo. Prima di tutto devo dire che ho installato slackware in un portatile un po' datato. Ho usato tutto l'hd. In questo momento mi trovo alle prese con: il drive della scheda wireless è un bcmxx la quale mi ha dato problemi anche con le vecchie distro di ubuntu. Ho risolto per il momento con una penna sitecom caricando i moduli ralink; ho copiato la directory slackware con i pacchetti nella /root, però ancora non ho capito come aggiungere altri programmi alla medesima (i files .txz in genere sono più di uno, quale dovrei prendere?); il mouse è un touchpad, pero non permette lo scorrimento delle pagine. Probabilmente è una questione di drivers, ma quali?
Per il momento vorrei trovare una interfaccia grafica, come wicd per esempio, per poter connettermi alla rete. Ho provato a installarlo ma non funziona.
Ti allego il file lilo.conf
Ancora una cosa: ho letto da qualche parte che pkgtoll non installa le dipendenze... è vero?
Ciao atomix, e grazie
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » sab feb 04, 2012 19:29

Ti rispondo lo stesso stavolta (visto che sei nuovo), però queste richieste sono Off Topic. È meglio aprire topic appositi. Qui limitiamoci a parlare del problema in questione.

lenzetta2 ha scritto:In attesa di trovare un driver adatto ho disattivato gli effetti del desktop.
Se hai una scheda video nvidia, potresti usare o i nouveau o i proprietari. Se usi delle vecchie radeon dovresti poter usare i driver open senza problemi (io prima avevo una Radeon 9200 e andavo di driver open source). Per le nuove radeon, ci dovrebbero essere i driver proprietari.

Prima di tutto devo dire che ho installato slackware in un portatile un po' datato. Ho usato tutto l'hd.
Io usavo Slackware su un PC di dieci anni fa. Non ho mai avuto problemi.

Per quanto riguarda l'hd pieno, probabilmente deriva dal fatto che hai scelto l'installazione completa. Rimuovi i pacchetti che non ti servono, così eliminerai spazio su disco.

In questo momento mi trovo alle prese con: il drive della scheda wireless è un bcmxx la quale mi ha dato problemi anche con le vecchie distro di ubuntu.
Qui è meglio che apri un topic nuovo.

ho copiato la directory slackware con i pacchetti nella /root, però ancora non ho capito come aggiungere altri programmi alla medesima (i files .txz in genere sono più di uno, quale dovrei prendere?);
Codice: Seleziona tutto
installpkg nomepacchetto.txz


il mouse è un touchpad, pero non permette lo scorrimento delle pagine. Probabilmente è una questione di drivers, ma quali?
Xorg dovrebbe gestire i touchpad con xf86-input-synaptic e Linux dovrebbe avere built-in il supporto.
Credo che sia una questione di configurazione, più che di driver.
Comunque anche qui, è meglio un topic apposito.

Per il momento vorrei trovare una interfaccia grafica, come wicd per esempio, per poter connettermi alla rete. Ho provato a installarlo ma non funziona.
Anche qui, topic nuovo.

Ancora una cosa: ho letto da qualche parte che pkgtoll non installa le dipendenze... è vero?
Si. Gli script del pkgtools non gestiscono le dipendenze.
Quindi se il pacchetto X ha dipendenze W,Y e Z, installpkg installerà solo il pacchetto scelto (in questo caso X).
Ci sono comunque delle utility apposite (slapt-get che unisce una sintassi APT-like con il pkgtools e slackyd, scritto e mantenuto qui su Slacky.eu) che gestiscono automaticamente le dipendenze.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » sab feb 04, 2012 23:10

Quando ho scritto: "ho usato tutto l'hd" era per farti capire che non è in dual boot.
Ritornando al vecchio problema, che mi dici del file lilo.conf che ho allegato? il boot= è su hda, che dovrebbe essere il disco, quindi dovrei cambiarlo con hda1 o 2 o 3, visto che le partizioni sono 3: recovery, fat e il sistema.
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » dom feb 05, 2012 14:57

Ritornando al vecchio problema, che mi dici del file lilo.conf che ho allegato?
Beh, non dico niente visto che non vedo nessun lilo.conf allegato.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » dom feb 05, 2012 16:47

Non so come fare; qui mi dice che 'l'estensione non è permessa, mentre io l'ho tolta, rinominandolo semplicemente lilo
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » dom feb 05, 2012 17:09

Codice: Seleziona tutto
$ cat /etc/lilo.conf > ~/lilo.conf
$ gzip ~/lilo.conf


Inserisci come allegato il file lilo.conf.gz creato.

Oppure copia il contenuto del file nel topic mettendolo tra i tag code
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda targzeta » dom feb 05, 2012 17:16

Offtopic:
atomix600 ha scritto:
Codice: Seleziona tutto
$ cat /etc/lilo.conf > ~/lilo.conf
$ gzip ~/lilo.conf


Inserisci come allegato il file lilo.conf.gz creato.
Scusate se mi intrometto, se parlate di allegarlo qui sul forum, anche i file .txt dovrebbero essere ammessi da quel che ricordo. Quindi potrebbe semplicemente copiare il file come .txt senza zipparlo. Oppure potrebbe anche usare i tag 'code' per postare l'output del comando:
Codice: Seleziona tutto
grep -v '^ *#' /etc/lilo.conf | uniq
così è anche più facile da leggere.

Emanuele

:edit: Ho aggiunto anche l'estensione .conf tra quelle permesse. Ora dovrebbe essere in grado anche di allegare direttamente il lilo.conf
.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda lenzetta2 » lun feb 06, 2012 16:40

Ne ho allegati 2, speriamo che vada bene.
Comunque nel frattempo è accaduto qualcosa di ben più grave, temo; con il portatile cercavo di collegarmi tramite la scheda wireless, senonché a un certo punto
ha smesso di andare anche via cavo, dopo un bel po' di smanettamenti ho deciso di reinstallare il sistema. Ho reinserito il disco di installazione e con cfdisk
ho provato a ricreare le partizioni. La prima volta che ho cercato di andare con cfdisk su /dev/sda, mi ha risposto che non avevo i permessi; poi su sda1 ho ricreato la partizione, che è andata a buon fine, ma il nome non è più sda1 ma sda1p1. Come posso riformattare tutto l'hardisk e riavere il più tranquillizzante nome di prima?

ancora una cosa, mi sono accorto in questo momento che dopo aver scritto la partizione il sistema riporta questo messaggio:
Wrote partition table, but re-resd table faild. Rebbot to update table.
Toggle bootable flag of the current partition
Allegati
~lilo.conf
(2.07 KiB) Scaricato 7 volte
lilo.conf.txt
(2.07 KiB) Scaricato 13 volte
lenzetta2
Linux 1.0
Linux 1.0
 
Messaggi: 36
Iscritto il: gio feb 02, 2012 18:30
Nome Cognome: antonio flamini
Slackware: 13.37

Re: installazione 13.37 cfdisk non scrive la partizione

Messaggioda hashbang » lun feb 06, 2012 20:20

lenzetta2 ha scritto:ho provato a ricreare le partizioni. La prima volta che ho cercato di andare con cfdisk su /dev/sda, mi ha risposto che non avevo i permessi; poi su sda1 ho ricreato la partizione, che è andata a buon fine, ma il nome non è più sda1 ma sda1p1.
Non ho capito bene.
In che modo hai ricreato la partizione su /dev/sda1?

Come posso riformattare tutto l'hardisk e riavere il più tranquillizzante nome di prima?
Puoi avviare cfdisk ignorando la tabella esistente
con
Codice: Seleziona tutto
cfdisk -z /dev/sda
e poi formattando le partizioni create.

ancora una cosa, mi sono accorto in questo momento che dopo aver scritto la partizione il sistema riporta questo messaggio:
Wrote partition table, but re-resd table faild. Rebbot to update table.
Quel messaggio indica che nonostante abbia scritto la tabella delle partizioni, non ha potuto effettuarne la rilettura "al volo". Ti invita comunque al riavvio, per ottenere lo stesso risultato.

Comunque, non dovrebbe essere niente di grave.

Per quanto riguarda LILO
Codice: Seleziona tutto
# Windows bootable partition config begins
other = /dev/sda2
  label = Windows
  table = /dev/sda2


La sezione table deve contenere /dev/sda, non /dev/sda2.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1830
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti