Repository 32bit  Forum
Repository 64bit  Wiki

Problema con le plib

Forum dedicato alla programmazione.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il linguaggio di programmazione usato.
2) Se possibile portare un esempio del risultato atteso.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema con le plib

Messaggioda RedSkull92 » sab feb 11, 2012 0:08

Ho installato le plib scaricando il pacchetto da slacky.eu

Ho realizzato un primo programmino
Codice: Seleziona tutto
#include <stdio.h>
#include <plib/js.h>
int main()
{
    jsJoystick *js[2];
    jsInit();
   
    js[0]= new jsJoystick(0);

    printf("Nome: %s\n",js[0]->getName());
    return 0;
}


e provo a compilarlo con :
$[~]--> g++ prova.cxx -o prova
/tmp/ccYcBGZY.o: In function `main':
prova.cxx:(.text+0xc): undefined reference to `jsInit()'
prova.cxx:(.text+0x2a): undefined reference to `jsJoystick::jsJoystick(int)'
collect2: ld returned 1 exit status

Ma come potete notare mi restituisce un errore.

Ho scaricato i sorgenti contenente gli esempi di plib e dando "make" i file vengono tutti compilati e resi funzionanti, però io dal Makefile non riesco a capire quali parametri passare a g++ (o gcc) Potreste darmi una mano oppure consigliarmi una libreria che mi permetta di ricavare le coordinate degli analogici di un joystick ?
Grazie.
Ah, questo è il Makefile dei file di esempio: http://sprunge.us/QDGK
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Problema con le plib

Messaggioda 414N » dom feb 12, 2012 10:47

L'errore è stato generato da ld, quindi è un errore in fase di linking.
Ti sei dimenticato di specificare a mano la libreria alla quale il codice deve collegarsi, che, in questo caso, presumo debba essere libjs.
Dovresti risolvere aggiungendo
Codice: Seleziona tutto
-ljs

alla riga di g++.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti