Repository 32bit  Forum
Repository 64bit  Wiki

Scheda ethernet NON rilevata.

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Scheda ethernet NON rilevata.

Messaggioda zoros » dom feb 12, 2012 12:58

yAri ha scritto:Non credo di essermi dimenticato l'ultima riga .. è cosi l'lspci.

ok yAri, può essere così ;) ...

posso dire che in almeno 2 occasioni ho notato un blocco della eth con rc.wicd attivo e sistema di rete pienamente configurato in rc.inet1.conf ... il blocco era talmente "reale" da dover riavviare il pc, inutili tutti i tentativi software di riavviare la rete ... può essere un qualcosa di simile a quanto accade a te ...

ti consiglio comunque di eliminare il persistent-net:
Codice: Seleziona tutto
# rm /etc/udev/rules.d/70-persistent-net.rules

e annullare tutte le voci in rc.inet1.conf ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » lun feb 13, 2012 7:51

ho rc.inet1.conf nullo e ho dato il comando suggerito.
Nulla da fare bisogna sempre e comunque partire con il cavo ethernet inserito per far apparire la scheda ethernet.. da macchina avviata impossibile trovarla.

p.s. annullando la configurazione rc.inet1.conf ora l'interfaccia wifi è eth0 e quella wired eth1
grazie per il vostro aiuto.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda rik70 » lun feb 13, 2012 10:26

Uhm.... ma non è che tutto questo è causato da wicd?

Prova a guardare il manuale di wicd, in particolare:

Codice: Seleziona tutto
man wicd-manager-settings.conf


Ci sono alcune voci che riguardano il modo con cui viene gestita la rete "cablata".

Ad esempio, guarda questa voce:
prefer_wired = <True|False>
True = Switch to wired interface if a link is detected, even if
already connected to wireless
False = Do not switch to wired interface automatically


Oppure, guarda questa:
always_show_wired_interface = <True|False>

A che serve? Nessun commento nel manuale.

Su wicd ne so quanto voi e non posso aiutare.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1276
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Scheda ethernet NON rilevata.

Messaggioda targzeta » lun feb 13, 2012 10:40

Io non uso wicd, ma non si potrebbe fare una prova disabilitandolo? Così almeno sappiamo se è lui che si mangia la scheda ethernet.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6194
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » lun feb 13, 2012 13:48

potrei provarci ma ditemi come..
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda murdock » lun feb 13, 2012 15:00

spina ha scritto:Io invece non riesco a capire come possa scomparire un device dalla lista elencata da lspci.
Emanuele


Porse perché è una scheda ibrida?
[ 16.638814] eth0: Broadcom BCM432b 802.11 Hybrid Wireless Controller 5.100.82.112


Anche io non me la spiego.

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 452
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.16,3
Desktop: KDE 4.14,1

Re: Scheda ethernet NON rilevata.

Messaggioda erio » lun feb 13, 2012 15:14

wicd se usa il wireless disabilita la ethernet e il contrario,in automatico,prova a connettere il cavo cat e scegli dal menu di wicd il device se te lo mostra
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Scheda ethernet NON rilevata.

Messaggioda erio » lun feb 13, 2012 15:28

http://www.broadcom.com/docs/linux_sta/ ... 112.tar.gz mi sa che devi compilare questi per la tua scheda,il pacchetto da dove l'hai preso?
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Scheda ethernet NON rilevata.

Messaggioda yAri » lun feb 13, 2012 17:19

erio ha scritto:http://www.broadcom.com/docs/linux_sta/hybrid-portsrc_x86_32-v5_100_82_112.tar.gz mi sa che devi compilare questi per la tua scheda,il pacchetto da dove l'hai preso?

Da qui.
.. be the change you want to see in the world ..
Avatar utente
yAri
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: dom ott 31, 2010 13:16
Nome Cognome: Yari Hembik
Slackware: 14.1
Kernel: 2.6
Desktop: KDE

Re: Scheda ethernet NON rilevata.

Messaggioda rik70 » lun feb 13, 2012 18:35

Guarda, il modo + semplice per fare una prova senza wicd è disinstallare il pacchetto. Altrimenti devi cambiare permessi e spostare alcuni file che ti romperanno sicuramente. Fatti un backup della directory /etc/wicd - così non perdi eventuali impostazioni personalizzate - rimuovi il pacchetto wicd, elimina il file /etc/udev/rules.d/70-persistent-net.rules (che verrà ricreato poi da udev) e riavvia la macchina.

Occhio che dopo il reboot molto probabilmente sarai senza connessione.

Puoi connettere al volo l'interfaccia "wired" con:
Codice: Seleziona tutto
root# dhclient ethX
dove ethX è l'interfaccia di rete cablata.

Poi vedi un pò cosa è cambiato con:
Codice: Seleziona tutto
ifconfig -a 

cat /etc/udev/rules.d/70-persistent-net.rules

lspci


Il tutto a tuo rischio e pericolo.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1276
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Scheda ethernet NON rilevata.

Messaggioda erio » lun feb 13, 2012 19:56

ricordo ancestrale, ma pppoe-setup non funziona piu' in slackware
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1086
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Scheda ethernet NON rilevata.

Messaggioda lablinux » mar feb 14, 2012 10:21

Se collego il cavo dopo l'avvio del pc, devo aprire wicd (iconcina nella barra) e connettermi manulamente alla rete.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 764
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot], Yahoo [Bot] e 3 ospiti