Repository 32bit  Forum
Repository 64bit  Wiki

FreeBSD e NVIDIA GeForce GT 525M

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

FreeBSD e NVIDIA GeForce GT 525M

Messaggioda Xunyl » lun feb 20, 2012 16:39

Possiedo un DELL Inspiron 17r http://www.dell.com/it/p/inspiron-17r-n7110/pd.aspx?c=it&cs=itdhs1&l=it&s=dhs&~ck=mn&ST=dell%20inspiron%2017R&dgc=ST&cid=41225&lid=1069586&acd=12476123854205618 con processore i5, scheda video NVIDIA GeForce GT 525M più una scheda integrata intel HD 3000. Ho installato con successo FreeBSD 9.0 (64 bit) ma Xorg non riesce ad avviare X se non con i driver vesa. Ho installato i driver proprietari NVIDIA prima dai ports e successivamente ho provato anche con quelli presi dal sito NVIDIA, X non si avvia in entrambi i casi (a volte il sistema fa un brutale reboot dopo lo "startx"). Ho provato anche ad utilizzare la scheda INTEL anziché la NVIDIA ma va solo con i driver vesa.

xorg.conf generato con "Xorg -configure":
Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/local/lib/xorg/modules"
   FontPath     "/usr/local/lib/X11/fonts/misc/"
   FontPath     "/usr/local/lib/X11/fonts/TTF/"
   FontPath     "/usr/local/lib/X11/fonts/OTF"
   FontPath     "/usr/local/lib/X11/fonts/Type1/"
   FontPath     "/usr/local/lib/X11/fonts/100dpi/"
   FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
   Load  "extmod"
   Load  "record"
   Load  "dbe"
   Load  "glx"
   Load  "dri"
   Load  "dri2"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/sysmouse"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Monitor"
   Identifier   "Monitor1"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "HWcursor"              # [<bool>]
        #Option     "NoAccel"               # [<bool>]
        #Option     "ShadowFB"              # [<bool>]
        #Option     "UseFBDev"              # [<bool>]
        #Option     "Rotate"                # [<str>]
        #Option     "VideoKey"              # <i>
        #Option     "FlatPanel"             # [<bool>]
        #Option     "FPDither"              # [<bool>]
        #Option     "CrtcNumber"            # <i>
        #Option     "FPScale"               # [<bool>]
        #Option     "FPTweak"               # <i>
        #Option     "DualHead"              # [<bool>]
   Identifier  "Card0"
   Driver      "nv"
   VendorName  "NVIDIA Corporation"
   BoardName   "GF108 [GeForce GT 540M]"
   BusID       "PCI:1:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
   Identifier  "Card1"
   Driver      "vesa"
   VendorName  "Intel Corporation"
   BoardName   "2nd Generation Core Processor Family Integrated Graphics Controller"
   BusID       "PCI:0:2:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes   "1280x1024"
   EndSubSection
EndSection

Section "Screen"
   Identifier "Screen1"
   Device     "Card1"
   Monitor    "Monitor1"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     24
      Modes   "1280x1024"
   EndSubSection
EndSection

xorg.conf generato con nvidia-xconfig:
Codice: Seleziona tutto
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.20  (buildmeister@swio-display-x86-rhel47-08.nvidia.com)  Mon Feb  6 21:34:27 PST 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
EndSection

Section "Module"
        Load  "extmod"
        Load  "record"
        Load  "dbe"
        Load  "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
   Modes      "1280x1024"
    EndSubSection
EndSection

Purtroppo non mi è possibile postare il log di Xorg in quanto il sistema si riavvia bruscamente dopo lo "startx".
Attendo lumi :)

Grazie, Xunyl
Xunyl
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: gio gen 28, 2010 15:57
Slackware: 14 - 64 bit
Kernel: 3.6.2
Desktop: openbox

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda erio » lun feb 20, 2012 17:19

non sono sicuro,ma hai un sistema a doppio chip grafico,dai uno sguardo al tread su bumblebee,che sicuramente trovi degli spunti utili a risolvere.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1065
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda hashbang » lun feb 20, 2012 17:21

Hai scritto che in certi casi ottieni un reboot forzato. Negli altri casi? Ottieni output di qualche tipo?
Inoltre, non ho capito bene. ma il file /var/log/Xorg.0.log, non viene proprio generato?


EDIT: Qui sembra che ci sia un problema simile al tuo.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1823
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda erio » lun feb 20, 2012 18:57

scusa atomix600:

Identifier "Card0"
Driver "nv"
VendorName "NVIDIA Corporation"
BoardName "GF108 [GeForce GT 540M]"
BusID "PCI:1:0:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
#Option "ModeSetClearScreen" # [<bool>]
Identifier "Card1"
Driver "vesa"
VendorName "Intel Corporation"
BoardName "2nd Generation Core Processor Family Integrated Graphics Controller"
BusID "PCI:0:2:0"
EndSection
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1065
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda Xunyl » lun feb 20, 2012 20:06

Dunque, andiamo con ordine:
bumblebee su FreeBSD non è supportato, almeno non so se i binari per linux vanno anche su BSD.
Il reboot forzato lo ottengo quando utilizzo la configurazione di Xorg per i driver NVIDIA.
Il file di log viene generato ma dato che reboota bruscamente non fa in tempo a memorizzarlo sull'hard disk e quindi al successivo riavvio c'è il log vecchio, quello della configurazione di Xorg -configure.
Ho seguito tutti i consigli di questo post http://forums.freebsd.org/archive/index.php/t-3065.html ma non è servito a risolvere.

Grazie per le risposte! Attendo altri suggerimenti :)
Xunyl
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: gio gen 28, 2010 15:57
Slackware: 14 - 64 bit
Kernel: 3.6.2
Desktop: openbox

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda Xunyl » sab feb 25, 2012 14:25

up!
Almeno riuscire a far funzionare una delle 2 schede... anche con i driver liberi, sono con i vesa :cry:
Xunyl
Linux 2.0
Linux 2.0
 
Messaggi: 156
Iscritto il: gio gen 28, 2010 15:57
Slackware: 14 - 64 bit
Kernel: 3.6.2
Desktop: openbox

Re: FreeBSD e NVIDIA GeForce GT 525M

Messaggioda B@Rz » dom mag 06, 2012 15:28

Scusa per la risposta un po' in ritardo, ma ecco qualche link che potrebbe fare al caso tuo:
http://forums.freebsd.org/showthread.php?t=27502
http://wiki.freebsd.org/Intel_GPU
Per motivi di tempo non ho ancora avuto l'occasione di dedicarmici accuratamente.
Avatar utente
B@Rz
Linux 1.0
Linux 1.0
 
Messaggi: 11
Iscritto il: ven lug 01, 2011 18:02
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE 4.7


Torna a Libera

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite