Repository 32bit  Forum
Repository 64bit  Wiki

Insolita attività disco

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Insolita attività disco

Messaggioda Eberoth » mar feb 14, 2012 15:09

Innanzitutto spero di aver azzeccato titolo e sezione, se così non fosse, modificate pure.
Detto questo,
Da qualche mese ho notato un comportamento insolito da parte del sistema: circa un paio di volte al secondo si accende il led che segnala attività del disco e, quando lavoro di notte, riesco chiaramente a sentire il rumore del HDD in funzione.
Non ho postato prima perché comunque il sistema funziona ed avevo cose più pressanti di cui occuparmi, ma adesso che ho un po' di tempo ammetto di cominciare a preoccuparmi.
Sto usando SalixOS64 13.37 con Xfce 4.8 di rworkman (ho dovuto aggiornare glibc e compagnia ovviamente) con tema oxygen-gtk e kernel 3.2.5 (ma anche col 3.1.1 avevo lo stesso problema).
Oltre a xfce ed un paio di suoi plugin, ho attivi wbar, conky e wicd.

Tra l'altro, non so se le due cose siano collegate o meno, ma una volta fatto il login, quando apro per la prima volta una directory con thunar questo impiega diversi secondi ad eseguire il comando, ed alla fine mi restuisce un messaggio di errore (che ora non ricordo ma posso replicare facilmente), ed una o due finestre con la directory aperta. Negli usi successivi, invece, faccio appena in tempo a cliccare che compare la finestra, senza nessun problema.

Sinceramente non ho nemmeno idea di dove cominciare per cercare il colpevole, quindi se vi serve qualche file di configurazione o l'output di qualche comando chiedete pure.

Vi ringrazio in anticipo per l'aiuto.

[edit]
modificato titolo
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Insolita attività disco

Messaggioda Eberoth » dom feb 19, 2012 12:23

Scusate, ma faccio un piccolo up. Spero che qualcuno risponda.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Insolita attività disco

Messaggioda 414N » dom feb 19, 2012 18:26

Potresti provare ad usare iotop per visualizzare i processi che agiscono su disco in una maniera simile a top, in maniera da poter individuare il colpevole del traffico anomalo su disco.
Ne trovi lo SlackBuild su SBo. Sappi che funziona anche con l'ultima versione disponibile, la 0.4.4.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Insolita attività disco

Messaggioda Eberoth » dom feb 19, 2012 22:17

Grazie,
ho scaricato il tutto, domani faccio il pacchetto e lo provo...spero di risolvere!!
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Insolita attività disco

Messaggioda Eberoth » lun feb 20, 2012 15:45

Ok,
Ho installato iotop ed ho tenuto il pc sotto osservazione per diversi minuti.
Tuttavia, benché il led continui regolarmente ad accendersi una o due vole al secondo, iotop non registra nessuna attività degna di nota.
Devo preoccuparmi?
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Insolita attività disco

Messaggioda rik70 » lun feb 20, 2012 16:13

Ma il led si accende e rimane fisso per un pò, oppure "pulsa" ogni tot secondi?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Insolita attività disco

Messaggioda Eberoth » lun feb 20, 2012 19:47

pulsa una o due volte al secondo.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Insolita attività disco

Messaggioda rik70 » mar feb 21, 2012 9:07

Anche sul mio PC - con controller IDE Intel - il led hdd fa dei piccoli 'lampi' appena percettibili ogni 1-2 secondi. Penso sia normale, ma non si sente nessuna attività disco. Se tu però noti degli errori o comportamenti strani che ti fanno pensare a problemi al disco, prova innanzitutto a fare un controllo con smartctl.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Insolita attività disco

Messaggioda Eberoth » mer feb 22, 2012 0:37

i controlli con smartctl li ho fatti ed il disco non presenta errori...
Sinceramente non ho riscontrato errori, ma quel pulsare continuo mi da un po' noia: odio non sapere cosa combina il mio pc.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti