Repository 32bit  Forum
Repository 64bit  Wiki

Forum in HTTPS [reply]

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Forum in HTTPS [reply]

Messaggioda zoros » lun mar 05, 2012 19:14

scusate gente,
anche se tecnicamente interessante l'https, ho l'impressione che creerà un sacco di problemi alla leggibilità del forum ... in particolare, specie per chi passerà di qui via IE (spero pochi), si avranno spesso warning (più o meno preoccupanti) sul mix di contenuti protetti/non protetti delle pagine ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Forum in HTTPS [reply]

Messaggioda targzeta » lun mar 05, 2012 19:16

zoros ha scritto:scusate gente,
anche se tecnicamente interessante l'https, ho l'impressione che creerà un sacco di problemi alla leggibilità del forum ... in particolare, specie per chi passerà di qui via IE (spero pochi), si avranno spesso warning (più o meno preoccupanti) sul mix di contenuti protetti/non protetti delle pagine ...

Beh Fabio, sei rimasto un po' indietro. Ora abbiamo entrambi i protocolli e quindi non ci dovrebbe essere nessun problema di sorta. Se vuoi usare https ci metti un https davanti, altrimenti visiti il forum come http. Oppure mi sono perso qualcosa io per strada?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Forum in HTTPS [reply]

Messaggioda targzeta » lun mar 05, 2012 19:30

Comunque sia, per statistiche, ci sono stati 425 diversi accessi alle pagine https...quindi qualcuno lo usa :)

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Forum in HTTPS [reply]

Messaggioda ZeroUno » lun mar 05, 2012 19:43

Il problema citato da zoros riguarda il fatto che se da una pagina https clicchi su un link allo stesso sito NON in https, allora IE ti da un warning che ti avverte che stai prendendo delle risorse non protette mentre poco fa eri su risorse protette.
Per esempio, uno a caso:
se io sto navigando sul topic:
h_t_t_p_s://www.slacky.eu/forum/viewtopic.php?f=51&t=35228&start=30#p316062
ci trovi "(v. anche l'altro topic)" in cui "altro topic" è un link a
h_t_t_p://www.slacky.eu/forum/viewtopic.php?p=315865

ecco che si passa da https a http.
ovviamente non stiamo usando alcuna estensione.

p.s.: il link "Forum" in alto alto alto alla pagina punta a http anche se stai navigando in https. sarebbe opportuno un link relativo.

Per quanto riguarda i 425 accessi, bisognerebbe controllare quanti di questi siano test dei presenti :-)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4411
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Forum in HTTPS [reply]

Messaggioda targzeta » lun mar 05, 2012 23:14

Ah ok, però ammetterai che è un problema (come al solito) di IE più che nostro. Perché mai dovremmo mettere tutte le pagina in https? Il repository, ad esempio, non ha proprio senso metterlo in https dato che comunque comporta un overhead. Così come tutto il resto, io lascerei solo il forum con questo doppio protocollo, insieme a poche altre pagine "sensibili".

Emanuele

P.S. Per i 425 gli accessi. Dobbiamo anche tener conto che per un po' di tempo il sito è stato solo in https :). Ma mi stavi suggerendo qualcosa? :D
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Forum in HTTPS [reply]

Messaggioda zoros » lun mar 05, 2012 23:24

ZeroUno ha scritto:
zoros ha scritto:Offtopic: questo


ecco là che cominciano i problemi http/https
...

il problema era già stato segnalato all'inizio da ZeroUno, partendo da un mio post-reply ... per me è molto fastidioso, ma non ci ho dato importanza al momento ... poi, ripensandoci, mi misuro ogni giorno con quel problema ed è in effetti fastidioso ... e per fortuna qui non si usano gadgets o iframe :? ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Forum in HTTPS [reply]

Messaggioda ZeroUno » mar mar 06, 2012 8:58

spina ha scritto:Ah ok, però ammetterai che è un problema (come al solito) di IE più che nostro.

Aimé, io credo che dovremmo pensare anche a loro.
Personalmente leggo il forum da svariati pc (anche non miei) e svariati browser; e in slacky ho visto scrivere anche chi non ha mai usato linux in vita sua.

Perché mai dovremmo mettere tutte le pagina in https?

E chi ha detto questo?
Il repo va per natura dei repo in http (anche perchè sennò sai che scocciatura fare sempre wget --no-check-certificates ..).
Il forum, se vogliamo l'https, dovrebbe andare con path relativi, così se clicco su un link e sono in http mi va in http, mentre se clicco un link e sono in https vado in https.
Oppure, dicevo, si mette un link o un bottone o un check sulla schermata di login "usa connessione sicura"; internet è pieno di chi fa così.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4411
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Forum in HTTPS [reply]

Messaggioda conraid » mar mar 06, 2012 9:44

Per il forum:
- i path sono relativi, se poi qualcuno inserisce i link appositamente, non possiamo farci niente o poco
- quel poco è già stato fatto e segnalato, adesso un link https di slacky viene convertito automaticamente in http come se fosse una parola "censurata" e questo l'ho detto qualche post fa, tanto che stiamo usando h_t_t_p_s negli esempi apposta per aggirare la cosa.
- volevamo fare un qualcosa per "migliorare" la vita agli utenti. Sinceramente preferisco qualche schermata di avviso che vedere la mia password, o magari messaggi privati, post in forum riservati, etc... letti da chiunque. Chi accede da qualche lan aziendale o qualche access point ha questi problemi. Poi se da fastidio, si toglie. Infatti ora abbiamo tolto tutto, non c'è nessuna forzatura, i link sono convertiti, cosa si vuole di più? o di meno? mi sta fuggendo il senso di tutto questo sinceramente
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Forum in HTTPS [reply]

Messaggioda targzeta » mar mar 06, 2012 10:29

Facciamo il sunto della situazione. Se non ho capito male, ad oggi, nulla è cambiato rispetto alla settimana scorsa. Tutto Slacky.eu è visitabile esattamente come la settimana scorsa via http. L'unica aggiunta fatta è il protocollo https per chi volesse usufruirne. Inoltre, tutti i link all'interno del forum sono nella forma di http (puri o censurati) quindi non ci sono problemi per gli utenti che usano http di ritrovarsi in una pagina https.

I problemi sollevati sono due:
  • certificato autofirmato
  • IE che lamenta il passaggio da https -> http per lo stesso sito

Per il certificato, se troviamo qualcosa di gratuito o economicamente accettabile, perché no, altrimenti io non cambierei la situazione. Invece, per gli utenti IE o altro, se vogliono, visitano il sito via http, altrimenti, com'è giusto, si trovano un modo per essere sicuri che rimangano in https, così come io mi sono trovato l'add-on per FF/Chrome.

Proposte per migliorare ancora la situazione? Di certo https è un valore aggiunto a cui non rinuncerei. Io in pratica non sono mai collegato direttamente dal mio modem, sono sempre in wireless lan,
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Forum in HTTPS [reply]

Messaggioda ZeroUno » mar mar 06, 2012 13:08

boh.
credo che la cosa importante, e che è stata fatta, è quella di non avere la forzatura in https.
A questo punto chi vuole https ne è cosciente e ci va apposta, e si può accontentare benissimo di un certificato fake o scaduto (tipo uno trial, valido ma non successivamente rinnovato).

Personalmente evito l'https dove non mi serve veramente, quindi non credo di avere ulteriore voce in capitolo.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4411
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Forum in HTTPS [reply]

Messaggioda zoros » mar mar 06, 2012 15:49

spina ha scritto:...
Proposte per migliorare ancora la situazione? ...

sì, assolutamente: quando hai un po' di tempo, per cortesia, fate (tu e Corrado) un piccolo wiki su come configurare https su Slackware 8)

per il resto credo che vada bene così ;)
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Forum in HTTPS [reply]

Messaggioda conraid » gio mar 29, 2012 8:44

Abbiamo un certificato "validato", poi scadrà, ma intanto... il problema è che ci sono firme con immagine esterne e quindi i browser segnalano la cosa. Stiamo valutando il da farsi. Intanto ditemi se funziona, ci sono problemi, etc...
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Forum in HTTPS [reply]

Messaggioda masalapianta » gio mar 29, 2012 10:49

finalmente! onestamente http, ad oggi, andrebbe evitato come la peste, in favore di https; la possibilità di averli entrambi, seppur non ottimale, è comunque accettabile.
Avatar utente
masalapianta
Iper Master
Iper Master
 
Messaggi: 2775
Iscritto il: dom lug 24, 2005 23:00
Località: Roma
Nome Cognome: famoso porco
Kernel: uname -r
Desktop: awesome
Distribuzione: Debian

Re: Forum in HTTPS [reply]

Messaggioda miklos » mar set 25, 2012 8:47

ragazzi riprendo questo post per avere info sul certificato che utilizzate.
dove lo avete acquistato!?!?!?

io devo affrontare lo stesso problema e ho trovato per ora questo plan che non mi pare troppo esoso.

voi che ne dite?

ciau
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1239
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.16.3
Desktop: openbox 3.5.2

Re: Forum in HTTPS [reply]

Messaggioda targzeta » mar set 25, 2012 14:32

Il nostro è completamente gratis. Però ora non ricordo dove l'abbiamo preso :(.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6185
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

PrecedenteProssimo

Torna a Libera

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti