Repository 32bit  Forum
Repository 64bit  Wiki

-- RISOLTO -- Impostare connessioni wireless

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 10:18

Adesso finalmente Slackware rileva le reti wireless.
Ma ci sono DUE nuovi problemi inquietanti:
Wicd continua a dirmi "bad password"
Windows 7, nell'altra partizione, non rileva più nulla

E' un incubo..
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 11:54

forse non hai trovato il firmware giusto ... immagino che il pc sia un portatile, quindi è sempre alimentato ... può essere che il firmware ti tenga bloccata la scheda anche per W7, nel caso forse togliendo la batteria per alcuni minuti ...

comunque se hai la possibiltà di provare su una rete wireless aperta dovrebbe connettersi ...

adc3000 ha scritto:...

E' un incubo..
sì, certo ... ma non è un problema di Linux, ma di certi produttori che non ci danno i driver ...

EDIT: comunque per la tua scheda ci sarebbe il driver proprietario: http://www.broadcom.com/support/802.11/linux_sta.php ... bisogna vedere però se compila :-k ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 13:07

zoros ha scritto: nel caso forse togliendo la batteria per alcuni minuti ...


Avevi ragione, adesso la connessione fortunatamente almeno su win7 va!

Ma adesso ho un po' di paura a rimetter mano su slack..
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 13:16

adc3000 ha scritto:
zoros ha scritto: nel caso forse togliendo la batteria per alcuni minuti ...


Avevi ragione, adesso la connessione fortunatamente almeno su win7 va!

Ma adesso ho un po' di paura a rimetter mano su slack..

per così poco! ... più è difficile e più si impara ;) ... la tua scheda wireless sembra non ben supportata con il driver b43, prova a compilare il driver proprietario (link di cui sopra) ...

EDIT: prime istruzioni:
scompatta il driver (immagino avrai slackware 32 bit), entra nella dir ed esegui il make (puoi farlo da user per provare):
Codice: Seleziona tutto
cd hybrid-portsrc_x86_32-v5_100_82_112/
make

probabilmente non compila, ci mettiamo una patch nel caso
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 13:30

adc3000 ha scritto:...
Ma adesso ho un po' di paura a rimetter mano su slack..

sì, ho capito i dubbi ... probabilmente su Slack si ricaricherà il driver bloccandoti la scheda ... devi mettere in blacklist il driver b43, aggiungendo le seguenti righe alla fine del file /etc/modprobe.d/blacklist.conf:
Codice: Seleziona tutto
blacklist b43
blacklist ssb
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 13:54

ok, ha compilato (credo)

Codice: Seleziona tutto
 
bash-4.1# cd /tmp/hybrid_wl/
bash-4.1# make
KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-2.6.37.6'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  Building modules, stage 2.
CFG80211 API is prefered for this kernel version
Using CFG80211 API
  MODPOST 1 modules
WARNING: modpost: missing MODULE_LICENSE() in /tmp/hybrid_wl/wl.o
see include/linux/module.h for more information
make[1]: Leaving directory `/usr/src/linux-2.6.37.6'


ho messo in blacklist ciò che mi avevi detto, non trova nessuna connessione..
quindi?
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 14:07

il driver sembra compilato ok ... al momento non è installato, ma puoi provarne il funzionamento ... se sei ancora nella dir del driver devi diventare root e quindi caricare il driver con insmod, questi i comandi:
Codice: Seleziona tutto
$ su
# modprobe lib80211
# insmod wl.ko

ovviamente $ e # ti indicano che passi da user a root
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 14:47

ottengo questo

Codice: Seleziona tutto
bash-4.1# cd /tmp/hybrid_wl/
bash-4.1# modprobe lib80211
bash-4.1# insmod wl.ko
insmod: error inserting 'wl.ko': -1 Unknown symbol in module


:?: :?: :?:

EDIT: wl.ko è presente sicuramente nella dir
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 15:01

io ho un altro kernel, per il modulo wl l'unica dipendenza è lib80211 ... a questo punto esegui l'installazione e carica con modprobe:
Codice: Seleziona tutto
make install
modprobe wl


Nota, per sapere le dipendenze del modulo:
Codice: Seleziona tutto
modinfo wl.ko
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 15:21

Ecco cosa mi dà:

Codice: Seleziona tutto
bash-4.1# cd /tmp/hybrid_wl/
bash-4.1# make install
install -D -m 755 wl.ko /lib/modules/`uname -r`/kernel/drivers/net/wireless/wl.ko
bash-4.1# modprobe wl
bash-4.1# modinfo wl.ko
filename:       wl.ko
alias:          pci:v000014E4d00000576sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000435Asv*sd*bc*sc*i*
alias:          pci:v000014E4d00004359sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004358sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004727sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000A99Dsv*sd*bc*sc*i*
alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Dsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Csv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Bsv*sd*bc*sc*i*
alias:          pci:v000014E4d0000432Asv*sd*bc*sc*i*
alias:          pci:v000014E4d00004329sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004328sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004315sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004313sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004312sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004311sv*sd*bc*sc*i*
depends:        cfg80211,lib80211
vermagic:       2.6.37.6-smp SMP mod_unload 686
parm:           oneonly:int
parm:           piomode:int
parm:           instance_base:int
parm:           nompc:int
parm:           name:string


Come procedo?
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 15:23

caricando i due moduli delle dipendenze e poi il driver:
Codice: Seleziona tutto
modprobe cfg80211
modprobe lib80211
insmod wl.ko


comunque il modprobe wl dovrebbe averti già caricato il modulo, controlla con il comando
Codice: Seleziona tutto
lsmod
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 15:29

ecco il risultato

Codice: Seleziona tutto
bash-4.1# modprobe cfg80211
bash-4.1# modprobe lib80211                                                                                                                                                                   
bash-4.1# insmod wl.ko                                                                                                                                                                         
insmod: error inserting 'wl.ko': -1 File exists                                                                                                                                               
bash-4.1# lsmod
Module                  Size  Used by                                                                                                                                                         
wl                   2427655  0                                                                                                                                                               
lib80211_crypt_tkip     7463  0                                                                                                                                                               
cfg80211              122542  1 wl                                                                                                                                                             
lib80211                3262  2 wl,lib80211_crypt_tkip
snd_seq_dummy           1119  0                                                                                                                                                               
snd_seq_oss            25900  0
snd_seq_midi_event      4696  1 snd_seq_oss
snd_seq                42680  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event                                                                                                                   
snd_seq_device          4505  3 snd_seq_dummy,snd_seq_oss,snd_seq                                                                                                                             
snd_pcm_oss            34554  0
snd_mixer_oss          14726  1 snd_pcm_oss
ipv6                  236629  28
cpufreq_ondemand        7672  8
speedstep_lib           2663  0
acpi_cpufreq            5195  1
freq_table              2039  2 cpufreq_ondemand,acpi_cpufreq
mperf                    923  1 acpi_cpufreq
lp                      7105  0
ppdev                   4901  0
parport_pc             18218  0
parport                25627  3 lp,ppdev,parport_pc
fuse                   58136  3
fglrx                2724502  515
dell_laptop             7003  0
video                  10482  0
thermal                 6718  0
rfkill                 13278  3 cfg80211,dell_laptop
fan                     1926  0
processor              23158  1 acpi_cpufreq
thermal_sys            11426  4 video,thermal,fan,processor
agpgart                23062  1 fglrx
uvcvideo               55980  0
videodev               57461  1 uvcvideo
dcdbas                  4364  1 dell_laptop
v4l1_compat            13666  2 uvcvideo,videodev
sdhci_pci               6138  0
sdhci                  14783  1 sdhci_pci
firewire_ohci          23789  0
joydev                  7695  0
r8169                  32377  0
rtc_cmos                7970  0
mmc_core               57264  1 sdhci
mii                     3334  1 r8169
firewire_core          43998  1 firewire_ohci
snd_hda_codec_hdmi     20152  1
rtc_core               11871  1 rtc_cmos
dell_wmi                1209  0
sparse_keymap           2436  1 dell_wmi
snd_hda_codec_idt      47981  1
rtc_lib                 1502  1 rtc_core
wmi                     7129  1 dell_wmi
snd_hda_intel          18443  3
snd_hda_codec          61720  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep               4772  1 snd_hda_codec
snd_pcm                59843  4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              15717  2 snd_seq,snd_pcm
snd                    43891  18 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore               4641  1 snd
snd_page_alloc          5925  2 snd_hda_intel,snd_pcm
i2c_i801                7018  0
evdev                   7303  21
ac                      2465  0
battery                 8431  0
button                  4005  1 fglrx
usbhid                 32435  0
sg                     21511  0
psmouse                40986  0
hid                    63771  1 usbhid
i2c_core               16421  2 videodev,i2c_i801
hwmon                   1065  1 thermal_sys
serio_raw               3542  0
shpchp                 23205  0
output                  1456  1 video


Adesso ? :)
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda zoros » dom mar 18, 2012 15:33

adc3000 ha scritto:...

Adesso ? :)

sembra tutto ok, procedi con wicd-gtk, ecc. ... dovrebbe funzionare ... (ricorda i comandi: iwconfig dovrebbe segnalare qualcosa) ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1302
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 13.37
Kernel: 3.2.5
Desktop: KDE-3.5.10

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 15:38

wicd non trova niente :?
iwconfig dà

Codice: Seleziona tutto
bash-4.1# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


uff.. e che fine ha fatto wlan0 ?
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

Re: Impostare connessioni wireless

Messaggioda adc3000 » dom mar 18, 2012 15:41

FUNZIONA TUTTO ho messo eth1 al posto di wlan0 nelle impostazioni di wicd

GRAZIE per la pazienza!! =D> =D> =D>
adc3000
Linux 1.0
Linux 1.0
 
Messaggi: 23
Iscritto il: mer mar 07, 2012 23:09
Slackware: 13.37

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite

cron