Repository 32bit  Forum
Repository 64bit  Wiki

UTF-8, non ci riesco!!!

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

UTF-8, non ci riesco!!!

Messaggioda targzeta » sab mar 31, 2012 22:40

Ciao a tutti,
in questo topic vorrei scrivere, con il vostro aiuto, una giuda da seguire per impostare la Slackware in UTF-8. Io non ci sono ancora riuscito. Vorrei fare tutto a passetti piccoli.

Ho fatto una installazione pulita della Slackware 13.37 e quindi non ci sono contaminazioni di sorta.

Partiamo dal kernel. Al lilo, durante la configurazione del sistema, la Slackware mi ha aggiunto l'entry:
Codice: Seleziona tutto
vt.default_utf8=1

Quindi passiamo alla console. Il mio utente esegue un:
Codice: Seleziona tutto
export LANG=it_IT@utf8
ho visto che esiste il file
Codice: Seleziona tutto
/etc/rc.d/rc.font
con all'interno un:
Codice: Seleziona tutto
setfont -v
però attualmente il file non è eseguibile ma anche eseguendo il comando non succede nulla. Il problema è che se premo una lettera accentata, poi posso fare due backspace e quindi posso cancellare anche il prompt. Eccovi un esempio:
Codice: Seleziona tutto
$>
(Backspace)
$>
(non è successo nulla, il prompt è lo stesso)
$>ò
(Backspace, Backspace)
$
(ho iniziato ha cancellare il prompt)
questo avviene, ovviamente, perché i caratteri in UTF-8 usano due byte per la rappresentazione e non uno.

Qualcuno mi aiuta a risolvere questo primo, piccolo problema?

Emanuele

P.S. Ho fatto una ricerca sul forum ed ho anche trovato alcune soluzioni che però non hanno funzionato. Vorrei ricominciare da capo, se per voi non ci sono problemi.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » sab mar 31, 2012 22:53

Codice: Seleziona tutto
$ cat /etc/rc.d/rc.keymap
#!/bin/sh
# Load the keyboard map.  More maps are in /usr/share/kbd/keymaps.
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys it.map
 /usr/bin/loadkeys euro2.map
fi

Codice: Seleziona tutto
$ cat rc.local
#!/bin/sh
#
if [ -x /usr/bin/unicode_start ]; then
    /usr/bin/unicode_start lat9w-16
fi
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » sab mar 31, 2012 23:27

No Corrado, non funziona. Era proprio a questa soluzione che mi riferivo nell'altro post. Con queste impostazioni, il prompt lo posso ancora cancellare dopo l'inserimento di una letterà accentata, ed inoltre, quando edito qualche file con 'nano', se premo 'C-x' per salvare il file, nel menù al posto del 'Sì' vedo un 'S@' (in realtà non è un @ ma un carattere strano). L'unica cosa che va è il segno dell'euro.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » sab mar 31, 2012 23:36

di nano non so, non uso, ma tutto il resto mi funziona, tranne qualche piccola cosa, tipo il sì di risposta quando esco dal man o da qualche comando :-)
Ma non ho più il fatto del doppio carattere che cancella il prompt, etc... non mi sembra di aver fatto altro sinceramente
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: UTF-8, non ci riesco!!!

Messaggioda Eberoth » sab mar 31, 2012 23:45

Tempo fa io risolsi il problema mettendo queste righe:

Codice: Seleziona tutto
export LANG=it_IT.UTF-8
export LANGUAGE=it_IT.UTF-8
export LINGUAS=it_IT.UTF-8
export LC_ALL=it_IT.UTF-8

nel file .bashrc (.profile e .bash_profile da me sono link simbolici).

Ricordo che la guida (non so più quale, era slackware 13.0) diceva di inserirle in /etc/profile, ma facendolo non risolvevo tutti i problemi così provai a usare le configurazioni locali e andò bene. Con il vantaggio che quando reinstallo il sistema mi ritrovo già tutto pronto!

Prova, magari funziona ancora (ora uso salixos che localizza il sistema durante l'installazione).
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 380
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: UTF-8, non ci riesco!!!

Messaggioda zoros » dom apr 01, 2012 0:38

io ho questi parametetri:
Codice: Seleziona tutto
cat /etc/lilo.conf
...
  append = "vt.default_utf8=1 splash=silent"
...

Codice: Seleziona tutto
cat /etc/profile.d/lang.sh
...
# en_US is the Slackware default locale:
export LANG=it_IT.UTF-8
...

in console modalità caratteri funziona, per esempio "mc" ha la sua bella cornice ed i menù in italiano ... nella konsole grafica invece la cornice di "mc" è fatta da tante ââââ... :roll: ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)

Re: UTF-8, non ci riesco!!!

Messaggioda Blallo » dom apr 01, 2012 0:56

io uso
Codice: Seleziona tutto
LANG=it_IT.utf8

e va tutto ok.
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3244
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » dom apr 01, 2012 1:01

Ok, scemo io. Ho sbagliato locale. Dopo aver dato un:
Codice: Seleziona tutto
locale -a | grep it_IT
it_IT
it_IT.utf8
it_IT@euro
Mi sono accorto che mettovo it_IT@utf8 invece di it_IT.utf8. Ora la console funziona bene.

Ho settato:
Codice: Seleziona tutto
setfont -v lat9w-16
nel file 'rc.font' e
Codice: Seleziona tutto
if [ -x /usr/bin/loadkeys ]; then
 /usr/bin/loadkeys it euro2
fi
nel file 'rc.keymap'. Posso vedere bene sia i caratteri accentati che il simbolo dell'euro (che dipende dai font lat9w-16). Ovviamente dopo aver esportato LANG a it_IT.utf8.

Appena installo X vi faccio sapere come va con xterm :).

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda Blallo » dom apr 01, 2012 1:09

nel bashrc un bel ri-export della LANG lo darei, a me sul vecchio acer non prendeva bene gli accenti senza di questa.
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3244
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » lun apr 02, 2012 10:48

Aggiornamento: X, Xterm e bash.

Sotto X non sembrano esserci grossi problemi, per ora. Per configurare bene Xterm con la bash ed i tasti meta della libreria readline, bisogna:
libreria readline (file inputrc)
Codice: Seleziona tutto
set enable-meta-key On
set input-meta On
set convert-meta Off
set output-meta On
(tutto come default di slackware nel file /etc/inputrc)

Resource per Xterm
Codice: Seleziona tutto
XTerm*Font:   -*-fixed-medium-r-*--*-120-*-*-*-*-iso10646-*
XTerm*Utf8Latin1: true
XTerm*eightBitInput: false
XTerm*eightBitControl: false
XTerm*eightBitOutput: true
Un qualsiasi font iso106464 va bene. A parte i font, le uniche risorse che non sono di default sono:
Codice: Seleziona tutto
XTerm*Utf8Latin1: true
XTerm*eightBitInput: false

Per ora va tutto bene :),
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » lun apr 02, 2012 12:12

Ciao

Per curiosità, se dai
Codice: Seleziona tutto
man manuale_inesistente

che salta fuori? Come caratteri intendo.

Thanks
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1322
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » lun apr 02, 2012 17:47

Mi manca la 'è' di "c 'è". Penso che questo tipo di problemi dipenda dai singoli programmi. Ad esempio, ho un mio programma che stampa delle frasette simpatiche su Chuck Norris che uso come 'fortune'. Ecco, anche quel programma mi visualizza male le lettere accentate. Però questo non succede con l'editor 'nano', dove il 'Sì' lo vedo correttamente.

Pensiamoci, questo thread è nato anche per questo, cercare di capire il mondo UTF8.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6200
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » lun apr 02, 2012 17:50

Come dicevo nel primo post anche io ho quel problema, e questo nonostante abbia configurato le man pages per utf8. In effetti sembra un problema di messaggi di errori, non delle man pages in quanto tali

Per esempio una guida
http://www.electrictoolbox.com/utf8-cha ... man-pages/

A suo tempo per il "mondo" utf8 mi trovai molto bene con le istruzioni del wiki di gentoo
http://www.gentoo.org/doc/it/utf-8.xml

p.s.
su slackware è in /usr/lib o /usr/lib64... per ogni chiarimento man man.conf ;-)

UPDATE
cercando su internet ho trovato questo tizio che si era già posto il problema
viewtopic.php?f=2&t=34658#p306505
:-'
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » lun apr 02, 2012 18:14

spina ha scritto:Mi manca la 'è' di "c 'è".
Emanuele


Come da me, è l'unico problema che ho riscontrato, + altre cose marginali, come ad es. il man di Mplayer in Italiano che ho dovuto convertire per essere leggibile correttamente.

La mia configurazione è molto simile alla tua, se non identica. Il problema della 'è' mancante credo sia dovuto - come dicevi - alla traduzione del pacchetto man.

Anche a me interessa parecchio la questione dell' UTF-8 in Slackware ^^

P.s.

il parametro 'vt.default_utf8=1' non è necessario, se nel config del kernel c'è questa voce:
Codice: Seleziona tutto
CONFIG_NLS_DEFAULT="utf8"

o almeno credo.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1322
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » lun apr 02, 2012 18:24

il problema di è infatti è nel file /usr/share/locale/it/man
se guardate i sorgenti vedete che il codeset è iso-8859-1
probabilmente con iconv nel file dei sorgenti e ricreando il pacchetto... ma sinceramente non ne vale la pena
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Exabot [Bot] e 1 ospite