Repository 32bit  Forum
Repository 64bit  Wiki

UTF-8, non ci riesco!!!

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » lun apr 02, 2012 18:47

conraid ha scritto:il problema di è infatti è nel file /usr/share/locale/it/man
se guardate i sorgenti vedete che il codeset è iso-8859-1
probabilmente con iconv nel file dei sorgenti e ricreando il pacchetto... ma sinceramente non ne vale la pena


Uh, ho letto ora ma avevo già fatto.

Ho scaricato i sorgenti del pacchetto man. Ho aperto con Geany il file 'msgs/mess.it', dall'editor ho settato la codifica su UTF-8 e ho salvato. Poi ho modificato il file 'msgs/mess.it.codeset' mettendo 'codeset=utf8' al posto di quello che c'era prima. Ricompilato con lo Slack.Build di Pat... et voila .... funziona!!
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » mar apr 03, 2012 18:50

Ok rik70, ho seguito il tuo esempio e scrivo qui una mini-guida.
  • Scaricate i due file allegati nella directory /tmp e poi scaricate lo SlackBuild di Pat come segue:
    Codice: Seleziona tutto
    $> cd /tmp
    $> wget -P man -nd -r ftp://ftp.slackware.org.uk/slackware/slackware-current/source/ap/man/
  • ora applicate le patch ed eseguite lo SlackBuild
    Codice: Seleziona tutto
    $> cd man
    $> mv /tmp/man.SlackBuild.diff /tmp/man.it_in_utf8.diff.gz .
    $> patch -p1 < man.SlackBuild.diff
    patching file man.SlackBuild
    #> sh man.SlackBuild
    (notate che l'ultimo comando va eseguito come root)
  • a lavoro ultimato, il pacchetto sarà in /tmp e basta installarlo con:
    Codice: Seleziona tutto
    #> upgradepkg --reinstall /tmp/man-1.6g-i486-1.txz
    (anche questo come root, ovviamente)
Allegati
man.it_in_utf8.diff.gz
Patch ai sorgenti di man
(1.8 KiB) Scaricato 23 volte
man.SlackBuild.diff
Patch per lo SlackBuild di Pat
(451 Byte) Scaricato 29 volte
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » mar apr 03, 2012 20:38

rik70 ha scritto:ps.

il parametro 'vt.default_utf8=1' non è necessario, se nel config del kernel c'è questa voce:
Codice: Seleziona tutto
CONFIG_NLS_DEFAULT="utf8"

o almeno credo.

Esatto, i kernel attuali hanno quel valore impostato di default a 1. Infatti durante l'installazione della Slackware ti viene anche detto. L'ho scritto solo per completezza.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » mar apr 03, 2012 20:48

conraid ha scritto:UPDATE
cercando su internet ho trovato questo tizio che si era già posto il problema
viewtopic.php?f=2&t=34658#p306505
:-'

Ho notato solo ora questo edit che hai fatto. Il problema della pagina di Mplayer comunque rimane, io ho dovuto fare un iconv da utf8 a latin1 per farlo andare. Mi aspettavo che con un ambiente a utf8 il problema sarebbe scomparso, però non è successo. Qualche spunto?

Un altro problema è con ssh. Quando mi collego verso un server remoto con ssh allora la variabile LANG. Ho cercato un po' in giro e sembra che possa risolvere il problema passando a ssh un '-o SendEnv LANG'. Questa soluzione non mi piace perché il server sshd remoto deve avere un'opzione del tipo 'AcceptEnv LANG' e non è detto che io possa modificare la configurazione del server remoto. Ora, potrei aggiungere uno script di inizializzazione sul server che mi imposti la variabile LANG ad ogni accesso, però a volte capita di condividere un account con altra gente e non voglio che anche loro si becchino LANG=it_IT.utf8 al login. Quindi la domanda è semplice: come posso dire a ssh di settarmi LANG?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda fgcl2k » mar apr 03, 2012 22:12

spina ha scritto:Ok rik70, ho seguito il tuo esempio e scrivo qui una mini-guida.
...

Seguite le istruzioni ha funzionato benissimo. Grazie!
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 131
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » mer apr 04, 2012 8:28

@spina

Ci manca qualcosa, questo è sicuro. Ho notato alcune "anomalie", diciamo cosi. Rimanendo sulla questione del man , prova a fare alcune prove. Prendi ad esmpio dal pacchetto man il file 'man2/html/locales/it/hman.1'. E' codificato in ISO8859-1: prova a visualizzarlo con man o anche con less. Noterai che tutti gli accenti sono corretti. Prova ora a convertirlo in utf8 e salvarlo con un altro nome e con estensione '.1'. Ora prova a visualizzarlo come il primo (con man e/o less): noterai gli stessi problemi del manuale di Mplayer. Con `cat` invece nessun problema, o anche con less se salvi senza o con estensione diversa .1{2,3,...)

Insomma, sembra che i manuali localizzati si vedano bene solo se sono scritti in ISO8859-1(15)
Dove stia l'inghippo non saprei. O forse sono io che sto sbarellando :)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » mer apr 04, 2012 8:51

Un programma dovrebbe riconoscere da solo la codifica. Se ti arriva una mail, in qualsiasi codifica sia, riesci a leggerla correttamente. Al limite è un problema di mancata configurazione e/o font mancanti. Ormai non di programmi che non sanno interpretare le varie codifiche.
Naturalmente una codifica maggiore racchiude quella minore. Nel senso che se imposti un programma solo "ascii" non vede nessun carattere fuori dai caratteri ascii. E con utf8 non vedi qualche carattere utf16.
Probabilmente il programma man non ha questa possibilità, e legge solo la codifica iso-8859-1, che poi in fase di output viene convertita da nroff nella codifica del terminale. Quindi stare a ritoccare le pagine man non so quanto sia utile, necessario o fattibile.
Naturalmente è solo una ipotesi, come dicevo nell'altro post non mi sono problemi su cui mi piace perderci tempo nel fare prove o studiare l'arcano :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » mer apr 04, 2012 9:03

@conraid

D'accordo con te, sono questioni irrilevanti. Era giusto per capire il livello di "supporto" all'utf8 da parte di Slacware, visto che Pat continua a consigliare l'uso di iso8859. A questo punto mi sa che per il pacchetto man ci vorrebbe una patch; oppure ce lo teniamo così com'è senza problemi :) .
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » mer apr 04, 2012 9:07

No, penso che al limite sia un problema di conversione runtime. Se modifichi come avete fatto voi, poi il problema è di chi non ha utf8. Anche se oggi ormai...
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » mer apr 04, 2012 20:46

Quindi:
  • la pagina man di MPlayer va convertita. Però se la distribuiscono in utf8 vuol dire che qualcuno la può usare bene così com'è.
  • per ssh nessuna soluzione? io non ho trovato niente di buono.
  • io ho un altro problema con IceWM. I titoli di alcune applicazioni scompaiono. Ad esempio se con gimp apro un'immagine, normalmente la finestra prende il nome di quella immagine, ora invece mi ritrovo con una finestra senza titolo. Stesso discorso vale per le tab di Firefox su alcuni siti, tipo il nostro Slacky.eu!!!!

Secondo me il nocciolo del problema è lo stesso, va solo capito come risolverlo.
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » gio apr 05, 2012 8:17

Da me nessun problema con IceWM.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » ven apr 06, 2012 20:26

Questa è un ottima notizia, vuol dire che è la mia configurazione che è sbagliata, allora. Mi passi i tuoi file?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda rik70 » ven apr 06, 2012 21:10

Allora, io son messo così:

---
.bashrc
Codice: Seleziona tutto
if [ -f /etc/profile ]; then
  . /etc/profile
fi
LANG=it_IT.UTF-8

export LANG


il "source" di /etc/profile è un fatto mio personale che non sto a spiegare, dato che - credo - non ha effetti sulla questione.

---
.bash_profile
Codice: Seleziona tutto
if [ ~/.bashrc ]; then
 . ~/.bashrc
fi


---
Output di xrdb -q
Codice: Seleziona tutto
Xft.antialias:   1
Xft.hinting:   1
Xft.rgba:   none
Xft.hintstyle:   hintslight
Xft.dpi:   96
Xcursor.theme:   PolarCursorTheme
*VT100*FaceSize:   12
*VT100*faceName:   Mono
XTerm*background:   grey13
XTerm*foreground:   grey75
*VT100*cursorColor:   azure3
XTerm*Utf8Fonts:   true
XTerm*eightBitInput:   false
XTerm*eightBitControl:   false
XTerm*eightBitOutput:   true



Di IceWM non ho toccato nulla se non alcuni font - uno per la verità, solo per provare:

~/.icewm/preferences
Codice: Seleziona tutto
TitleFontNameXft="verdana:size=9:bold"

Edit: anche a default il risultato è lo stesso.

Se non ho dimenticato nulla, non c'è altro.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1280
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: UTF-8, non ci riesco!!!

Messaggioda targzeta » sab apr 07, 2012 11:51

rik70, sinceramente allora non capisco come mai a me non funziona. Ho provato anche a compilare l'ultima versione di icewm ma mi da errore in compilazione. Errore che credo sia stato risolto da quelli di debian però usando le loro patch mi si blocca per un altro errore :).

La cosa è un po' fastidiosa, specialmente quando si usa gimp è utile sapere qual'è la finestra di una determinata immagine!!!

Corrado, tu dici che la codifica più grande include quella piccola, però quando apro i miei vecchi file in ISO8859-15 tutte le lettere accentate non è che le vedo proprio benissimo. Non voglio pensare alle lettere accentate sui nomi dei file (attualmente non saprei dove trovarne uno).

Inoltre guardate qui:
Codice: Seleziona tutto
$> ò
bash: $'\303\262': command not found


Insomma, mi si era detto che il passaggio sarebbe stato indolore, però un po' di problemini spuntano sempre :).
Emanuele

P.S. Ah, l'errore è di IceWM perché ho provato fvwm ed è filato tutto liscio.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: UTF-8, non ci riesco!!!

Messaggioda conraid » sab apr 07, 2012 11:54

"include la più piccola" se il programma è scritto per farlo. Ti faccio esempio, se su mutt uso UTF-8 se arrivano mail in iso lui le capisce. Però se arrivano mail che dichiarano una cosa e poi usano un codeset diverso va in tilt.
Alcuni editor "capiscono" e si adeguano. Altri no, e devi farlo tu a mano.
Insomma, dipende da programma a programma
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

PrecedenteProssimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti