Repository 32bit  Forum
Repository 64bit  Wiki

Layout tastiera KDE

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Layout tastiera KDE

Messaggioda sudneo » mer apr 04, 2012 16:03

Salve a tutti, so che e' una domanda posta in qualche discussione, ma di fatto ancora nessuna delle risposte e' stata a me funzionale.
Durante l'installazione di Slackware32 13.37 , ho confermato due volte la mappatura della tastiera italiana, che pero' come ho letto, non configura la mappatura dell'interfaccia X. Di conseguenza una volta avviato KDE , la mappatura e' nuovamente quella usa, o almeno solo per i simboli lo e'.
-Ho provato a editare il file in /etc/rc.d/rc.keymap (o qualcosa di simile) e sembra corretto.
-Ho provato a fare loadkeys it da root ma niente
-La cosa piu' strana e' che da Strumenti di sistema---->localizzazione io ho Controllo ortografico, lingua , ma non ho il cosidetto "Leyboard layout". Come posso fare?
sudneo
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mer apr 04, 2012 15:58
Slackware: 13.37 32bit
Desktop: KDE

Re: Layout tastiera KDE

Messaggioda matzu » mer apr 04, 2012 16:16

Guarda qui: ftp://ftp.slackware.at/slackware-13.37/ ... _HINTS.TXT (o nello stesso file sul dvd o cd d'installazione).

Prova a copiare il file 90-keyboard-layout.conf da /usr/share/X11/xorg.conf.d/ in /etc/X11/xorg.conf.d/, dopodiché lo editi modificando la lingua tastiera da us a it.
Avatar utente
matzu
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: dom set 20, 2009 1:26
Nome Cognome: Franco
Slackware: 64-13.37 13.1
Kernel: generic
Desktop: kde

Re: Layout tastiera KDE

Messaggioda sudneo » mer apr 04, 2012 16:40

Grazie dell'aiuto in primis. comunque ho copiato questo file, ma non riesco a editarlo (sono abbastanza nuovo di linux, lo capirai) , ho provato con nano nomefile ma non me lo legge, cioe' mi da una schermata nera, qualche consiglio?

Edit, sono riuscito a modificarlo, ho sostituito tutti gli US con IT...era questo che dovevo fare .?

Edit dell'edit, grazie mille, ho letto e giustamente richiedeva un restart. ora tutto funziona. Grazie tante
sudneo
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mer apr 04, 2012 15:58
Slackware: 13.37 32bit
Desktop: KDE

Re: Layout tastiera KDE

Messaggioda ermes » mer apr 04, 2012 20:04

impostazioni di sistema
--> dispositivi di immissione
--> tastiera
--> tab "mappature"

- spunta il flag "configura le mappature"
- schiaccia il pulsante "aggiungi mappatura"

... e poi credo sia abbastanza intuitivo.

fai sapere
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti