Repository 32bit  Forum
Repository 64bit  Wiki

Mi aiutate con uno script?

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Mi aiutate con uno script?

Messaggioda sunreal » dom apr 08, 2012 23:40

In questi giorni ho mandato in pensione la mia vecchia multifunzione ed ho acquistato una xerox 3220, premetto che la stampante funziona, e che lo scanner viene vista xsane. Solo che nel CD di installazione ho trovato una directory denominata, udite udite LINUX!!! All'interno c'è uno script di installazione che all' inizio mi dava dei problemi al momento di riavviare cups. Scorrendolo ho trovato il problema, alle righe 872 e 874 c'era il percorso sbagliato, /etc/init.d/cups invece ho messo etc/rc.d/rc.cups. L'installazione a questo punto procede normalmente, ma ad un certo punto si apre una finestra dove dovrei scegliere il tipo di stampante, ma rimane vuota e quindi va tutto in gloria. Sul desktop rimane l'icona di una stampante con la dicitura
xerox unified driver configuration
ma aprendolo non si ottiene nulla, poi nel menu K sono apparse due voci anch' esse inutili. C'è qualche anima buona che può dare una scorsa allo script allegato per vedere dove si può annidiare l'errore? E se c'è rimedio?
PS In /usr/share/cups/model/ c'è una directory xerox con il file .ppd.gz della 3220.
PS Ripeto la stampante funzione benissimo, volevo solo vedere se si riusciva a far funzionare il software di gestione automatica.
PS Lo scanner è rilevato da xsane ma non da vuescan. Ovviamente vuescan su win li vede entrambe.

Ciao.
Allegati
script_stampante.txt
(55.74 KiB) Scaricato 31 volte
Ultima modifica di sunreal il lun apr 09, 2012 12:33, modificato 1 volta in totale.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Mi aiutate con uno script?

Messaggioda Mongo » lun apr 09, 2012 12:28

Mi pare che qui riempia la lista, ma sembra che si aspetti i file non compressi e non divisi per marca. :?:
Codice: Seleziona tutto
     

1683  MODEL_LIST=`ls ./noarch/at_opt/share/ppd/*.ppd 2> /dev/null | awk -F. '{print $2}' | awk -F/ '{print $6}'`
1684  if test -z "$MODEL_LIST" ; then
1685          MODEL_LIST=`ls ../share/ppd/*.ppd 2> /dev/null | awk -F. '{print $3}' | awk -F/ '{print $4}'`

 
Avatar utente
Mongo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 08, 2009 10:50
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: fluxbox

Re: Mi aiutate con uno script?

Messaggioda sunreal » mar apr 10, 2012 6:15

Secondo te, i due indirizzi:
./noarch/at_opt/share/ppd/
../share/ppd/
sono riferiti al file presenti nel HD? Perchè i file ppd che ho trovato sono qui:
/usr/share/cups/xerox
e sono con estensione .ppd.gz
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Mi aiutate con uno script?

Messaggioda Mongo » mar apr 10, 2012 19:32

mi aspetterei che siano percorsi sul CD relativi alla dir dove si trova lo script :-k
Codice: Seleziona tutto
  1670  # Script execution starts here }
  1671
  1672  # test "$1" != "STAGE_GUI" && date > /tmp/install.log
  1673
  1674  SCRIPT_DIR=`dirname "$0"`
  1675  SCRIPT_NAME=`basename "$0"`
  1676  cd "$SCRIPT_DIR"
Avatar utente
Mongo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 08, 2009 10:50
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: fluxbox

Re: Mi aiutate con uno script?

Messaggioda sunreal » mer apr 11, 2012 9:23

Difatti sul CD c'è quel percorso con relativi file .ppd. Quindi lo script in quel punto è corretto.
sunreal
Master
Master
 
Messaggi: 1564
Iscritto il: sab apr 09, 2005 23:00
Località: P.P.P.

Re: Mi aiutate con uno script?

Messaggioda Mongo » sab apr 14, 2012 18:58

Scusa il ritardo. Settimana pesante.
Se copi tutto l'albero da CD su HD puoi probabilmente mettere degli echo di debug per vedere perché non carica la lista.
Se hai risolto mi sveli il segreto?
Avatar utente
Mongo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: lun giu 08, 2009 10:50
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: fluxbox


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti