Repository 32bit  Forum
Repository 64bit  Wiki

k3b è impazzito

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

k3b è impazzito

Messaggioda RedSkull92 » mer apr 11, 2012 0:00

Ho un problema con k3b, quando lo avvio mi dice che non trova nessun supporto ottico e di ricontrollare hal mentre da linea di comando con cdrecord riesco a masterizzare perfettamente.
I permessi sono corretti e questo è il risultato di cdrecord -scanbus:
Codice: Seleziona tutto
 
$[~]--> cdrecord -scanbus
Cdrecord-ProDVD-ProBD-Clone 3.01a02 (i686-pc-linux-gnu) Copyright (C) 1995-2010 Joerg Schilling
Linux sg driver version: 3.5.34
Using libscg version 'schily-0.9'.
scsibus2:
   2,0,0   200) 'ATA     ' 'Hitachi HTS54505' 'PB4O' Disk
   2,1,0   201) *
   2,2,0   202) *
   2,3,0   203) *
   2,4,0   204) *
   2,5,0   205) *
   2,6,0   206) *
   2,7,0   207) *
scsibus3:
   3,0,0   300) 'MATSHITA' 'DVD-RAM UJ890AS ' '1.00' Removable CD-ROM
   3,1,0   301) *
   3,2,0   302) *
   3,3,0   303) *
   3,4,0   304) *
   3,5,0   305) *
   3,6,0   306) *
   3,7,0   307) *
scsibus8:
   8,0,0   800) 'Multiple' 'Card  Reader    ' '1.00' Removable Disk
   8,1,0   801) *
   8,2,0   802) *
   8,3,0   803) *
   8,4,0   804) *
   8,5,0   805) *
   8,6,0   806) *
   8,7,0   807) *


Mi sono creato la iso e ho dato
Codice: Seleziona tutto
sudo cdrecord dev=3,0,0 -eject -v -raw96r speed=16 driveropts=burnfree BigFish.iso


Quale è il problema con k3b ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda conraid » mer apr 11, 2012 11:04

Guarda, lo faceva anche a me tempo fa. Ci ho perso giorni, prima di ricordare che avevo "provato" powertop e mi aveva disabilitato il riconoscimento automatico della periferica per risparmiare batteria.
Prova a dare il comando
Codice: Seleziona tutto
# hal-disable-polling --device /dev/XXX --enable-polling

e guarda che succede. Magari riavvia, ora non ricordo se basta riavviare hal. Con il mix tra udev ed hal ancora presente a volte uso metodi "alla windows" :-)

p.s.
do per scontato che hai k3b di default che usa ancora hal
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12016
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: k3b è impazzito

Messaggioda RedSkull92 » mer apr 11, 2012 13:24

Ho provato con
Codice: Seleziona tutto
#[~redskull]--> hal-disable-polling --device /dev/sr0 --enable-polling
Following symlink from /dev/sr0 to /dev/sr0.
Cannot find storage device /dev/sr0.

è normale ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda RedSkull92 » mer apr 11, 2012 13:38

Ho anche provato con
Codice: Seleziona tutto
#[~]--> hal-disable-polling --udi "/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0" --enable-polling
Device with udi /org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0 is not a storage device.

Prendendo l'udi da hal-device ma niente, solito errore
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda conraid » mer apr 11, 2012 13:40

Codice: Seleziona tutto
hal-find-by-property --key 'storage.drive_type' --string 'cdrom'

cosa ti restituisce? l'uid è questo solitamente
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12016
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: k3b è impazzito

Messaggioda RedSkull92 » mer apr 11, 2012 20:04

Non mi restituisce nulla
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda conraid » gio apr 12, 2012 15:46

sembra, e dico sembra, che hal non lo riconosca come cdrom, prova a cercare se esistono delle lista di device, magari con il serial number, ed aggiungici il tuo. Un po' come si fa con alcuni scanner per sane.
Naturalmente solo una ipotesi
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12016
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: k3b è impazzito

Messaggioda RedSkull92 » ven apr 13, 2012 9:36

Cioè ?
Come dovrei fare ?
Prima funzionava tutto correttamente
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda conraid » ven apr 13, 2012 9:41

Come ti ho detto è solo una ipotesi la mia, non saprei nemmeno dirti dove guardare, se in qualche file di configurazione o direttamente nei sorgenti.
Però dici che "prima" funzionava, prima di cosa? perché a questo punto devi guardare le varie modifiche che hai fatto. Per esempio a me successe dopo l'uso di powertop
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12016
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: k3b è impazzito

Messaggioda fgcl2k » ven apr 13, 2012 10:21

RedSkull92 ha scritto:Ho provato con
Codice: Seleziona tutto
#[~redskull]--> hal-disable-polling --device /dev/sr0 --enable-polling
Following symlink from /dev/sr0 to /dev/sr0.
Cannot find storage device /dev/sr0.

è normale ?

Cosa dice
Codice: Seleziona tutto
ls -l /dev/sr0
?
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 129
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: k3b è impazzito

Messaggioda RedSkull92 » ven apr 13, 2012 16:24

mi dà
Codice: Seleziona tutto
$[~]--> ls -l /dev/sr0
brw-rw---- 1 root cdrom 11, 0 Apr 13  2012 /dev/sr0


Non ho usato programmi "nuovi" o "strani", se non ricordo male è successo tutto dopo un aggiornamento
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda RedSkull92 » ven apr 13, 2012 18:19

Ah, se può servire questo è l'output di lshal
http://sprunge.us/efhW
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda rik70 » sab apr 14, 2012 10:26

Non vorrei dire castronerie - è molto probabile che lo siano - ma a me quella roba sembra un problema legato a udev.

Nell'output di hal manca qualsiasi riferimento a dispositivi di tipo "block".

Che computer hai? Il masterizzatore è scsi o pata/sata? Hai modificato qualcosa nelle regole di udev?

Chiedo perché tutti i dispositivi sembrano "inizializzati" come periferiche scsi generiche. Guarda tu stesso, per es. il dvd/cdrom:
info.linux.driver = 'sr' (string)
info.parent = '/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0' (string)
info.product = 'SCSI Device' (string)
info.subsystem = 'scsi' (string)
info.udi = '/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0' (string)
linux.hotplug_type = 2 (0x2) (int)
linux.subsystem = 'scsi' (string)
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1f.2/host3/target3:0:0/3:0:0:0' (string)
scsi.bus = 0 (0x0) (int)
scsi.host = 3 (0x3) (int)
scsi.lun = 0 (0x0) (int)
scsi.model = 'DVD-RAM UJ890AS' (string)
scsi.target = 0 (0x0) (int)
scsi.type = 'cdrom' (string)
scsi.vendor = 'MATSHITA' (string)

udi = '/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0_scsi_generic'
info.capabilities = {'scsi_generic'} (string list)
info.category = 'scsi_generic' (string)
info.parent = '/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0' (string)
info.product = 'SCSI Generic Interface' (string)
info.subsystem = 'scsi_generic' (string)
info.udi = '/org/freedesktop/Hal/devices/pci_8086_3b29_scsi_host_0_scsi_device_lun0_scsi_generic' (string)
linux.device_file = '/dev/sg1' (string)
linux.hotplug_type = 2 (0x2) (int)
linux.subsystem = 'scsi_generic' (string)
linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1f.2/host3/target3:0:0/3:0:0:0/scsi_generic/sg1' (string)
scsi_generic.device = '/dev/sg1' (string)

Il bus è quello che hai usato con cdrecord, però il dispositivo punta a /dev/sg1 (???)

Cosa restituisce
Codice: Seleziona tutto
cat /etc/udev/rules.d/70-persistent-cd.rules
??
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1204
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: k3b è impazzito

Messaggioda RedSkull92 » sab apr 14, 2012 12:47

Non ho toccato proprio nulla, anche perché con udev non saprei proprio dove mettere le mani, ecco l'output di quel comando:
http://sprunge.us/gjhe
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: k3b è impazzito

Messaggioda rik70 » sab apr 14, 2012 13:00

Uhm....

Hai idea cosa sian que(i)l "SanDisk_Cruzer" | "Cruzer" che appare nelle 2 "regole" finali?

Viene visto come cdrom, ma ha tutta l'aria di essere un'unità flash.

P.s.

Edit:
Se ti è possibile, prova a rimuoverlo. Poi elimina /etc/udev/rules.d/70-persistent-cd.rules - o spostalo da un'altra parte - e riavvia.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1204
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite