Repository 32bit  Forum
Repository 64bit  Wiki

mod_rewrite sempre not found ..

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

mod_rewrite sempre not found ..

Messaggioda mandrago » lun apr 16, 2012 19:32

è da un po' che ci smanetto sopra ma ogni volta che provo sempre 404 not found... qua un po' di dati:
access_log
Codice: Seleziona tutto
127.0.0.1 - - [16/Apr/2012:20:24:39 +0200] "GET /test/notizie/14.html HTTP/1.1" 404 218

error_log
Codice: Seleziona tutto
[Mon Apr 16 20:24:39 2012] [error] [client 127.0.0.1] File does not exist: /srv/httpd/htdocs/test/notizie

.htaccess
Codice: Seleziona tutto
RewriteBase /var/www/htdocs/test
RewriteEngine On
RewriteRule ^notizie/([^/]+).html notizie.php?id=$1 [L]

Ho provato a navigare con:
Codice: Seleziona tutto
http://localhost/test/notizie.php?id=14

e funziona ma con non funziona :
Codice: Seleziona tutto
http://localhost/test/notizie/14.html


Ho messo:
Codice: Seleziona tutto
AllowOverride All


In httpd.conf il mod_rewrite viene caricato correttamente (anche con phpinfo() si visualizza...)
idee?
mandrago
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: ven mar 30, 2012 17:13
Località: Arco (Trento)
Nome Cognome: Daniel
Slackware: 13.37
Kernel: 3.0.4
Desktop: XFCE4

Re: mod_rewrite sempre not found ..

Messaggioda roberto67 » lun apr 16, 2012 21:37

mandrago ha scritto:[...]
Codice: Seleziona tutto
RewriteBase /var/www/htdocs/test
RewriteEngine On
RewriteRule ^notizie/([^/]+).html notizie.php?id=$1 [L]

[...]


Credo che prima dell'istruzione RewriteRule debba selezionare la pagina in questione, sulla quale applicare la regola che hai scritto, ad esempio così
Codice: Seleziona tutto
RewriteCond %{REQUEST_URI}   .*notizie/([^/]+).html$
RewriteRule ....

insomma la RewriteRule viene eseguita solo se la condizione di sopra si verifica, viceversa è chiaro che si passa oltre.
roberto67
Packager
Packager
 
Messaggi: 291
Iscritto il: lun set 14, 2009 17:55
Slackware: 14.1 multilib
Desktop: kde

Re: mod_rewrite sempre not found ..

Messaggioda mandrago » lun apr 16, 2012 21:56

funziona grazie!
mandrago
Linux 1.0
Linux 1.0
 
Messaggi: 30
Iscritto il: ven mar 30, 2012 17:13
Località: Arco (Trento)
Nome Cognome: Daniel
Slackware: 13.37
Kernel: 3.0.4
Desktop: XFCE4


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti