Repository 32bit  Forum
Repository 64bit  Wiki

FreeType: couldn't find encoding 'gb2312.1980-0' [RISOLTO]

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

FreeType: couldn't find encoding 'gb2312.1980-0' [RISOLTO]

Messaggioda targzeta » gio apr 26, 2012 11:42

Quando ho un problema con la Slackware non so mai se postare qui o in Slackware64 :).

Qualcuno di voi che ha installato il pacchetto:
Codice: Seleziona tutto
wqy-zenhei-font-ttf
riscontra questo problema (il messaggio completo è:
Codice: Seleziona tutto
FreeType: couldn't find encoding 'gb2312.1980-0' for '/usr/share/fonts/TTF/wqy-zenhei.ttc'
)? A me compariva quando facevo partire emacs (guardate i log di X).

Il problema si risolve facendo:
Codice: Seleziona tutto
mkfontdir -e /usr/share/fonts/encodings -e /usr/share/fonts/encodings/large .
all'interno della directory:
Codice: Seleziona tutto
/usr/share/fonts/TTF/

Quasi tutti i pacchetti dei font eseguono quel comando come post-installazione, però questo pacchetto no. Secondo voi è da segnalare il problema a Pat?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6155
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti