Repository 32bit  Forum
Repository 64bit  Wiki

gimp 2.8 stabile!

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: gimp 2.8 stabile!

Messaggioda slux » lun mag 07, 2012 18:21

Io sto usando una Current 32 bit aggiornata,ma dopo aver installato Gimp e le nuove dipendenze ho avuto diverse noie con LXDM e XFCE 4.6.2 .
Lxdm sono riuscito a ricompilarlo e ora è a posto,mentre con XFCE non ci riesco e devo dire che non ho molta voglia di cercare una soluzione.Credo che farò un "revert" alle versioni più stabili ed aspetterò con pazienza un pacchetto più ufficiale.
Comunque grazie mille per il tuo sforzo Sya54m :thumbright:
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: gimp 2.8 stabile!

Messaggioda robbybby » lun mag 07, 2012 19:06

rik70 ha scritto:Io la sto utilizzando in Slackware 13.1.
Ho compilato e installato tutto in /opt/gimp.

Cioè hai messo sia Gimp che le dipendenze in /opt/gimp?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1178
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: gimp 2.8 stabile!

Messaggioda rik70 » lun mag 07, 2012 19:19

robbybby ha scritto:Cioè hai messo sia Gimp che le dipendenze in /opt/gimp?


Esattamente.

L'unico modo alla mia portata per provare il nuovo Gimp senza compromettere l'intera dstro ^^
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda robbybby » lun mag 07, 2012 22:54

rik70 ha scritto:Esattamente.
L'unico modo alla mia portata per provare il nuovo Gimp senza compromettere l'intera dstro ^^

Avresti gli slackbuild per mettere tutto in /opt/gimp, per favore?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1178
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 8:02

robbybby ha scritto:Avresti gli slackbuild per mettere tutto in /opt/gimp, per favore?

No, mi dispiace: niente slackbuild.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda sya54M » mar mag 08, 2012 8:28

scusate tutti, non mi sono più arrivate le email di notifica che avevate risposto e non me ne ero accorto...
comunque io ho usato tutti gli slackbuild ufficiali di slackware, mi sembrava quindi superfluo ripubblicarli... l'unico che ho fatto io è quello di libffi
Codice: Seleziona tutto
#!/bin/sh

PKGNAM=libffi
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1_ap}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) export ARCH=i486 ;;
    arm*) export ARCH=arm ;;
       *) export ARCH=$( uname -m ) ;;
  esac
fi

NUMJOBS=${NUMJOBS:-" -j7 "}

CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-libffi
rm -rf $PKG
mkdir -p $TMP $PKG

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

cd $TMP
rm -rf libffi-$VERSION
tar xvf $CWD/libffi-$VERSION.tar.?z* || exit 1
cd libffi-$VERSION || exit 1

chown -R root:root .
find . \
  \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var/lib \
  --mandir=/usr/man \
  --infodir=/usr/info \
  --docdir=/usr/doc/libffi-$VERSION \
  --build=$ARCH-slackware-linux

make $NUMJOBS || make || exit 1
mkdir -p $PKG/usr/share/applications $PKG/usr/share/application-registry
make install DESTDIR=$PKG || exit 1

( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)

( cd $PKG/usr/info
find . -type f -exec gzip -9 {} \;
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)

mkdir -p $PKG/usr/doc/libffi-$VERSION
cp -a \
  LICENSE README ChangeLog* \
  $PKG/usr/doc/libffi-$VERSION

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
requiredbuilder -v -y -s $CWD $PKG
/sbin/makepkg -l y -c n $CWD/libffi-$VERSION-$ARCH-$BUILD.txz

ma è abbastanza standard
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 8:51

Una curiosità:

se premete il tasto F1 che vi dice? Funziona o.... ??
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda sya54M » mar mag 08, 2012 8:52

slux ha scritto:Io sto usando una Current 32 bit aggiornata,ma dopo aver installato Gimp e le nuove dipendenze ho avuto diverse noie con LXDM e XFCE 4.6.2 .
Lxdm sono riuscito a ricompilarlo e ora è a posto,mentre con XFCE non ci riesco e devo dire che non ho molta voglia di cercare una soluzione.Credo che farò un "revert" alle versioni più stabili ed aspetterò con pazienza un pacchetto più ufficiale.
Comunque grazie mille per il tuo sforzo Sya54m :thumbright:

figurati, mi dispiace, ma che problemi ti da? usando kde e non mi sono accorto di eventuali problemi con xfce... di solito si hanno problemi con librerie più vecchie e non più nuove, poi tutti i programmi gtk mi funzionano, quindi non mi ero posto il problema
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: gimp 2.8 stabile!

Messaggioda sya54M » mar mag 08, 2012 8:53

rik70 ha scritto:Una curiosità:

se premete il tasto F1 che vi dice? Funziona o.... ??

dice di leggere il manuale online... mi pare normale...
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 8:57

sya54M ha scritto:
rik70 ha scritto:

dice di leggere il manuale online... mi pare normale...


Anche a me pare normale, è che qui non funziona:
Messaggio help
Impossibile aprire 'http://docs.gimp.org/2.8/en/gimp-help.xml' in lettura: Operazione non supportata

Forse mancano i backend GIO ed è necessario installare GVFS?


Perciò chiedevo :D
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 10:53

P.s.

Alle dipendenze occorre aggiungere:

libcroco-0.6.5

librsvg-2.36.1 -- passando al configure --enable-introspection=no --disable-introspection | uno dei 2

Diversamente non si abilita il supporto a SVG: non gli basta la versione delle librsvg che c'è in current.

Sulla questione della documentazione on-line, non ho risolto. Non vorrei c'entrasse qualcosa il riferimento a webkit. Nelle preferenze -> sezione aiuto noto che manca la scelta del browser, che invece è presente nella versione 2.6. Problema solo mio?

Al di la di questo, per ora sembra tutto a posto.

Bye
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda sya54M » mar mag 08, 2012 10:57

a me funziona... si apre il browser...
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 10:59

sya54M ha scritto:a me funziona... si apre il browser...


Ok, allora è il mio metodo che non funziona per qualche ragione - forse le gtk+ compilate a ***** ?

Grazie mille ;)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: gimp 2.8 stabile!

Messaggioda sya54M » mar mag 08, 2012 11:07

rik70 ha scritto:
sya54M ha scritto:a me funziona... si apre il browser...


Ok, allora è il mio metodo che non funziona per qualche ragione - forse le gtk+ compilate a ***** ?

Grazie mille ;)

di niente :)
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: gimp 2.8 stabile!

Messaggioda rik70 » mar mag 08, 2012 12:02

@sya54M

Ti rompo per l'ultima volta :)

Io in preferenze > aiuto ho questo:

Immagine

Tu come sei messo?

Thanks
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

PrecedenteProssimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron