Repository 32bit  Forum
Repository 64bit  Wiki

aggiornamento a current (X)

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: aggiornamento a current (X)

Messaggioda appo » gio mag 10, 2012 19:23

Una qualche informazione per gli utenti ATI.
I driver proprietari per alcune schede, a seguito dell'aggiornamento di X, vanno in "segmentation fault".
Qui una breve discussione: https://www.linuxquestions.org/questions/slackware-14/latest-update-causes-ati-driver-segfault-943527/.
A me accade con una HD5600 su Slackware64.
Per ora sto usando il "driver" radeon, che a parte qualche bizza alla partenza di X mi consente di utilizzare il gestore delle finestre.

EDIT: dimenticavo di aggiungere che personalmente utilizzo la "current".
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda Roland » mar mag 15, 2012 11:41

appo ha scritto:Una qualche informazione per gli utenti ATI.
I driver proprietari per alcune schede, a seguito dell'aggiornamento di X, vanno in "segmentation fault".
Qui una breve discussione: https://www.linuxquestions.org/questions/slackware-14/latest-update-causes-ati-driver-segfault-943527/.
A me accade con una HD5600 su Slackware64.
Per ora sto usando il "driver" radeon, che a parte qualche bizza alla partenza di X mi consente di utilizzare il gestore delle finestre.

EDIT: dimenticavo di aggiungere che personalmente utilizzo la "current".


Grazie per la dritta!
Come suggerito in quel thread: un (abbastanza) rapido
Codice: Seleziona tutto
slackpkg reinstall x
e driver proprietario nuovamente funzionante :D
Avatar utente
Roland
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: mer ago 20, 2008 0:32
Località: Catanzaro Lido
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2

Re: aggiornamento a current (X)

Messaggioda appo » mar mag 15, 2012 13:42

Roland <-- stai usando il driver proprietario e lo xorg-server 1.12? Questo è strano, dato che il problema si presenta con questa accoppiata.
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda Roland » mer mag 16, 2012 7:24

appo ha scritto:Roland <-- stai usando il driver proprietario e lo xorg-server 1.12? Questo è strano, dato che il problema si presenta con questa accoppiata.


Sono su -current 64...
Dopo aver tentato inutilmente, subito dopo l'aggiornamento, la disinstallazione e reinstallazione dei driver (gli ultimi amd-ati versione 12.4), il problema si è risolto quando ho seguito il consiglio di reinstallare x come si dice nel thread postato da te.
Prima dello startx ho dato un rm /etc/X11/xorg.conf e poco dopo kde era nuovamente up and running ;)
Avatar utente
Roland
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: mer ago 20, 2008 0:32
Località: Catanzaro Lido
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2

Re: aggiornamento a current (X)

Messaggioda appo » gio mag 17, 2012 10:32

Chiaro, quindi non stai usando il driver ATI ma il driver radeon.
Giusto per capire, potresti postare l'output di lsmod?
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda Roland » gio mag 17, 2012 14:35

appo ha scritto:Chiaro, quindi non stai usando il driver ATI ma il driver radeon.
Giusto per capire, potresti postare l'output di lsmod?


Uhm...in effetti lsmod mi restituisce come caricati sia il modulo radeon che quello fglrx e, inoltre, il catalyst control center va in errore per mancanza dei driver proprietari.
Sembrava troppo semplice... :D
Provo a reisntallare i driver proprietari.
Avatar utente
Roland
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: mer ago 20, 2008 0:32
Località: Catanzaro Lido
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2

Re: aggiornamento a current (X)

Messaggioda Roland » gio mag 17, 2012 15:57

La normale disinstallazione aveva lasciato qualche file e il modulo continuava a caricarsi anche se non funzionante.
Questo mi ha ingannato, poiché
Codice: Seleziona tutto
lsmod | grep fglrx
me lo restituiva come caricato e ho dato per scontato che radeon non lo fosse.
Perciò ho giusto fatto la prova del nove disinstallando i driver proprietari con
Codice: Seleziona tutto
sh /usr/share/ati/amd-uninstall.sh --force
e reinstallandoli per constatare che non vanno.
Non ci resta che attendere driver aggiornati, credo... ;)
Avatar utente
Roland
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: mer ago 20, 2008 0:32
Località: Catanzaro Lido
Slackware: current x86_64
Kernel: 3.2.13
Desktop: KDE 4.8.2

Re: aggiornamento a current (X)

Messaggioda appo » gio mag 17, 2012 18:14

Temo che sia così.
Il supporto sarà introdotto, teoricamente, con la prossima versione che speriamo arrivi presto.
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda appo » ven giu 29, 2012 10:40

L'ultimo driver rilasciato da ati (12-6 o 8.98) funziona su current64.
Beh, funziona è una parola grossa. X parte, ecco.
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda IamSOMBER » ven giu 29, 2012 14:43

appo ha scritto:L'ultimo driver rilasciato da ati (12-6 o 8.98) funziona su current64.
Beh, funziona è una parola grossa. X parte, ecco.


A me nemmeno quello :( anzi se avete un consiglio...
Ho una Radeon 6870 e installando gli ultimi 12.6, su un 3.3.8 vanilla, lo schermo resta nero e non va più nulla nemmeno la console con CTRL-Fn.
Finora ho utilizzato il modulo radeon che però manda la ventola al massimo e dopo una mezz'ora é un ottimo deterrente per spegnere tutto.
Con il kernel 3.4.4 nemmeno compilano, in perfetto legacy-style ATI (ora AMD).
Avatar utente
IamSOMBER
Linux 2.4
Linux 2.4
 
Messaggi: 213
Iscritto il: mar nov 08, 2005 15:49
Località: Matelica (MC)
Nome Cognome: Mirko
Slackware: Slackware64 current
Kernel: 3.12.27
Desktop: KDE 4.14.0

Re: aggiornamento a current (X)

Messaggioda appo » ven giu 29, 2012 16:34

Il log di xorg ti da qualche informazione?
Inoltre, che versione di X stai usando?

In effetti è un vero sbattimento questo dei driver ati. "F**k you n****a" e tutto, sono pure d'accordo, ma quella roba funziona (almeno credo).
appo
Linux 1.0
Linux 1.0
 
Messaggi: 47
Iscritto il: dom mag 16, 2010 11:23

Re: aggiornamento a current (X)

Messaggioda Trotto@81 » sab giu 30, 2012 9:39

appo ha scritto:Il log di xorg ti da qualche informazione?
Inoltre, che versione di X stai usando?

In effetti è un vero sbattimento questo dei driver ati. "F**k you n****a" e tutto, sono pure d'accordo, ma quella roba funziona (almeno credo).

Eccome se funziona!! ;)
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3017
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: aggiornamento a current (X)

Messaggioda IamSOMBER » sab giu 30, 2012 13:35

Aggiornamento!!
Ho installato per provare il kernel di Pat 3.2.21.
Adesso i drivers compilano e sembrano funzionare senza problemi..almeno da dieci minuti a questa parte ;)

In risposta ad Appo ho xorg della current e i log non davano informazioni utili, almeno per quello che ci capivo io...
Avatar utente
IamSOMBER
Linux 2.4
Linux 2.4
 
Messaggi: 213
Iscritto il: mar nov 08, 2005 15:49
Località: Matelica (MC)
Nome Cognome: Mirko
Slackware: Slackware64 current
Kernel: 3.12.27
Desktop: KDE 4.14.0

Re: aggiornamento a current (X)

Messaggioda hashbang » mar lug 17, 2012 14:21

slucky ha scritto:
Se usi driver nvidia legacy (173 o precedenti) puoi dire loro addio.
Non supportano infatti le release più recenti di Xorg.
Se usi i driver più recenti non dovresti avere problemi di sorta.


quindi nelle future releases di Slackware non sarà più possibile utilizzare questi vecchi driver, e come faremo noi che ancora abbiamo vecchie schede nvidia? :roll:

Scusate l'offtopic.
Dopo quasi un anno, i driver nvidia 173.14.35 sono stati rilasciati.
Ora dovrebbero avere il supporto a Xorg 1.11 e quindi dovrebbero poter essere utilizzabili anche su Slackware -current.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1832
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Precedente

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti