Repository 32bit  Forum
Repository 64bit  Wiki

errori dopo ultimo aggiornamento a current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

errori dopo ultimo aggiornamento a current

Messaggioda ermes » dom mag 20, 2012 15:23

ciao a tutti.
dopo l'ultimo aggiornamento non sono più riuscito ad avviare la combinazione Mysql-Apache-php.
Mysql mi dava errori nei file di configurazione (ho provato a re-installare ma anche il file mysql_install_db era pieno di errori

alla fine ho dovuto scaricare i 3 file della 13.37, fare il downgrade e ora è tutto a posto

nessuno ha avuto gli stessi problemi ?

grazie
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » dom mag 20, 2012 15:29

sì, ci sono dei problemi nei 3 pacchetti. O meglio, apache non dovrebbe averli, ma devi aggiornare e sistemare i file di configurazione, sono cambiate alcune cose. Per php aspetta, che sembra che php-fpm vada in conflitto con aspx. Per Mysql a me va normalmente (anche qui sistema i file di configurazione, leggi i log, per esempio togli skip-locking), anche se non ho provato molto, per mysql-install-db ho letto di errori nel percorso

https://www.linuxquestions.org/question ... he-945986/
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » dom mag 20, 2012 17:48

Salve ragazzi... Stesso problema qua, avevo già lottato parecchio per attivare LAMP sulla mia slack, adesso però dopo l'aggiornamento mi è stato sovrascritto anche httpd.conf -.- Sapete indicarmi un mirror per fare il downgrade almeno di httpd e poi qualche guida infallibile per attivare LAMP ??
I pacchetti 13.37 sono equivalenti a quelli precedenti l'upgrade??

Grazie
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda ermes » dom mag 20, 2012 17:51

nel frattempo ho trovato un altro errore molto più grave (dato che non so a cosa è dovuto)
il server akonadi non riesce più a partire e quindi non funziona più kontact.

ho provato a vedere cosa fare ma non ho trovato nulla.
mi associo alla richiesta di dove trovare i pacchetti della penultima current.

grazie
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » dom mag 20, 2012 17:54

presumo sia per mysql aggiornato, anche se dovrebbe essere "integrato". Ma non lo uso akonadi quindi non saprei. Però se ti da errore mysql forse è li la causa

p.s.
definirlo più "grave" mi sembra una esagerazione, alla fine è un software desktop, a differenza di php e degli altri pacchetti
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » dom mag 20, 2012 17:56

Io non riesco ad aprire phpMyAdmin, il server apache funziona come testimoniato dal "It works!" visualizzato nel browser..
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda ermes » dom mag 20, 2012 18:03

forse è hai ragione... la gravità però è dovuta al fatto che non riesco più a vedere la posta e il resto gestito da kontact.

comunque ho fatto il downgrade di mysql e ora funziona... per questo motivo non capisco cosa non vada.
Ho trovato questi errori:
Codice: Seleziona tutto
Nessun agente delle risorse è stato trovato. Akonadi non è utilizzabile senza almeno uno di essi. Questo normalmente indica che non è stato installato alcun agente delle risorse o c'è un problema con la configurazione. Gli agenti sono stati ricercati nei seguenti percorsi: «/usr/share/akonadi/agents». La variabile d'ambiente XDG_DATA_DIRS è impostata a «/usr/share:/usr/share:/usr/local/share», assicurati che includa tutti i percorsi in cui sono installati agenti di Akonadi.


ci capisci qualche cosa ?

il fatto che non usi akonadi significa che non usi kde oppure c'è un modo per fare altrimenti ?
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » dom mag 20, 2012 18:09

uso kde, ma solo come desktop manager, mi tengo alla larga da kmail e simili. Alla fine per me kde è solo un gestore di finestre :)

Non so proprio che dirti riguardo quell'errore
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » lun mag 21, 2012 11:51

Bene ragazzi, adesso riesco ad aprire phpMyAdmin (probabilmente il problema era il fatto che scrivevo localhost/phpMyAdmin e non localhost/phpmyadmin, come del resto ho sempre fatto, ma vabè!) tornando a noi phpMyAdmin mi da un errore su mysql e di fatti rifacendo la procedura di settaggio di mysql mi viene dato il seguente errore:

Codice: Seleziona tutto
root@darkstar:~# mysql_install_db

FATAL ERROR: Could not find ./bin/my_print_defaults

If you compiled from source, you need to run 'make install' to
copy the software into the correct location ready for operation.

If you are using a binary release, you must either be at the top
level of the extracted archive, or pass the --basedir option
pointing to that location.


qualche idea?
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda ermes » mar mag 22, 2012 7:46

penso sia tutta questione di variabili d'ambiente non settate o settate non correttamente
ho provato a metterci mano... ma dopo aver risolto quel problema ne spuntava un altro, sempre dovuto a path settati male (probabbilmente in fase di compilazione ?!?!?!)... allora ho rinunciato e, come ho scritto sopra, ho fatto il downgrade dei pacchetti mysql, php, apache a quelli della 13.37
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 339
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda targzeta » mar mag 22, 2012 15:59

Io ho scaricato la curent giusto ora ed ho visto qualche indicazione nel ChangeLog. Che faccio, aggiorno o no? Perché a me LAMP mi serve. A qualcuno funziona bene dopo l'aggiornamento?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » mar mag 22, 2012 18:58

Io più che LAMP posso usare LAP! Non ho ancora trovato un modo per usare mysql...
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda targzeta » mar mag 22, 2012 19:40

Quindi apache e php funzionano? E' solo un problema di mysql? Però è strano perché sia per PHP che per apache ci sono log in ChangeLog, mentre per mysql dice solo upgraded :)

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: errori dopo ultimo aggiornamento a current

Messaggioda ponce » mar mag 22, 2012 21:10

apache e mysql funzionano tranquillamente (non ho testato l'upgrade, solo un installazione pulita), e' giusto lo script mysql_install_db che ha dei percorsi sbagliati, basta correggerlo cosi'
Codice: Seleziona tutto
--- mysql_install_db.orig       2012-05-16 21:27:30.000000000 +0200
+++ mysql_install_db    2012-05-21 07:26:15.394000008 +0200
@@ -18,9 +18,9 @@
 #
 # All unrecognized arguments to this script are passed to mysqld.
 
-basedir=""
+basedir="/usr"
 builddir=""
-ldata="./data"
+ldata="/var/lib/mysql"
 langdir=""
 srcdir=""



per il php invece bisogna compilarsi una versione corretta da Heinz Weisinger
http://www.liwjatan.at/files/slackware/ ... e-current/

c'e' un thread al riguardo su linuxquestions
https://www.linuxquestions.org/question ... he-945986/

entrambi i problemi sono stati segnalati a Pat e saranno sistemati presto ;)
Avatar utente
ponce
Master
Master
 
Messaggi: 1503
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: errori dopo ultimo aggiornamento a current

Messaggioda targzeta » mar mag 22, 2012 21:30

Allora aspetto che Pat sistemi. Grazie mille ponce.

Emanuele

P.S. Quindi sei tu quello citato nel ChangeLog :). Mi dicevo:"strano che un italiano non fa parte di Slacky"!!
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6186
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 3 ospiti