Repository 32bit  Forum
Repository 64bit  Wiki

errori dopo ultimo aggiornamento a current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: errori dopo ultimo aggiornamento a current

Messaggioda targzeta » mer mag 23, 2012 15:28

Ma quindi posso aggiornare tutto senza paura?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: errori dopo ultimo aggiornamento a current

Messaggioda RedSkull92 » mer mag 23, 2012 16:13

conraid ha scritto:altra cosa strana, come ho scritto su LQ (non chiedermi di riscrivere, che tra mia scarsa conoscenza dell'inglese e ... lasciamo perdere va), ho provato adesso sul notebook, a 64bit, e non da quell'errore. Sul fisso a 32 sì. Boh... avrò dimenticato qualcosa, poi controllo meglio. Ma sembra tutto di default

UPDATE
sì, con tutto di default (oddio, decommentando la riga che include mod_php) ho questo
Codice: Seleziona tutto
SSH root@asustar:/etc/httpd# apachectl start
[Wed May 23 14:50:07.707395 2012] [:crit] [pid 2282:tid 3070101248] Apache is running a threaded MPM, but your PHP Module is not compiled to be threadsafe.  You need to recompile PHP.
AH00013: Pre-configuration failed

solo nella -current a 32 bit

per la cronaca
64bit:
# grep mpm httpd.conf
LoadModule mpm_event_module lib64/httpd/modules/mod_mpm_event.so
#LoadModule mpm_prefork_module lib64/httpd/modules/mod_mpm_prefork.so
#Include /etc/httpd/extra/httpd-mpm.conf

32bit
# grep mpm httpd.conf
LoadModule mpm_event_module lib/httpd/modules/mod_mpm_event.so
#Include /etc/httpd/extra/httpd-mpm.conf

Anche nella mia 32bit dà questo errore, infatti sono dovuto tornare al pacchetto della stable per far rifunzionare il tutto.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: errori dopo ultimo aggiornamento a current

Messaggioda ermes » mer mag 23, 2012 17:18

Amarok continua a darmi problemi.
ora vede le scalette, i file e si collega al Db di Mysql ma non riesce a riprodurre nulla... continua a scorrere la scaletta dei brani e dice che ci sono troppi errori :cry:
ho provato anche a svuotare il Db e fargli ricostruire tutto... ma non funziona proprio [-X
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 340
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » mer mag 23, 2012 17:27

a me amarok funziona regolarmente. Ma qui sul notebook, dove ho un solo cd indicizzato. Quindi poco utile come test
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda ponce » mer mag 23, 2012 20:29

se devo dire la verità anch'io ho testato la 64 (e un installazione pulita funziona senza problemi).
Domani mi installo una 32 e provo :)
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » gio mag 24, 2012 12:42

Disponibili nuovi pacchetti tra cui php e mysql... Vediamo un po' dopo l'upgrade..
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » gio mag 24, 2012 12:45

rfringuello89 ha scritto:Disponibili nuovi pacchetti tra cui php e mysql... Vediamo un po' dopo l'upgrade..


ma dove? o stai ancora parlando di quelli di ieri?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » gio mag 24, 2012 12:52

si credo siano di ieri!! non mi venivano visualizzare le pagine 2 e 3 di questo topic e quindi ho scritto la risposta pensando finisse tutto a pagina 1!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » gio mag 24, 2012 16:28

Funziona tutto alla perfezione, perfino la connessione tramite NetBeans con il server Apache e il framework Hibernate!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda targzeta » gio mag 24, 2012 18:39

Quindi aggiorno anche io???

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6195
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: errori dopo ultimo aggiornamento a current

Messaggioda rfringuello89 » gio mag 24, 2012 19:24

A me funziona egregiamente.. Altro che mySql Administrator che usavo a scopo didattico e per giunta su windows!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: errori dopo ultimo aggiornamento a current

Messaggioda ponce » ven mag 25, 2012 5:34

n/php-5.4.3-x86_64-3.txz: Rebuilt.
Added --enable-maintainer-zts to the ./configure options.
It seems that this option was automatically enabled on the 64-bit side,
but not on 32-bit. I'm still not entirely sure why that happened. I
had a few theories about it, like perhaps httpd was running when one of
the PHP packages was compiled, but testing on 32-bit seemed to engage
ZTS at random. The only reliable way to make things work was to specify
the option explicitly, so that's what has been done. If it has to be
one way or the other, I think we want a thread-safe PHP that will work
with any httpd MPM. Let me know if there are still any issues, but it
should be working properly now.

Pat ha risposto anche su linuxquestions ;)

https://www.linuxquestions.org/question ... ost4686764
Avatar utente
ponce
Master
Master
 
Messaggi: 1514
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.18-rc2
Desktop: lxde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » ven mag 25, 2012 10:09

Finalmente qualcuno che ha capito la cosa :-' dovevo scrivere a lui fin dal'inizio :p

Ora scarico e provo, comunque come dicevo qualche post fa e come vorrei scrivere li se sapessi bene l'inglese, non è proprio un "problema", visto che quelli di PHP mettono warning ovunque relativi all'uso di mpm non prefork con mod_php. Però in effetti è strano questo comportamento del configure
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: errori dopo ultimo aggiornamento a current

Messaggioda ermes » ven mag 25, 2012 18:08

finalmente sono riuscito a capire cosa non andava in amarok: il backend
alcune current fa avevo settato xine perché con gstreamer non funzionava (grazie a Corrado)
ora invece l'unico modo per farlo funzionare è quello di ritornare su gstreamer... vabbè!

continua ad avere problemi invece sul montaggio in kde degli hd esterni. Vengono rilevati, vengono aperti ma solo in lettura... le penne usb invece vanno normalmente.

qualcuno ha un'idea ? [-o<
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 340
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: errori dopo ultimo aggiornamento a current

Messaggioda conraid » ven mag 25, 2012 18:15

ermes ha scritto:finalmente sono riuscito a capire cosa non andava in amarok: il backend
alcune current fa avevo settato xine perché con gstreamer non funzionava (grazie a Corrado)
ora invece l'unico modo per farlo funzionare è quello di ritornare su gstreamer... vabbè!

continua ad avere problemi invece sul montaggio in kde degli hd esterni. Vengono rilevati, vengono aperti ma solo in lettura... le penne usb invece vanno normalmente.

qualcuno ha un'idea ? [-o<


per gstreamer stai attento, che con il kernel 3.4 ha dei problemi con la versione in -current
http://slackblogs.blogspot.it/2012/05/u ... ugins.html

a me gli hd esterni vanno, tra l'altro non c'è differenza tra hd e usbpen, almeno che non abbiano filesystem diversi. Io gli hd esterni li ho solo ext3/4, le usbpen fat
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti