Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] lyx-editor LaTeX

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] lyx-editor LaTeX

Messaggioda Procopio » mer feb 15, 2012 19:15

Ciao a tutti!

dal nostro repos ho installato il lyx, se però provo a farlo partire da "applicazioni" -> "ufficio" -> "Latex Frontend (lyx)" questo sembra partire, ma dopo aver fatto "la finta" non fa nulla, se provo a lanciarlo ad riga di comando ottengo
Codice: Seleziona tutto
bash-4.1# /usr/bin/lyx
/usr/bin/lyx: error while loading shared libraries: libhunspell-1.2.so.0: cannot open shared object file: No such file or directory
la libreria a cui fa riferimento non l'ho trovata ne sul nostra repos ne fra gli slackbuilds... ho cercato un po in giro nel web ed ho trovato "hunspell-1.3.2" l'ho installato, ma non è neanche andata a buon fine l'instalazione.... qualcuno sa come posso risolvere? :)
Ultima modifica di Procopio il sab feb 18, 2012 19:00, modificato 2 volte in totale.
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: lyx-editor LaTeX

Messaggioda targzeta » mer feb 15, 2012 19:56

Sembra faccia parte della slackware:
Codice: Seleziona tutto
fMANIFEST.sh libhunspell
||   Package:  ./l/hunspell-1.2.9-x86_64-1.txz
-rwxr-xr-x root/root       988 2010-05-03 20:04 usr/lib64/libhunspell-1.2.la
-rwxr-xr-x root/root    266944 2010-05-03 20:04 usr/lib64/libhunspell-1.2.so.0.0.0


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6194
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: lyx-editor LaTeX

Messaggioda Procopio » mer feb 15, 2012 20:31

ecco, però la mia è a 32 bit, la installo lo stesso?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: lyx-editor LaTeX

Messaggioda targzeta » gio feb 16, 2012 10:29

Indendevo dire che il pacchetto lo trovi nella Slackware, senza andare in giro. Se hai una current a 32bit il pacchetto è questo.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6194
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: lyx-editor LaTeX

Messaggioda Procopio » gio feb 16, 2012 19:13

grazie mille spina! scusa per il problema banale, lyx ora funziona correttamente!
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda Procopio » sab mag 26, 2012 15:51

riesumo questo post perchè ho tentato di compilare lyx con gli slackbuild, ma ho riscontrato un errore
Codice: Seleziona tutto
./boost/boost/config/stdlib/libstdcpp3.hpp:42:0: warning: "BOOST_DISABLE_THREADS" redefined [enabled by default]
In file included from insets/InsetTabular.cpp:20:0:
../config.h:628:0: note: this is the location of the previous definition
insets/InsetTabular.cpp: In instantiation of 'const string lyx::{anonymous}::write_attribute(const string&, const T&) [with T = lyx::Tabular::VAlignment; std::string = std::basic_string<char, std::char_traits<char>, std::allocator<char> >]':
insets/InsetTabular.cpp:1398:66:   required from here
insets/InsetTabular.cpp:194:26: error: 'tostr' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
insets/InsetTabular.cpp:299:14: note: 'const string lyx::{anonymous}::tostr(const lyx::Tabular::BoxType&)' declared here, later in the translation unit
insets/InsetTabular.cpp: In instantiation of 'const string lyx::{anonymous}::write_attribute(const string&, const T&) [with T = lyx::Tabular::HAlignment; std::string = std::basic_string<char, std::char_traits<char>, std::allocator<char> >]':
insets/InsetTabular.cpp:1403:48:   required from here
insets/InsetTabular.cpp:194:26: error: 'tostr' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
insets/InsetTabular.cpp:299:14: note: 'const string lyx::{anonymous}::tostr(const lyx::Tabular::BoxType&)' declared here, later in the translation unit
insets/InsetTabular.cpp: In instantiation of 'const string lyx::{anonymous}::write_attribute(const string&, const T&) [with T = lyx::LyXAlignment; std::string = std::basic_string<char, std::char_traits<char>, std::allocator<char> >]':
insets/InsetTabular.cpp:1407:62:   required from here
insets/InsetTabular.cpp:194:26: error: 'tostr' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
insets/InsetTabular.cpp:299:14: note: 'const string lyx::{anonymous}::tostr(const lyx::Tabular::BoxType&)' declared here, later in the translation unit
insets/InsetTabular.cpp: In instantiation of 'const string lyx::{anonymous}::write_attribute(const string&, const T&) [with T = lyx::Tabular::BoxType; std::string = std::basic_string<char, std::char_traits<char>, std::allocator<char> >]':
insets/InsetTabular.cpp:1449:58:   required from here
insets/InsetTabular.cpp:194:26: error: 'tostr' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive]
insets/InsetTabular.cpp:299:14: note: 'const string lyx::{anonymous}::tostr(const lyx::Tabular::BoxType&)' declared here, later in the translation unit
make[4]: *** [InsetTabular.o] Error 1
make[4]: Leaving directory `/tmp/SBo/lyx-2.0.0/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/SBo/lyx-2.0.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/SBo/lyx-2.0.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/SBo/lyx-2.0.0'
make: *** [all] Error 2



la patch dovrebbe essere questa?

qua invece c'è il ramo di sviluppo? scusate la domanda ma che diferenza c'è tra sorgenti e binari?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda conraid » dom mag 27, 2012 9:39

Ma perché prendere i sorgenti di una vecchia versione e cercare patch quando l'ultima compila normalmente?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda Procopio » dom mag 27, 2012 10:20

ma i sorgenti li prendo dal link sul sito degli slackbuilds, comunque i sorgenti nuovi sono questi?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda conraid » dom mag 27, 2012 10:31

http://www.slackers.it/repository/lyx/src/

trovi build e link ai sorgenti :-)

tra l'altro l'ho ricompilato ieri perché ho dovuto aggiornare alla nuova versione di boost

Sì, i sorgenti sono quelli
Come vedi la 2.0.3 è del primo marzo, ma la 2.0.0 è dell'8 maggio 2011. Sono cambiate un po' di cose da allora.
Usare i build va bene, da qualsiasi parte li prendi, e quelli di SBo vai sul sicuro, ma ricorda sempre due cosa:
1) sono per stable
2) è un lavoro grande e non sempre sono aggiornati
quindi ti conviene sempre modificarli per l'ultima versione del programma, che poi non è detto che funzioni su current, per esempio per alcuni programmi dobbiamo aspettare gstreamer, gtk3, e tante altre cosini, che forse nemmeno saranno messo nella prossima stable.
Insomma, prendi, guarda, ma usa la fantasia :-)

poi scusa, ti sei messo a cercare delle patch e non la versione nuova? :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda Procopio » dom mag 27, 2012 10:39

ma no in realtà se guardi avevo cercato subito tutti e due, ma proprio solo perchè non ero sicuro su cosa dovevo fare...:)
ma poi scusa, io mi ricordavo che ci fosse anche sullo slackers, ed infatti ieri ho scaricato anche il pacchetto, ma mi sembrava meglio compilare, è un impressione saggia? oppure per tutti i programmi che trovo già pacchettizzati su slackers.it è uguale se uso quel pacchetto?
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda conraid » dom mag 27, 2012 10:40

Procopio ha scritto:ma no in realtà se guardi avevo cercato subito tutti e due, ma proprio solo perchè non ero sicuro su cosa dovevo fare...:)
ma poi scusa, io mi ricordavo che ci fosse anche sullo slackers, ed infatti ieri ho scaricato anche il pacchetto, ma mi sembrava meglio compilare, è un impressione saggia? oppure per tutti i programmi che trovo già pacchettizzati su slackers.it è uguale se uso quel pacchetto?


beh dipende. Se vuoi opzioni particolari o ottimizzazioni spinte allora ricompila. Ma in quel caso cambia anche i CFLAGS in base al tuo processore (o con la direttiva native di gcc mi sembra)

Dipende sempre da quel che devi fare. Comunque mi sono accorto che lo slack-desc è errato e sto ricreando il pacchetto :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12022
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: [RISOLTO] lyx-editor LaTeX

Messaggioda Procopio » dom mag 27, 2012 10:42

ok! Grande Corrado! :)
Avatar utente
Procopio
Linux 2.6
Linux 2.6
 
Messaggi: 701
Iscritto il: ven lug 29, 2011 10:50
Località: Torino
Nome Cognome: Matteo Micheletto Oddino
Kernel: 3.16.1-1-ARCH
Desktop: awesome 3.5.5-1
Distribuzione: ArchLinux


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron