Repository 32bit  Forum
Repository 64bit  Wiki

Configurazione X e driver open ati

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Configurazione X e driver open ati

Messaggioda -sf » gio mag 24, 2012 18:12

Ciao a tutti, ho bisogno di una mano per configurare X su slackware 13.37 a 64bit; sembra funziona abbastanza bene ma non parte KDE e non e' possibile sfruttare la risoluzione del monitor di 1920x1080.
Premetto che la scheda video e' una ati e per il momento girano i driver open.
KDE non parte ma con xfce non ci sono problemi, se non appunto una risoluzione troppo bassa (1280x1024 forse).

Curiosando in xorg.conf, sotto device viene specificato il driver "vesa" e non c'e nulla riguardo alla risoluzione (xorg.conf generato da xorgsetup).
Per quel che ricordo i driver per le schede ati/amd erano chiamati "radeon" e cercando fra i moduli caricati non compaiono; tuttavia se vengono caricati manualmente tutto va a buon fine.
Modificando di conseguenza xorg.conf specificando di usare il driver radeon non c'e modo di far partire X, googlando un po' ho trovato qualche esempio e qualche dritta su xorg.conf ma nessuna sembra funzionare... ho letto anche un wiki qui su slacky ma credo sia per una vecchia release di Xorg e non ha funzionato.

Inoltre ho anche un'altro dubbio: l'accelerazione video e' supportata dai driver open solo per alcune schede se non erro, non sono riuscito a capire se questa lo e', ma dando:
Codice: Seleziona tutto
bash-4.1# glxinfo | grep rendering
direct rendering: Yes

Vuol dire che l'accelerazione e' attiva?
I driver specificati in xorg.conf sono sempre i vesa e non radeon (che nemmeno vengono caricati).

Uso questi driver, che comunque funzionano, e cerco di modificare solo la risoluzione dello schermo? (Come?)
Oppure forzo Xorg ad usare i radeon? I vesa non vengono generalmene caricati di default per garantire una compatibilita' con quasi tutte le schede?

Il discorso KDE non ho ancora approfondito, non so se si tratta di Xorg o di configurare proprio KDE, forse la seconda visto che con xfce non ci sono problemi di sorta.

Grazie mille :D
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda alphamanitine » lun mag 28, 2012 14:57

L'acceleraione è attiva. Se carichi moduli al volo es.:
Codice: Seleziona tutto
# modprobe radeon
e tutto funziona meglio è probabile che siano quelli giusti..comunque esiste anche il modulo RADEONHD che supporta determinate schede video o meglio processori grafici http://cgit.freedesktop.org/xorg/driver/xf86-video-radeonhd/plain/README più recenti, però solo tu sai quale scheda video hai, di conseguenza controlla il link e fai le prove...
Spero di essere stato di aiuto. Ciao.
Avatar utente
alphamanitine
Linux 2.0
Linux 2.0
 
Messaggi: 164
Iscritto il: mar feb 15, 2005 0:00
Località: Prato
Slackware: 14

Re: Configurazione X e driver open ati

Messaggioda -sf » lun mag 28, 2012 19:29

Ciao, intanto grazie per la risposta!
Ho dato uno sguardo al link ma non c'e la scheda percio' credo che il driver piu' appropriato sia radeon.

Il problema e' che non riesco a farglielo usare a Xorg nel suo file di configurazione.
Se sostituisco semplicemente "vesa" con "radeon" non parte e nemmeno se provo a disabilitare altri moduli che vengono caricati nella sezione MODULE (come da suggerimento in alcuni wiki).
Nel log che crea vedo che carica alcuni moduli (DRI ecc) e poi al momento di cercare la scheda video restituisce un "device not found" e ovviamente ferma tutto.

Per il resto caricando manualmente il driver radeon non ci sono problemi; a dirla tutta anche con vesa non ha problemi, se non il fatto che non riesco a settare una risoluzione maggiore di 1280x780 (o giu di li).
Leggendo in giro mi e' parso di capire che sia una questione legata a vesa, che non supporta appunto alcune risoluzioni particolarmente "elevate".
Puo' essere?
In alternativa come mi consigli di modificare xorg.conf?

Appena riesco posto la configurazione attuale.

Grazie! :)
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda Amrod » lun mag 28, 2012 22:20

Ciao, io uso i closed quindi potrei dire qualcosa di inesatto, se non sbaglio per controllare se l'accelerazione e' attiva devi controllare l'output del comando glinfo
e vedere la riga GL_RENDERER.

Nel mio caso con i closed ho come risultato
Codice: Seleziona tutto
marco@amrod:~$glinfo | grep RENDERER
GL_RENDERER: AMD Radeon HD 7800 Series


se non ricordo male se non e' attiva l'accelerazione come output c'e' qualcosa del tipo software rasterizer, se e' attiva dovrebbe uscire qualcosa relativo a mesa
o a llvm.

Per configurare al meglio xorg.conf ti suggerisco di leggere qui https://wiki.archlinux.org/index.php/Radeon

Ciao e scusa se ho scritto qualche fesseria.
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Configurazione X e driver open ati

Messaggioda -sf » mer mag 30, 2012 20:14

Ciao, grazie per il suggerimento.

L'accelerazione a questo punto direi che e' attiva, rimane pero' il fatto che non riesco a settare la giusta risoluzione.
Ho fatto qualche prova veloce seguendo il wiki di arch ma senza risultati, appena ho un attimo di tempo provo ad approfondire meglio.

Se intanto qualcuno ha qualche altra dritta da darmi ben venga :)

Grazie per il momento!
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda joseph » gio mag 31, 2012 7:33

Prova a dare un "xrandr" in console e vedi un pò che risoluzioni ti spuntano fuori :D
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: Configurazione X e driver open ati

Messaggioda -sf » gio mag 31, 2012 13:23

Ne ho 4-5 e la piu' alta e' 1280x1024, che e' gia anche in uso.
Per quanto riguarda il driver radeon non riesco a passarlo a xorg, mi restituisce sempre un errore "device non found" (nel log) al lancio di X.
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda joseph » gio mag 31, 2012 13:33

Prova a guardare in "/usr/X11R6/lib/xorg/modules/drivers" se è presente il modulo "radeon_drv.so" altrimenti mi sa che devi installare il pacchetto dei drivers di xorg.
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: Configurazione X e driver open ati

Messaggioda -sf » gio mag 31, 2012 19:08

Si il modulo e' presente

Codice: Seleziona tutto
bash-4.1# ls /usr/X11R6/lib64/xorg/modules/drivers/ | grep radeon*
radeon_drv.la
radeon_drv.so
radeonhd_drv.la
radeonhd_drv.so
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda 414N » ven giu 01, 2012 8:56

Di quale scheda video ATI/AMD stiamo parlando?
Attenzione a non confondere il driver radeon del kernel col "driver" radeon di X e col "driver" rXXX contenuto in Mesa: sono tre cose diverse, anche se vanno a braccetto ;)
Tornando al problema, magari un log di X (/var/log/Xorg.0.log) quando imposti come driver radeon in /etc/X11/xorg.conf e scegli di avviare KDE ci può aiutare a capire la situazione. Ovviamente riportalo tra tag code, altrimenti il thread diventa lungo quanto "I promessi sposi"...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Configurazione X e driver open ati

Messaggioda -sf » lun giu 04, 2012 21:39

Eccomi, ho avuto qualche problemino di rete (tanto per cambiare :roll: )

Allora questo e' il log generato quando vado a sostituire "radeon" a "vesa" nel conf di xorg
Codice: Seleziona tutto
[   156.846]
X.Org X Server 1.9.5
Release Date: 2011-03-17
[   156.846] X Protocol Version 11, Revision 0
[   156.846] Build Operating System: Slackware 13.37 Slackware Linux Project
[   156.847] Current Operating System: Linux darkstar 2.6.37.6 #3 SMP Sat Apr 9 22:49:32 CDT 2011 x86_64
[   156.847] Kernel command line: root=/dev/sda4 ro
[   156.847] Build Date: 17 March 2011  10:50:17PM
[   156.847] 
[   156.847] Current version of pixman: 0.20.2
[   156.847]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   156.847] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   156.848] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  4 15:17:26 2012
[   156.848] (==) Using config file: "/etc/X11/xorg.conf"
[   156.848] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   156.848] (==) ServerLayout "X.org Configured"
[   156.848] (**) |-->Screen "Screen0" (0)
[   156.848] (**) |   |-->Monitor "Monitor0"
[   156.848] (**) |   |-->Device "Card0"
[   156.848] (**) |-->Input Device "Mouse0"
[   156.848] (**) |-->Input Device "Keyboard0"
[   156.848] (==) Automatically adding devices
[   156.848] (==) Automatically enabling devices
[   156.848] (WW) The directory "/usr/share/fonts/local" does not exist.
[   156.848]    Entry deleted from font path.
[   156.848] (WW) The directory "/usr/share/fonts/CID" does not exist.
[   156.848]    Entry deleted from font path.
[   156.848] (WW) The directory "/usr/share/fonts/local" does not exist.
[   156.848]    Entry deleted from font path.
[   156.848] (WW) The directory "/usr/share/fonts/CID" does not exist.
[   156.848]    Entry deleted from font path.
[   156.848] (**) FontPath set to:
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic,
   /usr/share/fonts/TTF,
   /usr/share/fonts/OTF,
   /usr/share/fonts/Type1,
   /usr/share/fonts/misc,
   /usr/share/fonts/75dpi/:unscaled,
   /usr/share/fonts/100dpi/:unscaled,
   /usr/share/fonts/75dpi,
   /usr/share/fonts/100dpi,
   /usr/share/fonts/cyrillic
[   156.848] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   156.848] (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   156.848] (WW) Disabling Mouse0
[   156.848] (WW) Disabling Keyboard0
[   156.848] (II) Loader magic: 0x7d2500
[   156.848] (II) Module ABI versions:
[   156.848]    X.Org ANSI C Emulation: 0.4
[   156.848]    X.Org Video Driver: 8.0
[   156.848]    X.Org XInput driver : 11.0
[   156.848]    X.Org Server Extension : 4.0
[   156.849] (--) PCI:*(0:1:0:0) 1002:68ba:174b:e144 rev 0, Mem @ 0xd0000000/268435456, 0xfe8c0000/131072, I/O @ 0x0000b000/256, BIOS @ 0x????????/131072
[   156.849] (II) Open ACPI successful (/var/run/acpid.socket)
[   156.849] (II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) "record" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) "dri" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) "dri2" will be loaded. This was enabled by default and also specified in the config file.
[   156.849] (II) LoadModule: "dri2"
[   156.849] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
[   156.850] (II) Module dri2: vendor="X.Org Foundation"
[   156.850]    compiled for 1.9.5, module version = 1.2.0
[   156.850]    ABI class: X.Org Server Extension, version 4.0
[   156.850] (II) Loading extension DRI2
[   156.850] (II) LoadModule: "dri"
[   156.850] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
[   156.850] (II) Module dri: vendor="X.Org Foundation"
[   156.850]    compiled for 1.9.5, module version = 1.0.0
[   156.850]    ABI class: X.Org Server Extension, version 4.0
[   156.850] (II) Loading extension XFree86-DRI
[   156.850] (II) LoadModule: "dbe"
[   156.850] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
[   156.850] (II) Module dbe: vendor="X.Org Foundation"
[   156.850]    compiled for 1.9.5, module version = 1.0.0
[   156.850]    Module class: X.Org Server Extension
[   156.850]    ABI class: X.Org Server Extension, version 4.0
[   156.850] (II) Loading extension DOUBLE-BUFFER
[   156.850] (II) LoadModule: "extmod"
[   156.850] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
[   156.850] (II) Module extmod: vendor="X.Org Foundation"
[   156.850]    compiled for 1.9.5, module version = 1.0.0
[   156.850]    Module class: X.Org Server Extension
[   156.850]    ABI class: X.Org Server Extension, version 4.0
[   156.850] (II) Loading extension MIT-SCREEN-SAVER
[   156.850] (II) Loading extension XFree86-VidModeExtension
[   156.850] (II) Loading extension XFree86-DGA
[   156.850] (II) Loading extension DPMS
[   156.850] (II) Loading extension XVideo
[   156.850] (II) Loading extension XVideo-MotionCompensation
[   156.850] (II) Loading extension X-Resource
[   156.850] (II) LoadModule: "glx"
[   156.850] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   156.850] (II) Module glx: vendor="X.Org Foundation"
[   156.850]    compiled for 1.9.5, module version = 1.0.0
[   156.850]    ABI class: X.Org Server Extension, version 4.0
[   156.850] (==) AIGLX enabled
[   156.850] (II) Loading extension GLX
[   156.850] (II) LoadModule: "record"
[   156.851] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
[   156.851] (II) Module record: vendor="X.Org Foundation"
[   156.851]    compiled for 1.9.5, module version = 1.13.0
[   156.851]    Module class: X.Org Server Extension
[   156.851]    ABI class: X.Org Server Extension, version 4.0
[   156.851] (II) Loading extension RECORD
[   156.851] (II) LoadModule: "radeon"
[   156.851] (II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
[   156.891] (II) Module radeon: vendor="X.Org Foundation"
[   156.891]    compiled for 1.9.5, module version = 6.14.1
[   156.891]    Module class: X.Org Video Driver
[   156.891]    ABI class: X.Org Video Driver, version 8.0
[   156.891] (II) RADEON: Driver for ATI Radeon chipsets:
   ATI Radeon Mobility X600 (M24) 3150 (PCIE), ATI FireMV 2400 (PCI),
   ATI Radeon Mobility X300 (M24) 3152 (PCIE),
   ATI FireGL M24 GL 3154 (PCIE), ATI FireMV 2400 3155 (PCI),
   ATI Radeon X600 (RV380) 3E50 (PCIE),
   ATI FireGL V3200 (RV380) 3E54 (PCIE), ATI Radeon IGP320 (A3) 4136,
   ATI Radeon IGP330/340/350 (A4) 4137, ATI Radeon 9500 AD (AGP),
   ATI Radeon 9500 AE (AGP), ATI Radeon 9600TX AF (AGP),
   ATI FireGL Z1 AG (AGP), ATI Radeon 9800SE AH (AGP),
   ATI Radeon 9800 AI (AGP), ATI Radeon 9800 AJ (AGP),
   ATI FireGL X2 AK (AGP), ATI Radeon 9600 AP (AGP),
   ATI Radeon 9600SE AQ (AGP), ATI Radeon 9600XT AR (AGP),
   ATI Radeon 9600 AS (AGP), ATI FireGL T2 AT (AGP), ATI Radeon 9650,
   ATI FireGL RV360 AV (AGP), ATI Radeon 7000 IGP (A4+) 4237,
   ATI Radeon 8500 AIW BB (AGP), ATI Radeon IGP320M (U1) 4336,
   ATI Radeon IGP330M/340M/350M (U2) 4337,
   ATI Radeon Mobility 7000 IGP 4437, ATI Radeon 9000/PRO If (AGP/PCI),
   ATI Radeon 9000 Ig (AGP/PCI), ATI Radeon X800 (R420) JH (AGP),
   ATI Radeon X800PRO (R420) JI (AGP),
   ATI Radeon X800SE (R420) JJ (AGP), ATI Radeon X800 (R420) JK (AGP),
   ATI Radeon X800 (R420) JL (AGP), ATI FireGL X3 (R420) JM (AGP),
   ATI Radeon Mobility 9800 (M18) JN (AGP),
   ATI Radeon X800 SE (R420) (AGP), ATI Radeon X800XT (R420) JP (AGP),
   ATI Radeon X800 VE (R420) JT (AGP), ATI Radeon X850 (R480) (AGP),
   ATI Radeon X850 XT (R480) (AGP), ATI Radeon X850 SE (R480) (AGP),
   ATI Radeon X850 PRO (R480) (AGP), ATI Radeon X850 XT PE (R480) (AGP),
   ATI Radeon Mobility M7 LW (AGP),
   ATI Mobility FireGL 7800 M7 LX (AGP),
   ATI Radeon Mobility M6 LY (AGP), ATI Radeon Mobility M6 LZ (AGP),
   ATI FireGL Mobility 9000 (M9) Ld (AGP),
   ATI Radeon Mobility 9000 (M9) Lf (AGP),
   ATI Radeon Mobility 9000 (M9) Lg (AGP), ATI Radeon 9700 Pro ND (AGP),
   ATI Radeon 9700/9500Pro NE (AGP), ATI Radeon 9600TX NF (AGP),
   ATI FireGL X1 NG (AGP), ATI Radeon 9800PRO NH (AGP),
   ATI Radeon 9800 NI (AGP), ATI FireGL X2 NK (AGP),
   ATI Radeon 9800XT NJ (AGP),
   ATI Radeon Mobility 9600/9700 (M10/M11) NP (AGP),
   ATI Radeon Mobility 9600 (M10) NQ (AGP),
   ATI Radeon Mobility 9600 (M11) NR (AGP),
   ATI Radeon Mobility 9600 (M10) NS (AGP),
   ATI FireGL Mobility T2 (M10) NT (AGP),
   ATI FireGL Mobility T2e (M11) NV (AGP), ATI Radeon QD (AGP),
   ATI Radeon QE (AGP), ATI Radeon QF (AGP), ATI Radeon QG (AGP),
   ATI FireGL 8700/8800 QH (AGP), ATI Radeon 8500 QL (AGP),
   ATI Radeon 9100 QM (AGP), ATI Radeon 7500 QW (AGP/PCI),
   ATI Radeon 7500 QX (AGP/PCI), ATI Radeon VE/7000 QY (AGP/PCI),
   ATI Radeon VE/7000 QZ (AGP/PCI), ATI ES1000 515E (PCI),
   ATI Radeon Mobility X300 (M22) 5460 (PCIE),
   ATI Radeon Mobility X600 SE (M24C) 5462 (PCIE),
   ATI FireGL M22 GL 5464 (PCIE), ATI Radeon X800 (R423) UH (PCIE),
   ATI Radeon X800PRO (R423) UI (PCIE),
   ATI Radeon X800LE (R423) UJ (PCIE),
   ATI Radeon X800SE (R423) UK (PCIE),
   ATI Radeon X800 XTP (R430) (PCIE), ATI Radeon X800 XL (R430) (PCIE),
   ATI Radeon X800 SE (R430) (PCIE), ATI Radeon X800 (R430) (PCIE),
   ATI FireGL V7100 (R423) (PCIE), ATI FireGL V5100 (R423) UQ (PCIE),
   ATI FireGL unknown (R423) UR (PCIE),
   ATI FireGL unknown (R423) UT (PCIE),
   ATI Mobility FireGL V5000 (M26) (PCIE),
   ATI Mobility FireGL V5000 (M26) (PCIE),
   ATI Mobility Radeon X700 XL (M26) (PCIE),
   ATI Mobility Radeon X700 (M26) (PCIE),
   ATI Mobility Radeon X700 (M26) (PCIE),
   ATI Radeon X550XTX 5657 (PCIE), ATI Radeon 9100 IGP (A5) 5834,
   ATI Radeon Mobility 9100 IGP (U3) 5835,
   ATI Radeon XPRESS 200 5954 (PCIE),
   ATI Radeon XPRESS 200M 5955 (PCIE), ATI Radeon 9250 5960 (AGP),
   ATI Radeon 9200 5961 (AGP), ATI Radeon 9200 5962 (AGP),
   ATI Radeon 9200SE 5964 (AGP), ATI FireMV 2200 (PCI),
   ATI ES1000 5969 (PCI), ATI Radeon XPRESS 200 5974 (PCIE),
   ATI Radeon XPRESS 200M 5975 (PCIE),
   ATI Radeon XPRESS 200 5A41 (PCIE),
   ATI Radeon XPRESS 200M 5A42 (PCIE),
   ATI Radeon XPRESS 200 5A61 (PCIE),
   ATI Radeon XPRESS 200M 5A62 (PCIE),
   ATI Radeon X300 (RV370) 5B60 (PCIE),
   ATI Radeon X600 (RV370) 5B62 (PCIE),
   ATI Radeon X550 (RV370) 5B63 (PCIE),
   ATI FireGL V3100 (RV370) 5B64 (PCIE),
   ATI FireMV 2200 PCIE (RV370) 5B65 (PCIE),
   ATI Radeon Mobility 9200 (M9+) 5C61 (AGP),
   ATI Radeon Mobility 9200 (M9+) 5C63 (AGP),
   ATI Mobility Radeon X800 XT (M28) (PCIE),
   ATI Mobility FireGL V5100 (M28) (PCIE),
   ATI Mobility Radeon X800 (M28) (PCIE), ATI Radeon X850 5D4C (PCIE),
   ATI Radeon X850 XT PE (R480) (PCIE),
   ATI Radeon X850 SE (R480) (PCIE), ATI Radeon X850 PRO (R480) (PCIE),
   ATI unknown Radeon / FireGL (R480) 5D50 (PCIE),
   ATI Radeon X850 XT (R480) (PCIE),
   ATI Radeon X800XT (R423) 5D57 (PCIE),
   ATI FireGL V5000 (RV410) (PCIE), ATI Radeon X700 XT (RV410) (PCIE),
   ATI Radeon X700 PRO (RV410) (PCIE),
   ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X700 (RV410) (PCIE),
   ATI Radeon X700 SE (RV410) (PCIE), ATI Radeon X1800,
   ATI Mobility Radeon X1800 XT, ATI Mobility Radeon X1800,
   ATI Mobility FireGL V7200, ATI FireGL V7200, ATI FireGL V5300,
   ATI Mobility FireGL V7100, ATI Radeon X1800, ATI Radeon X1800,
   ATI Radeon X1800, ATI Radeon X1800, ATI Radeon X1800,
   ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
   ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
   ATI Mobility Radeon X1400, ATI Radeon X1300/X1550,
   ATI Radeon X1550 64-bit, ATI Mobility Radeon X1300,
   ATI Mobility Radeon X1300, ATI Mobility Radeon X1300,
   ATI Mobility Radeon X1300, ATI Radeon X1300, ATI Radeon X1300,
   ATI RV505, ATI RV505, ATI FireGL V3300, ATI FireGL V3350,
   ATI Radeon X1300, ATI Radeon X1550 64-bit, ATI Radeon X1300/X1550,
   ATI Radeon X1600, ATI Radeon X1300/X1550, ATI Mobility Radeon X1450,
   ATI Radeon X1300/X1550, ATI Mobility Radeon X2300,
   ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
   ATI Mobility Radeon X1350, ATI Mobility Radeon X1450,
   ATI Radeon X1300, ATI Radeon X1550, ATI Mobility Radeon X1350,
   ATI FireMV 2250, ATI Radeon X1550 64-bit, ATI Radeon X1600,
   ATI Radeon X1650, ATI Radeon X1600, ATI Radeon X1600,
   ATI Mobility FireGL V5200, ATI Mobility Radeon X1600,
   ATI Radeon X1650, ATI Radeon X1650, ATI Radeon X1600,
   ATI Radeon X1300 XT/X1600 Pro, ATI FireGL V3400,
   ATI Mobility FireGL V5250, ATI Mobility Radeon X1700,
   ATI Mobility Radeon X1700 XT, ATI FireGL V5200,
   ATI Mobility Radeon X1700, ATI Radeon X2300HD,
   ATI Mobility Radeon HD 2300, ATI Mobility Radeon HD 2300,
   ATI Radeon X1950, ATI Radeon X1900, ATI Radeon X1950,
   ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
   ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
   ATI Radeon X1900, ATI Radeon X1900, ATI Radeon X1900,
   ATI AMD Stream Processor, ATI Radeon X1900, ATI Radeon X1950,
   ATI RV560, ATI RV560, ATI Mobility Radeon X1900, ATI RV560,
   ATI Radeon X1950 GT, ATI RV570, ATI RV570, ATI FireGL V7400,
   ATI RV560, ATI Radeon X1650, ATI Radeon X1650, ATI RV560,
   ATI Radeon 9100 PRO IGP 7834, ATI Radeon Mobility 9200 IGP 7835,
   ATI Radeon X1200, ATI Radeon X1200, ATI Radeon X1200,
   ATI Radeon X1200, ATI Radeon X1200, ATI RS740, ATI RS740M, ATI RS740,
   ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 XT,
   ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro, ATI Radeon HD 2900 GT,
   ATI FireGL V8650, ATI FireGL V8600, ATI FireGL V7600,
   ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
   ATI Radeon 4800 Series, ATI Radeon HD 4850 x2,
   ATI FirePro V8750 (FireGL), ATI FirePro V7760 (FireGL),
   ATI Mobility RADEON HD 4850, ATI Mobility RADEON HD 4850 X2,
   ATI Radeon 4800 Series, ATI FirePro RV770, AMD FireStream 9270,
   AMD FireStream 9250, ATI FirePro V8700 (FireGL),
   ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
   ATI Mobility RADEON HD 4870, ATI Radeon 4800 Series,
   ATI Radeon 4800 Series, ATI FirePro M7750, ATI M98, ATI M98, ATI M98,
   ATI Mobility Radeon HD 4650, ATI Radeon RV730 (AGP),
   ATI Mobility Radeon HD 4670, ATI FirePro M5750,
   ATI Mobility Radeon HD 4670, ATI Radeon RV730 (AGP),
   ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
   ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
   ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
   ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
   ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
   ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI Radeon HD 4770,
   ATI FirePro M5750, ATI RV610, ATI Radeon HD 2400 XT,
   ATI Radeon HD 2400 Pro, ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000,
   ATI RV610, ATI Radeon HD 2350, ATI Mobility Radeon HD 2400 XT,
   ATI Mobility Radeon HD 2400, ATI RADEON E2400, ATI RV610,
   ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
   ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
   ATI Mobility Radeon HD 3850 X2, ATI RV670,
   ATI Mobility Radeon HD 3870, ATI Mobility Radeon HD 3870 X2,
   ATI Radeon HD3870 X2, ATI FireGL V7700, ATI Radeon HD3850,
   ATI Radeon HD3690, AMD Firestream 9170, ATI Radeon HD 4550,
   ATI Radeon RV710, ATI Radeon RV710, ATI Radeon RV710,
   ATI Radeon HD 4350, ATI Mobility Radeon 4300 Series,
   ATI Mobility Radeon 4500 Series, ATI Mobility Radeon 4500 Series,
   ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
   ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
   ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
   ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
   ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
   ATI FireGL V3600, ATI Radeon HD 2600 LE,
   ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
   ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
   ATI Radeon HD 3450, ATI Radeon HD 3450, ATI Radeon HD 3430,
   ATI Radeon HD 3450, ATI FirePro V3700, ATI FireMV 2450,
   ATI FireMV 2260, ATI FireMV 2260, ATI Radeon HD 3600 Series,
   ATI Radeon HD 3650 AGP, ATI Radeon HD 3600 PRO,
   ATI Radeon HD 3600 XT, ATI Radeon HD 3600 PRO,
   ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
   ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
   ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
   ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
   ATI Radeon HD 3300 Graphics, ATI Radeon HD 3200 Graphics,
   ATI Radeon 3000 Graphics, ATI Radeon HD 4200, ATI Radeon 4100,
   ATI Mobility Radeon HD 4200, ATI Mobility Radeon 4100,
   ATI Radeon HD 4290, ATI Radeon HD 4250, AMD Radeon HD 6310 Graphics,
   AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
   AMD Radeon HD 6250 Graphics, CYPRESS,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
   AMD Firestream 9350, ATI Radeon HD 5800 Series,
   ATI Radeon HD 5800 Series, ATI Radeon HD 5800 Series,
   ATI Radeon HD 5900 Series, ATI Radeon HD 5900 Series,
   ATI Mobility Radeon HD 5800 Series,
   ATI Mobility Radeon HD 5800 Series,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI Mobility Radeon HD 5800 Series, ATI Radeon HD 5700 Series,
   ATI Radeon HD 5700 Series, ATI Radeon HD 5700 Series,
   ATI Mobility Radeon HD 5000 Series,
   ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI FirePro (FireGL) Graphics Adapter, ATI Radeon HD 5670,
   ATI Radeon HD 5570, ATI Radeon HD 5500 Series, REDWOOD,
   ATI Mobility Radeon HD 5000 Series,
   ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon Graphics,
   ATI Mobility Radeon Graphics, CEDAR,
   ATI FirePro (FireGL) Graphics Adapter,
   ATI FirePro (FireGL) Graphics Adapter, ATI FirePro 2270, CEDAR,
   ATI Radeon HD 5450, CEDAR, CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN,
   CAYMAN, CAYMAN, CAYMAN, CAYMAN, CAYMAN, AMD Radeon HD 6900 Series,
   AMD Radeon HD 6900 Series, CAYMAN, CAYMAN,
   AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
   BARTS, Mobility Radeon HD 6000 Series,
   Mobility Radeon HD 6000 Series, BARTS, BARTS, BARTS, BARTS,
   AMD Radeon HD 6800 Series, AMD Radeon HD 6800 Series, TURKS, TURKS,
   TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS, TURKS,
   TURKS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS, CAICOS,
   CAICOS, CAICOS, CAICOS, CAICOS
[   156.894] (--) using VT number 7

[   156.895] (EE) No devices detected.
[   156.895]
Fatal server error:
[   156.895] no screens found
[   156.895]
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   156.895] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   156.895]


La scheda in questione e' una radeon 6770.
Che non venga riconosciuta come dovrebbe?

Questo invece e' xorg.conf, cosi' come viene generato da xorgsetup con la sola modifica al driver da usare

Codice: Seleziona tutto
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
   ModulePath   "/usr/lib64/xorg/modules"
   FontPath     "/usr/share/fonts/local"
   FontPath     "/usr/share/fonts/TTF"
   FontPath     "/usr/share/fonts/OTF"
   FontPath     "/usr/share/fonts/Type1"
   FontPath     "/usr/share/fonts/misc"
   FontPath     "/usr/share/fonts/CID"
   FontPath     "/usr/share/fonts/75dpi/:unscaled"
   FontPath     "/usr/share/fonts/100dpi/:unscaled"
   FontPath     "/usr/share/fonts/75dpi"
   FontPath     "/usr/share/fonts/100dpi"
   FontPath     "/usr/share/fonts/cyrillic"
EndSection

Section "Module"
   Load  "dri2"
   Load  "dri"
   Load  "dbe"
   Load  "extmod"
   Load  "glx"
   Load  "record"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
   Identifier  "Card0"
   Driver      "radeon"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
   SubSection "Display"
      Viewport   0 0
      Depth     1
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     4
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     8
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     15
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     16
   EndSubSection
   SubSection "Display"
      Viewport   0 0
      Depth     24
   EndSubSection
EndSection

Ho provato a cambiare/togliere i moduli caricati come scritto in qualche wiki, ma e' sempre la stessa solfa!

Grazie! :)

EDIT: viste le dimensioni bibliche non riesco a postare il log generato quando tento di far partire kde con "startx" (supera il limite dei 60000 caratteri per i post).
Se dovesse tornare utile fatemi sapere che lo allego al post.
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda 414N » lun giu 04, 2012 22:21

La tua scheda è troppo nuova per i driver X presenti in Slackware 13.37 (per non parlare di Mesa). Lo puoi vedere dal log di X: subito dopo il caricamento del modulo radeon è segnalato un errore ([ 156.895] (EE) No devices detected.) il quale indica che non sono stati trovati dispositivi compatibili col driver radeon.
A parte l'aggiornamento di X e Mesa (che comportano altri aggiornamenti a ruota che comunque non ti porterebbero in una situazione decente a livello di accelerazione hardware) credo proprio che ti convenga ripiegare sui driver proprietari della AMD per il momento.
Puoi creare un pacchetto per Slackware del driver proprietario usando l'opzione "--buildpkg Slackware" con lo script installer, dopo averlo scaricato.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Configurazione X e driver open ati

Messaggioda -sf » mar giu 05, 2012 23:48

Caspita... e se faccio un upgrade completo alla current?
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Configurazione X e driver open ati

Messaggioda 414N » mer giu 06, 2012 6:28

Dovresti disporre di un'accelerazione 2D/3D di base, comunque molto inferiore a quella fornita dal driver proprietario.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Configurazione X e driver open ati

Messaggioda -sf » mer giu 06, 2012 23:34

Grazie mille per le info!
Provero' a prendere quello che mi serve dalla current (o faccio un upgrade direttamente) e faro' un confronto con i driver amd... magari i driver open mi bastano per il momento.

Tra l'altro colgo l'occasione per un altra domanda: sarebbe possibile installare entrambi i driver ed effettuare un switch a quelli closed quando serve? Anche manualmente si intende, alla fine l'utilizzo primario non sono applicazioni grafiche pesanti quindi anche la minima accellerazione fornita dai driver open potrebbe bastarmi per l'uso quotidiano.

Grazie! :)
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron