Repository 32bit  Forum
Repository 64bit  Wiki

Attivare audio hdmi

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Attivare audio hdmi

Messaggioda RedSkull92 » lun giu 04, 2012 20:35

Salve, da quando ho il mio portatile non sono mai riuscito a far sentire l'audio sul televisore connesso tramite hdmi, mi sapreste dare una mano per riuscire a configurare le impostazioni audio ?
L'audio sul portatile mi funziona egregiamente, idem per il video sul televisore ma l'audio non si decide proprio a partire.

Ho un Acer Aspire 5745G, scheda grafica NVIDIA GeForce GT 330M.
Ecco aplay -l
Codice: Seleziona tutto
┌─$[~]
└─>aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC271X Analog [ALC271X Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC271X Digital [ALC271X Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


Codice: Seleziona tutto
┌─$[~]
└─>cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel


Codice: Seleziona tutto
┌─$[~]
└─>cat /proc/asound/cards 
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xb7100000 irq 22
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xb3000000 irq 16


Se vi servono altre info basta chiedere, grazie per l'eventuale aiuto.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda RedSkull92 » mar giu 05, 2012 20:33

Ho scoperto che funziona sul device 1,7 ma alsamixer non mi dice nulla, qualche consiglio ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda robbybby » mer giu 06, 2012 11:31

Io avevo un problema del genere. La soluzione è stata inserire i vari device in /etc/modprobe.d/sound.conf
Non ho mai provato se l'HDMI funziona, però lo vedo in alsamixer. Il mio problema primario era assegnare il microfono della webcam.
Vedi se ti può essere di aiuto.

Codice: Seleziona tutto
Adesso ha un aspetto del genere:
options id=SB index=0
alias snd-card-0 id=SB
alias sound-slot-0 id=SB
options id=SB position_fix=1 model=3stack-6ch

options snd-usb-audio index=1
alias snd-card-1 snd-usb-audio
alias sound-slot-1 snd-usb-audio

options id=NVidia index=2 enable_msi=0 enable=1                                                     
alias snd-card-2 id=NVidia                                                                         
alias sound-slot-2 id=NVidia
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » mer giu 06, 2012 11:37

qual è la tua configurazione ?
mi posti il risultato del comando aplay -l?
Per cosa sta alla fine "index=2" ?
Perché ho modificato alias snd-card-2 in alias snd-card-1 dato che io ho solo la card 0 e 1 (1 = nVidia)
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda robbybby » mer giu 06, 2012 11:59

Sì, questa è la mia configurazione.
Una è la scheda audio integrata nella MB (una delle solite Realtek), una è l'HDMI della scheda video e la rimanente è il microfono della webcam usb.


$ aplay -l
Codice: Seleziona tutto
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


index=2 mi sembra sia l'indice a cui farà riferimento alsamixer.

PS:
/proc/asound/pcm mi mostra correttamente la scheda HDMI
Codice: Seleziona tutto
00-00: ALC889A Analog : ALC889A Analog : playback 1 : capture 1
00-01: ALC889A Digital : ALC889A Digital : playback 1 : capture 1
00-02: ALC889A Analog : ALC889A Analog : capture 2
01-00: USB Audio : USB Audio : capture 1
02-03: HDMI 0 : HDMI 0 : playback 1
02-07: HDMI 0 : HDMI 0 : playback 1
02-08: HDMI 0 : HDMI 0 : playback 1
02-09: HDMI 0 : HDMI 0 : playback 1


PPS:
Con
speaker-test -D plughw:2,7 -c6 -r19200 -FS32_LE
non mi dà errori (idem con plughw:2,3 e anche 8 e 9), quindi ALSA vede correttamente le uscite HDMI della scheda vide nVidia (seconda scheda video, ecco che ritorna il 2 di cui abbiamo detto sopra). Penso tu possa lasciare tranquillamente 2, anche se ti manca la terza scheda audio. La mia scheda 1 è la webcam, che non è nemmeno sempre collegata, ma tutto funziona lo stesso.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » mer giu 06, 2012 19:38

speaker-test -D plughw:2,7 -c6 -r19200 -FS32_LE
Mi dà errori.
Ho modificato 2,7 con 1,7 e funziona. (Questo perché io ho solo la scheda 0 e la scheda 1)
Fa tipo un fruscio negli speaker del monitor a cui sono collegato.
Ho modificato /etc/modprobe.d/sound.conf così:
Codice: Seleziona tutto

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.23 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---
options id=NVidia index=1 enable_msi=0 enable=1                                                     
alias snd-card-1 id=NVidia                                                                         
alias sound-slot-1 id=NVidia


Ma alsamixer continua a non funzionare per quanto riguarda la scheda Nvidia.
ecco alcuni screenshot:
alsamixer con la scheda intel:
Immagine

alsamixer con la scheda nvidia
Immagine

Come risolvo ?
ah, ecco come ho in /proc/asound/pcm
Codice: Seleziona tutto

00-00: ALC271X Analog : ALC271X Analog : playback 1 : capture 1
00-01: ALC271X Digital : ALC271X Digital : playback 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda erio » mer giu 06, 2012 20:22

vai su spidf 1 evidenzialo e dai m dalla tastiera,
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1069
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Attivare audio hdmi

Messaggioda robbybby » mer giu 06, 2012 20:49

E' già acceso. M lo spegnerebbe.
Ho controllato: fa lo stesso anche a me.
Il fruscio è normale: speakertest butta fuori rumore rosa, che è percepito da noi umani come fruscio.
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » mer giu 06, 2012 20:57

Quindi quale potrebbe essere il problema ?
Come risolvo ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda robbybby » mer giu 06, 2012 22:17

Non ne ho idea.
Mi vengono in mente solo un paio di considerazioni:
1. Se con speakertest senti il fruscio, la scheda funziona e viene vista dal s.o.
2. Penso sia normale che alsamixer non possa regolare il volume, ma solo fare on/off, dato che è un'uscita digitale.
3. Non è che occorra configurare il programma che usi per vedere i video/ascoltare la musica in modo che usi l'uscita HDMI che hai appena configurato?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » mer giu 06, 2012 23:38

Credo che il problema sia principalmente "reedirezionare" il suono dalla scheda intel a quella nvidia quindi al monitor.
Per esempio in chromium o firefox che usano flash come diamine faccio ?
Con mplayer ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda robbybby » gio giu 07, 2012 10:45

Ho provato con VLC, e lì c'è la scheda nelle opzioni.
Per flash non ne ho proprio idea.
Hai provato a vedere nelle impostazioni del desktop environment?
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » gio giu 07, 2012 13:36

con vlc mi dà questo:
Immagine
Mi vede il device 0 quando quello che funziona è solo il device 3, come cambiarlo ?
Uso fluxbox.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Attivare audio hdmi

Messaggioda robbybby » gio giu 07, 2012 14:44

A me li dà tutti, ma dopo aver attivato le opzioni complete, e in un'altra sezione delle impostazioni.
PS: ho ricontrollato: me li dà tutti anche nelle impostazioni come le tue. Io uso la versione 1.1.9.
Allegati
vlc1.png
VLC
vlc1.png (59.22 KiB) Osservato 573 volte
Avatar utente
robbybby
Linux 3.x
Linux 3.x
 
Messaggi: 1172
Iscritto il: sab dic 16, 2006 10:48
Località: Fra Trantor e Terminus
Slackware: 13.1 / 64 bit
Kernel: 3.3.x
Desktop: KDE 4.4.5

Re: Attivare audio hdmi

Messaggioda RedSkull92 » gio giu 07, 2012 17:31

Io uso la 2.0.1 e mi continua a dare la 0
Quale potrebbe essere il problema ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti