Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] problema con PHP e Mysql in current

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] problema con PHP e Mysql in current

Messaggioda ermes » sab giu 16, 2012 11:31

ciao a tutti.
come descritto in un post di qualche tempo fa ho avuto problemi con i nuovi aggiornamenti in current di Mysql, Php, e Apache.
Il problema era legato ad alcune pagine che utilizzavano vecchie versioni di librerie Pear e che con l'aggiornamento di PHP non funzionavano più a dovere.
Sono dovuto tornare ai pacchetti della 13.37 e finalmente ho deciso di creare una macchina virtuale dove sperimentare gli aggiornamenti della current prima di installarli anche sulla macchina che mi serve per la produzione.
Dopo questa lunga e forse inutile premessa, la situazione è questa:
Macchina virtuale con current a 64 bit. Apache e Mysql attivi.
Installo Phpmyadmin e mi ritrovo con questo messaggio:
Codice: Seleziona tutto
phpMyAdmin - Error
The mysql extension is missing. Please check your PHP configuration. <a href="Documentation.html#faqmysql" target="documentation"><img class="icon" src="./themes/pmahomme/img/b_help.png" width="11" height="11" alt="Documentation" title="Documentation" /></a>


ho provato a verificare php.ini e tutto sembra a posto... il path delle estensioni è quello giusto, la libreria mysql.so è decommentata...

qualche idea ?
Ultima modifica di ermes il sab giu 16, 2012 14:17, modificato 1 volta in totale.
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: problam con PHP e Mysql in current

Messaggioda targzeta » sab giu 16, 2012 11:34

Ma quando lanci apache, il file di log che dice?
Codice: Seleziona tutto
/var/log/httpd/error_log

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: problam con PHP e Mysql in current

Messaggioda ermes » sab giu 16, 2012 12:16

ecco, non mi sembra ci sia niente di strano... o no ?

Codice: Seleziona tutto
[Sat Jun 16 13:12:27.801901 2012] [mpm_event:notice] [pid 2280:tid 139763713173376] AH00491: caught SIGTERM, shutting down
[Sat Jun 16 13:12:30.381312 2012] [mpm_event:notice] [pid 2902:tid 140687463868288] AH00489: Apache/2.4.2 (Unix) PHP/5.4.3 configured -- resuming normal operations
[Sat Jun 16 13:12:30.381438 2012] [core:notice] [pid 2902:tid 140687463868288] AH00094: Command line: '/usr/sbin/httpd'
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: problam con PHP e Mysql in current

Messaggioda conraid » sab giu 16, 2012 13:25

ma stai usando gli stessi file di configurazione della 13.37 per php, apache e mysql?
phpinfo() che ti dice?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: problam con PHP e Mysql in current

Messaggioda ermes » sab giu 16, 2012 14:00

no
l'installazione è nuova di pacca e ho modificato i file di configurazione per attivare il php

ho provato anche a scaricare l'ultima versione di phpmyadmin sperando fosse un problema legato alle vecchie versioni... ma niente
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde

Re: problam con PHP e Mysql in current

Messaggioda ermes » sab giu 16, 2012 14:17

provato a ri-installare e riconfigurare mysql
e al riavvio successivo tutto a posto.

cosa sia successo non lo so... boh!

grazie comunque
Avatar utente
ermes
Linux 2.4
Linux 2.4
 
Messaggi: 338
Iscritto il: dom feb 20, 2005 0:00
Località: Rho (Mi)
Slackware: current 64
Desktop: kde


Torna a Packages

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 2 ospiti