Repository 32bit  Forum
Repository 64bit  Wiki

problema cdrecord

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

problema cdrecord

Messaggioda rfringuello89 » ven giu 08, 2012 16:45

Quando provo a masterizzare con k3b o altre vie, mi viene restituito un errore in sostanza mi viene detto che la velocità del disco non è compatibile con quella del masterizzatore. In realtà so per certo che siano compatibili visto che su windows non ho problemi. Da cosa potrebbe dipendere? Per far riconoscere il masterizzatore ho dovuto lavorare parecchio a livello di kernel; che sia ancora li il problema?

Grazie a tutti
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda joseph » ven giu 08, 2012 21:48

"cdrecord -scanbus" ti ritorna i valori giusti ?
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: problema cdrecord

Messaggioda rfringuello89 » sab giu 09, 2012 8:24

questa è l'unica riga che riguarda il masterizzatore

Codice: Seleziona tutto
scsibus3:
        3,0,0   300) 'MATSHITA' 'DVD+-RW UJ-857G ' 'Z111' Removable CD-ROM
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda joseph » lun giu 11, 2012 16:56

Guarda prova un pò cosi:
Codice: Seleziona tutto
cdrecord -v -dummy -eject speed=quellochevuoi dev=3,0,0 file

Vedi un pò se ti riconosce la velocità, il -dummy dovrebbe fare solo la simulazione (quindi non dovrebbe scrivere nulla sul DVD) :D
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: problema cdrecord

Messaggioda rfringuello89 » mar giu 12, 2012 7:45

Questo è l'output del comando dopo il tentativo di scrittura su un CD-RW, il problema si presenta uguale anche con DVD non RW
Codice: Seleziona tutto
cdrecord: Probably trying to use ultra high speed+ medium on improper writer.
cdrecord: fifo had 64 puts and 0 gets.
cdrecord: fifo was 0 times empty and 1 times full, min fill was 0%.
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda joseph » mar giu 12, 2012 8:11

E se invece provi cosi:

Codice: Seleziona tutto
hdparm -E velocità /dev/dvd


dove -E sarebbe " -E Set cd/dvd drive speed", e provi a masterizzare. :)
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: problema cdrecord

Messaggioda rfringuello89 » mer giu 20, 2012 15:39

Sempre uguale!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda rik70 » mer giu 20, 2012 16:42

Se puoi, prova a masterizzare con Xfburn: trovi tutto su SlackBuilds.org.

Se va, è un problema di cdrecord, altrimenti è roba hardware.

P.s.

Cosa intendi per "lavorare parecchio a livello di kernel per far riconoscere il masterizzatore"? Cosa hai fatto di preciso?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: problema cdrecord

Messaggioda rfringuello89 » ven giu 22, 2012 17:37

Allora, ho provato Xfburn e purtroppo non riesco a masterizzare neanche con lui, l'output della shell è:

Codice: Seleziona tutto
** (xfburn:28454): WARNING **: [FATAL] 131357: SCSI error on write(-150,16): [3 73 03] Medium error. Power calibration area error. (0)

** (xfburn:28454): WARNING **: [FATAL] 131339: Burn run failed (0)


Con il fatto del kernel, intendevo dire che inizialmente potevo masterizzare, poi il masterizzatore non veniva più riconosciuto da kde e k3b. Cambiando delle impostazioni nel kernel sono riuscito a farlo rilevare come /dev/sr0 mentre prima era semplicemente /dev/hda (quando non veniva riconosciuto).

RIuscivo ancora a masterizzare con uno dei kernel di default ma dopo averlo aggiornato, anche con esso non funzionava più. Non vorrei bisogni limare ancora qualcosa a livello di kernel, altrimenti significa che è proprio andato il masterizzatore in effetti su windows è un po' che non provo più a masterizzare anche considerando che non ho interesse a installare programmi come Nero. In realtà masterizzo molto poco però ogni volta che capita mi tocca collegare quello esterno ed è una scocciatura soprattutto se non sono a casa!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda rik70 » ven giu 22, 2012 17:51

Senti, ma il masterizzatore non è stato più riconosciuto di punto in bianco, oppure dopo aggiornamenti... etc?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: problema cdrecord

Messaggioda erio » ven giu 22, 2012 17:59

se hai a disposizione un'altro masterizzatore provalo,power error calibration,ha a che fare con il laser, prova a pulire la lente del laser,aumentare la potenza del laser tramite trimmer?difficile ,corrente insufficiente.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: problema cdrecord

Messaggioda rfringuello89 » ven giu 22, 2012 19:17

Allora il masterizzatore non venne più riconosciuto (strana coincidenza) da quando kde ha deciso di non usare più hal, forse è stato quello o forse è stato qualche cambio nel kernel (ma io ho attribuito il problema a kde4) e in seguito dopo credo un anno modificando il kernel sono riuscito a farlo riconoscere ma non a farlo masterizzare (se non con kernel default come su detto).

L'altro masterizzatore che ho è un masterizzatore esterno e funziona perfettamente, tieni presente che non posso provarne un altro in quanto il mio computer è un laptop Dell xps 1330. Se il problema fosse la lente potrebbe non masterizzare ma comunque leggere correttamente i cd/dvd? (tra l'altro ho notato che alcuni dvd probabilmente ormai malconci non vengono letti ma vengono letti da quello esterno)
Per quanto riguarda gli altri tentativi come calibrazione etc. non penso sia alla mia altezza!
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda rik70 » sab giu 23, 2012 13:33

Uhm...io propenderei x un problema hardware del masterizzatore. La prova del 9 sarebbe fare il boot con una distro live e tentare una scrittura con cdrecord.

Però non mi è chiara una cosa:

come mai il disco veniva visto come /dev/hda?

/dev/hd{a,b,c,d,etc} apartengono al passato ormai, niente oggi devrebbe essere visto in quel modo. Come mai è successo questo? O volevi dire /dev/sda?

Ancora: scusa se sono duro di comprendonio, ma cosa hai fatto di preciso per forzare il kernel a riconoscere il drive come /dev/sr0?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: problema cdrecord

Messaggioda rfringuello89 » sab giu 23, 2012 17:16

Si ho scritto bene! Il drive veniva visto come /dev/hda !! Tant'è che provai anche a usare l'emulazione SCSI senza successo per fare in modo che venisse rilevato.

Il masterizzatore è stato nuovamente visto da kde quando nel kernel sono passato da usare:
-ATA/ATAPI/MFM/RLL support

a usare:
-Serial ATA and Parallel ATA drivers

Ho pensato che qualcosa sia stato spostato al passare delle versioni del kernel e per quel motivo non venisse più visto il mio masterizzatore in modo corretto.
"When you know Slackware, you know Linux… when you know Red Hat, all you know is Red Hat."
Avatar utente
rfringuello89
Linux 2.4
Linux 2.4
 
Messaggi: 244
Iscritto il: sab feb 21, 2009 18:47
Nome Cognome: Renato Fringuello
Slackware: 64 current
Kernel: 3.13.3
Desktop: kde 4.12.4 [Alien]

Re: problema cdrecord

Messaggioda rik70 » dom giu 24, 2012 12:31

rfringuello89 ha scritto:Il masterizzatore è stato nuovamente visto da kde quando nel kernel sono passato da usare:
-ATA/ATAPI/MFM/RLL support

a usare:
-Serial ATA and Parallel ATA drivers


Ecco questa è la cosa "strana" che non capisco:

-ATA/ATAPI/MFM/RLL support non è piu usato gia da un po' e non è più supportato ufficialmente da udev. Sin dalla versione 13.1 di slackware viene usato al suo posto "Serial ATA and Parallel ATA drivers".

Ti chiedo a questo punto:

a quali versioni del kernel e/o di slackware ti riferisci quando dici che hai fatto il passaggio da ATA/ATAPI --> SATA/PATA ?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1255
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti