Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Problemi con permessi e autologin su Slackware13.37

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]Problemi con permessi e autologin su Slackware13.37

Messaggioda joe » gio lug 05, 2012 10:01

Ho installato slackware-13.37 su un vecchio PC..
Ho creato un account per l'utente semplice con adduser aggiungendolo anche ai gruppi necessari per varie operazioni più delicate, in pratica quando adduser propone l'aggiunta a questi gruppi premendo mi pare la freccia "SU", io ho dato freccia su e premuto invio. Insomma alla fine se non ricordo male funzionava tutto come ci si aspetta, quindi riuscivo a fare il login senza problemi, avviare X (pur con qualche problema con kde che però dovrei riuscire a mettere apposto).

Poi dopo qualche settimana, ho deciso di configurare l'autologin, come già ho fatto da tempo sulla mia slackware-13.1.
Praticamente il tutto consiste nel creare un piccolo programmino in C, compilarlo ed installarlo (io ne ho fatto un pacchetto slackware txz). Vi posto il sorgente:
Codice: Seleziona tutto
#include <unistd.h>

int main(void) {
           execlp("login", "login", "-f", "USERNAME", NULL);
}

Occhio che al posto di USERNAME va messo il nomeutente per l'account che si vuole avviare automaticamente all'avvio.
Poi si edita /etc/inittab aggiungendo la riga seguente e commentando quella superflua:
Codice: Seleziona tutto
# These are the standard console login getties in multiuser mode:
c1:2345:respawn:/sbin/agetty -n -l /usr/bin/autologin 38400 tty1 linux
#c1:1235:respawn:/sbin/agetty 38400 tty1 linux

Ok. Questo dovrebbe essere sufficente per non dover immettere utente e password al login. Di fatto avviando in init3 quindi in console, mi ritrovo che sulla tty1 sono già loggato come l'utente che ho scelto come default, per esempio sul mio portatile mi ritrovo la shell di "joe".
Ok. Però la cosa utile di qesta modalità è che possiamo anche associare un comando all'autologin che avviene sulla tty. Lo si può fare attraverso il file ".bash_profile", per fare un esempio nel mio caso specifico ho messo:
Codice: Seleziona tutto
 cat /home/joe/.bash_profile
. .bashrc
if [[ -z $DISPLAY && $(tty) = /dev/tty1 ]]; then
  /usr/bin/startx
fi

Che in pratica vuol dire, se ti sei appena loggato sulla tty1 lancia startx e quindi si avvia il server grafico.
Tutto questo per ottenre la situazione: accendo il PC e mi ritrovo in ambiente grafico già loggato come utente semplice scelto come default. Lo trovo molto comodo.

Problema. Sul PC con slackware-13.37 ho fatto la stessa cosa, il login automatico lo fa ma non esegue startx perchè dice che non ha i permessi per farlo. Inoltre dopo aver configurato i files di cui sopra così come gli ho riportati, ottengo che sempre dopo aver effettuato l'autologin, non funziona quasi niente è come se il PATH dell'utente semplice fosse limitatissimo, tanto per dire se dò un "clear" mi dice che non riconosce il comando, idem per altri comandi shell basilari... è molto strano.
Ho provato anche a loggarmi come root e creare un utente nuovo "pippo", ma se faccio il login come "pippo" ottengo la stessa situazione.... tanto per dirne un'altra, non riesce ad eseguire neanche "fortune"...

Come vi ho detto all'inizio, prima di configurare l'autologin nel modo spiegato sopra, era tutto normale, come mi sono sempre ritorvato su slackware appena installata. Per questo penso che dipenda dalla procedura che ho seguito per l'autologin ad avere incasinato qualcosa.
Vi riporto anche un mio post come conferma del fatto che appena installato il sistema e creato l'utente semplice "stratx" funzionava e non rilevavo problemi legati ai permessi dell'utente... ottenevo al consueta shell usabile normalmente.
Dove può stare il problema secondo voi?
Ad occhio e croce direi in inittab... però ripeto nella mia slack-13.1 sul portatile l'ho modificato allo stesso modo e non ci sono problemi...
Va bè, lacio a voi la parola. Grazie in anticipo. :D
Ultima modifica di joe il gio lug 12, 2012 1:00, modificato 1 volta in totale.
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda targzeta » gio lug 05, 2012 10:49

Per l'autologin basta semplicemente:
Codice: Seleziona tutto
c1:1235:respawn:/bin/login -f USERNAME
nell'inittab (anche se forse c'è qualche problema che non riconosce il logout utente...ora non ricordo. Comunque funziona.). Al limite ti fai uno script che esegue login, non vedo perché scrivere un programma in C con l'utente hardcoded. Io facevo come te fino a poco tempo fa, solo che ora ho disabilitato l'autologin ma ho conservato l'avvio di X automatico (anche se con una politica diversa).

Per il tuo problema invece, hai provato a vedere il PATH? Io ho appena testato il codice di autologin di cui sopra e tutto ha funzionato senza problemi.

Emanuele

P.S. La tua politica di avvio di X non è corretta. Le variabili d'ambiente sono locali alla shell attiva, ergo se ti loggi da un altro terminale (tty2, ad esempio) la tua shell riproverà a far partire X.
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » gio lug 05, 2012 16:13

Ti rispondi un punto alla volta partendo dal fondo:
1- la politica di X non so se è corretta, perchè non ho ben chiaro cosa intendi per "politica di X".
Però ti posso confermare che se mi loggo sulla "tty2" X non parte. E non parte per un semplice motivo:
Codice: Seleziona tutto
if [[ -z $DISPLAY && $(tty) = /dev/tty1 ]]; then
  /usr/bin/startx
fi

...cioè solo nel caso in cui tty è uguale a /dev/tty1 viene avviato "startx" e allo stesso tempo solo se è non è definitala variabile d'ambiente DISPLAY (quindi siamo in console senza X avviato).
Fammi sapere se questo punto ti torna adesso. Forse non avevi letto bene la condizione con l'AND logico fermandoti alla variabile DISPLAY.... la butto lì.
...Perchè a me funziona perfettamente settato in questo modo. Come ti dico uso sul portatile questa configurazione da tempo e il comportamento è il seguente:
1- quando accendo la macchina mi ritrovo in ambiente grafico senza effettuare il login.
2- quando spengo il server X riottengo la shell sulla tty1(vedi avvio in init3 mantenuto). Posso usarla normalmente e se eventualmente mi serve far ripartire x posso tranquillamente lanciare startx.
3- se esco dalla tty1 lanciando exit, riparte il login automatico e di conseguenza mi ritrovo nuovamente in una nuova sessione grafica.

Non ricordo più neanche io il motivo della soluzione con il programmino in c.
Avevo trovato la cosa in rete e avevo scopiazzato. Ma avevo chiesto anche qua. Forse con altre alternative più semplici c'era qualcosa che non fuzionava a dovere. Vado a rivedermi quella vecchia discussione.

Il PATH c'entra sicuramente, ma perchè è stato modificato?
Inoltre il PATH mi sembra solo una delle conseguenze: se vedi come avvio startx in bash_profile, cioè lanciandolo con percorso completo /usr/bin/startx risulta evidente che lì non si tratta di PATH limitato. Infatti se nella tty lancio anche a mano /usr/bin/startx salta fuori un errore relativo ai permessi mancanti... che complica il quadro della faccenda.

Eppure quel PC non l'avevo più toccato e l'ultima volta funzionava tutto normalmente... Mah...
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda targzeta » gio lug 05, 2012 17:32

Ok, hai ragionissimo sull'avvio di X, non ho letto bene e mi sono saltato l'AND sul tty.

Se ti loggi dal tty2, puoi fare startx? Perché altrimenti l'autologin non c'entra nulla.

Datti comunque una riguardata sul programmino C. Non ha molto senso secondo me. Alla fine fai solo una exec, anche la bash può fare una exec.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » gio lug 05, 2012 19:32

No anche sulla tty2 non posso fare neanche "clear" per pulire lo schermo....
Quindi alla fine solo inittab e bash_profile e per l'utente pippo neanche quello poi... Penso anche io che l'autologin non c'entri nulla, ma allora da dove posso partire per venirne a capo?
Tra parentesi anche riavviano il sistema (non si sa mai...) non cambia nulla.
Grazie comunque per l'aiuto.
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda targzeta » gio lug 05, 2012 20:36

Ma hai provato a vedere i permessi del file?
Codice: Seleziona tutto
ls -l /usr/bin/clear


Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » ven lug 06, 2012 10:54

Eh, al momento non ho sottomano il PC per verificare. Sulla slack-13.1 del mio portatile vedo che sono:
Codice: Seleziona tutto
-rwxr-xr-x 1 root root 3356 2009-02-22 00:10 /usr/bin/clear

Quindi tutti gli utenti possono eseguire quel file e solo l'owner che sarebbe root può anche scriverci sopra.
Non vedo perchè in un a slackware appena installata dovrebbero essere differenti... comunque controllerò, anzi a dirla tutta mi sembra di aver già controllato, perchè d'altra parte è la prima cosa che viene in mente visto l'errore che presentava. MA se i permessi fossero apposto, come sospetto.
Allora dove caspita potrebbe essere il problema?

Pensavo al modo in cui ho installato quel sistema:
1- partizionato in due l'HD
2- prima partizione come target in cui mettere il sistema ho fatto un unica partizione "/".
3- seconda partizione contenente i pacchetti da installare cioè in pratica la sorgente d'installazione (avevo avuto problemi col lettore DVD e poi in termini di tempi penso che così sia più rapida l'installzione).
In soldoni mi sta venendo il dubbio che la partizione di sistema possa essere troppo stretta. Infatti poi l'idea era di allargarla estendendola all'intero HD. Tuttavia mi pare strano di aver occupato l'intera partizione target... ma devo controllare anche questo-

Se per caso fosse esaurito lo spazio su disco, potrebbe dare "sintomi" simili allo strano comportamento che ho descritto?
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda targzeta » ven lug 06, 2012 13:18

Boh, mi sembra strano, dovrebbe semplicemente dirti che non hai spazio e non darti errori sui permessi. Comunque fa i tuoi test e tienici aggiornati.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » ven lug 06, 2012 13:28

Vedrò se riesco a mettere le mani su quel PC e sequestrarlo per un po' in modo da averlo a portata di mano... d'altra parte ci sto dietro nei ritagli di tempo. L'altra sera ero partito convinto e mi ero prefissato di settare l'autologin, testare kde togliendo gli effetti grafici (altrimenti crasha, ne avevo parlato in un altro topic...), testare la connessione ad internet, scaricare ed installare un po' di software necessario a faccende d'ufficio ecc ecc. Ovviamente mi sono arenato sul punto 1... pazienza via.

Vi farò sapere. Intanto grazie :D
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda conraid » ven lug 06, 2012 17:22

Perdonate, ho una curiosità.

Volete fare autologin, ok.
Volete avviare X subito dopo il login, ok.
Ma allora perché non avviare il sistema in init4 e lasciar fare autologin al display manager invece che tutti questi script?
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda rik70 » ven lug 06, 2012 19:32

In effetti parrebbe una cosa senso.

Però se hai bisogno che il login utente e la sessione X "ripartano" automaticamente quando fai un logout, forse è l'unica soluzione. Ma ammetto la mia ignoranza.

Per esempio: io lo utilizzo per una sessione xbmc in modalità standalone. A volte capita che un addon vada in crash e fare un logout o un riavvio del server X da tastiera è l'unica soluzione. O peggio ancora: crasha - per colpa sempre di qualche addon o altro - xbmc stesso e viene 'terminata' la sessione grafica. In questi casi, senza quella sorta di loop via inittab, dovresti rifare il login dal display manager.

Ehm.... come diceva qualcuno dalle mie parti: "non so se mi sono capito" :)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » mar lug 10, 2012 23:07

Ho sequestrato il pc nottetempo ;)
Adesso l'ho sttomano, non è connesso ad internet ma va bè. Ora l'ho avviato e ottengo lo stesso strano comportamento.
I permessi di /usr/bin/clear sono normali come nel post sopra:
Codice: Seleziona tutto
-rwxr-xr-x

Il proprietario è root e come gruppo ha root. Tutto normale insomma.
Ma se lo lancio da utente normale ottengo (copio a mano... che barba!):
Codice: Seleziona tutto
-bash: /usr/bon/clear: Permission denied.

Il PATH dell'utente semplice comprende correttamente il percorso "/usr/bin".
Mah... ci capisco sempre meno.

Provo a vedere se l'imputato è l'autologin, reimpostando inittab come di default. E vi faccio sapere
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » mar lug 10, 2012 23:16

Allora qua mi sa proprio che l'autologin non c'entra nulla.
È sempre più un mistero! :(
Ho rimesso inittab com'era poi ho riavviato, quindi l'autologin non ha funzionato.
Ho fatto il login a mano come utente semplice.
E niente l'incipit è: "-bash: fortune: command not found".
Clear non funziona ecc ecc.
Quindi pur disabilitando l'autologin persiste questo strano comportamento dell'utente semplice.
Cercherò un po' in rete.Se nel frattempo avete qualche idea o consiglio su altri test per venirne a capo... sono tutto orecchi.
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda joe » mer lug 11, 2012 13:14

Penso di aver capito dove sta il problema.
Il titolo della discussione è azzeccato nel senso che si tratta di un problema di permessi.
La cosa interessante (per un ignorante come me, diciamolo...) è chi diavolo ha modificato quei permessi.
Risposta: è stata l'installazione del programmino autologin.
Installazione avvenuta attraverso un pacchetto slackware creato da me.
L'avevo creato sul mio portatile, ho ancora la directory di build del pacchetto con i permessi che grosso modo vanno bene:
Codice: Seleziona tutto
root@darkstar:~# ls -lR build/src/autologin/autologin-pkg/
build/src/autologin/autologin-pkg/:
total 8
drwxr-xr-x 2 root root 4096 2011-10-06 09:50 install/
drwxr-xr-x 4 root root 4096 2011-10-06 09:41 usr/

build/src/autologin/autologin-pkg/install:
total 8
-rw-r--r-- 1 root root 580 2011-10-06 09:50 slack-desc
-rw-r--r-- 1 root root 614 2011-10-06 09:50 slack-desc~

build/src/autologin/autologin-pkg/usr:
total 8
drwxr-xr-x 2 root root 4096 2011-10-06 09:57 bin/
drwxr-xr-x 3 root root 4096 2011-10-06 09:41 doc/

build/src/autologin/autologin-pkg/usr/bin:
total 8
-rwxr-xr-x 1 root root 5531 2011-10-06 09:56 autologin*

build/src/autologin/autologin-pkg/usr/doc:
total 4
drwxr-xr-x 2 root root 4096 2011-10-06 09:41 autologin/

build/src/autologin/autologin-pkg/usr/doc/autologin:
total 4
-rw-r--r-- 1 root root 94 2011-10-06 09:41 autologin.c


Ora, dove stà l'inghippo?
Nella copia di quella directory di build. Infatti ho copiato autologin-pkg così com'era in una chiavetta usb, quindi ho trasferito il tutto nella directory home di root sul pc in cui doveva essere installato autologin. Ma siccome la chiavetta era formattata in ntfs, i permessi non sono stati preservati a dovere e la directory copiata ha permessi diversi. In praticolare
- "autologin-pkg/usr" presenta "drwx------" e appartiene a root:root.
così come la sottodir "bin" ecc.
Il pacchetto che ho creato a partire da quella directory di costruzione si è portato dietro questi permessi sballati.
E anche in fase d'installazione ha modificato tutti i permessi delle directories coinvolte:
In pratica /usr, /usr/bin, /usr/doc e /usr/doc/autologin... ecco il contenuto del paccheto:
Codice: Seleziona tutto
PACKAGE LOCATION: ../../../pkg/autologin-0.0.1-i486-1hb.txz
PACKAGE DESCRIPTION:
autologin:
autologin: autologin (no need log in helper)
autologin:
autologin:
autologin:
autologin:
autologin:
autologin:
autologin:
autologin:
autologin:
FILE LIST:
./
install/
install/slack-desc~
install/slack-desc
usr/
usr/doc/
usr/doc/autologin/
usr/doc/autologin/autologin.c
usr/bin/
usr/bin/autologin


Ora mi chiedo, ma se disinstallo il pacchetto che ha creato casino... i permessi tornano normali? direi di no, ma provo.
A limite li modifico a mano... tanto sono 4 directories da modificare...
Quindi ricapitolando:
1- causa del problema: permessi sballati a causa di una copia su chiavetta usb con filesystem ntfs.
2- creando ed installando il pacchetto a partire da quella directory ha fatto si che il problema si propagasse anche alle direcotries del sistema target.
3- effetti gli eseguibili in /usr non sono più accessibili da parte dell'utenza semplice con ovvie ripercussioni sul normale utilizzo del sistema.

Se avete commenti, dite pure...

That'all folks!

PS.
Se avessi fatto uno slackbuild questo problema non ci sarebbe stato. Anche se il pacchetto è semplice, sarebbe buona norma scrivere uno slackbuild in ogni caso... spesso non lo faccio ma ho perso più più tempo a risolvere questo problemino che non a scrivermi due righe di script. Pazienza.
Avatar utente
joe
Master
Master
 
Messaggi: 1950
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Re: Problemi con permessi e autologin su Slackware-13.37

Messaggioda targzeta » mer lug 11, 2012 14:57

Fatti uno script per l'autologin e non un programma :). Per i permessi dovrebbe bastare reinstallare il pacchetto aaa_base.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6157
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Prossimo

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti