Repository 32bit  Forum
Repository 64bit  Wiki

Consiglio Ebook reader in gtk2

Area di discussione libera.

Moderatore: Staff

Regole del forum
1) Rispettare le idee altrui.
2) Evitare le offese dirette.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Consiglio Ebook reader in gtk2

Messaggioda unonessuno » ven lug 27, 2012 17:43

Ciao a tutti.
Come da titolo mi servirebbe un EBook reader in gtk da installare su Slackware con XFCE 4.xy..
Attualmente utilizzo:
Codice: Seleziona tutto
fbreader e Calibre

In qt4 su Debian a 64 bit con XFCE 4.8, siccome non voglio sporcare anche Slackware con Xfce4, semplicemente perchè ho avuto la massima cura nel tenerla pulita ed esente da e da software che non si appoggi alle librerie gtk.

Qualcuno conosce qualcosa di altrettanto valido in GTK ??
Grazie.
Avatar utente
unonessuno
Linux 2.0
Linux 2.0
 
Messaggi: 137
Iscritto il: dom giu 27, 2010 2:59
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: XFCE4.10

Re: Consiglio Ebook reader in gtk2

Messaggioda Plaoo » ven lug 27, 2012 17:59

Sinceramente non ho capito, ti serve un un software per la lettura degli ebook su slackware con xfce senza gtk??? :?
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: Consiglio Ebook reader in gtk2

Messaggioda Ansa89 » ven lug 27, 2012 18:06

Offtopic: Dal titolo mi sembra piuttosto chiara la sua richiesta.

Puoi provare odin.
Comunque leggendo qua e là, mi sembra di capire che anche fbreader usa le gtk :roll: .
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Consiglio Ebook reader in gtk2

Messaggioda unonessuno » ven lug 27, 2012 18:15

Plaoo ha scritto:Sinceramente non ho capito, ti serve un un software per la lettura degli ebook su slackware con xfce senza gtk??? :?


NO al contrario con le GTK senza qt
Avatar utente
unonessuno
Linux 2.0
Linux 2.0
 
Messaggi: 137
Iscritto il: dom giu 27, 2010 2:59
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: XFCE4.10

Re: Consiglio Ebook reader in gtk2

Messaggioda unonessuno » ven lug 27, 2012 18:23

Ansa89 ha scritto:Offtopic: Dal titolo mi sembra piuttosto chiara la sua richiesta.

Puoi provare odin.
Comunque leggendo qua e là, mi sembra di capire che anche fbreader usa le gtk :roll: .


Grazie per la segnalazione adesso mi informo su:"Odin" e poi lo provo, non vorrei dire cazzate ma fbreader è in Qt, la versione che sto usando lo è guarda:
http://packages.debian.org/wheezy/fbreader
Una delle dipendenze è:"libzlui-qt4" prendo come riferimento i pacchetti di debian perchè prima di installare sulla mia Slackware voglio essere sicuro.
Avatar utente
unonessuno
Linux 2.0
Linux 2.0
 
Messaggi: 137
Iscritto il: dom giu 27, 2010 2:59
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: XFCE4.10

Re: Consiglio Ebook reader in gtk2

Messaggioda Ansa89 » ven lug 27, 2012 19:11

Sei sicuro che sulla tua slackware non hai installate le qt?
Se la risposta è "sì", puoi provare a compilare fbreader e vedere se ottieni un esegubile funzionante (costa poco tempo e ti togli ogni dubbio).

FBReader README.build ha scritto:FBReader requires
** expat -- library for XML parsing. AFAIK, all popular destributions
includes package with name like 'expat-dev' or 'libexpat-dev'.
If you cannot find expat in your distribution, please visit
http://expat.sourceforge.net
** libz and libbz2 -- libraries for zip and bzip2 (de)compression
** UI library -- this depends on your target platform. For desktop,
Qt library, version 3.* or 4.*
OR
GTK+ library, version >= 2.4
should be installed

** libunibreak (http://vimgadgets.cvs.sourceforge.net/vimgadgets/common/tools/linebreak/) -- library for line breaking in a Unicode sequence
** libfribidi -- for bidirectional text support
** lincurl, version >= 7.17 -- for network libraries integration
** libsqlite3
** for win32 version, we use also libpng, libungif, libjpeg and libtiff
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1


Torna a Libera

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti