Repository 32bit  Forum
Repository 64bit  Wiki

caratteri giganti (RISOLTO)

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

caratteri giganti (RISOLTO)

Messaggioda creppolo » dom lug 29, 2012 3:36

ho installato slack 13.37 su un vecchio pIII, con xfce come DE
tutto ok, ma quando ho provato a inserire fluxbox mi ha creato problemi: caratteri giganteschi nella barra e nel menu (davvero inutilizzabile, non si riesce a leggere nulla)
dato che mi succede solo con fluxbox sono tornato a xfce e è tutto a posto ma non capisco...
Ultima modifica di creppolo il mar lug 31, 2012 7:22, modificato 1 volta in totale.
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda 414N » dom lug 29, 2012 11:05

Provato a leggere qui?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: caratteri giganti

Messaggioda creppolo » dom lug 29, 2012 17:48

scusa, non ce l'ho fatta a rispondere prima...
si avevo già trovato quella pagina e ho provato a modificare il file overlay... ma nulla: i caratteri restano giganteschi e fluxbox è inutilizzabile (per capirsi se provo ad accedere al menu riesco a vedere solo TRE lettere delle prime due righe)...
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda 414N » dom lug 29, 2012 17:58

:-k
Quale scheda video ha il computer in questione? Quale driver usa X (lo vedi da /var/log/Xorg.0.log)?
Hai provato a riportare il file ~/.fluxbox/overlay al suo default, ovvero:
Codice: Seleziona tutto
! The following line will prevent styles from setting the background.
! background: none

?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: caratteri giganti

Messaggioda creppolo » dom lug 29, 2012 18:18

no, mi son stufato, ho dato di matto e tengo xfce
comunque me lo faceva anche con icewm (ho provato al volo)
solo con xfce è tutto a posto...
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda creppolo » dom lug 29, 2012 18:20

:D
Ultima modifica di creppolo il dom lug 29, 2012 22:00, modificato 2 volte in totale.
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda creppolo » dom lug 29, 2012 21:59

ho provato ad installare salix fluxbox e funziona bene (caratteri normali): solo in gdm al momento dell'autenticazione nella casella dove bisogna digitare il nome utente i caratteri sono fuori grandezza (giganti anche qua: con 2 lettere occupa tutto lo spazio)
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda percoco2000 » dom lug 29, 2012 23:13

Per curiosita' vedi a quanto e' settato il valore di dpi di X (xdpyinfo) se e' configurato male i font vengono renderizzati con dimensioni errate...

https://wiki.archlinux.org/index.php/Xo ... ze_and_DPI

dai una lettura a questa guida per arch, spiega come procedere..
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 613
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Re: caratteri giganti

Messaggioda creppolo » lun lug 30, 2012 11:49

non ho capito come settarlo a mano. comunque questa è la schermata:
massi[~]$ xdpyinfo | grep -B2 resolution
screen #0:
dimensions: 1152x864 pixels (10x10 millimeters)
resolution: 2926x2195 dots per inch
massi[~]$
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti

Messaggioda percoco2000 » mar lug 31, 2012 0:38

Questo spiegherebbe il perche' dei caratteri giganti.....Secondo Xorg il tuo monitor ha una dimesione 10x10 mm :D :D

Il wiki linkato dice che devi crearti un file custom con dentro le corrette misure del monitor...espresse in millimetri (largehzza x altezza)

crea questo file
/etc/X11/xorg.conf.d/90-monitor.conf

e dentro metti

Codice: Seleziona tutto
Section "Monitor"
    Identifier             "<default monitor>"
    DisplaySize            larg alt    # In millimeters
EndSection


Sostituendo ad larg ed alt i valori misurati.
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 613
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware

Re: caratteri giganti

Messaggioda creppolo » mar lug 31, 2012 7:21

grazie mille, risolto !
chi pensa col cervello degli altri il suo lo può friggere (G.L.)
il mondo è bello perchè è avariato (G.L.)
gli amici si vedono nel momento del loro bisogno (M.L.)
Avatar utente
creppolo
Linux 2.6
Linux 2.6
 
Messaggi: 500
Iscritto il: mer apr 01, 2009 12:41
Località: Massa
Nome Cognome: Massimiliano Luccini
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: IceWM

Re: caratteri giganti (RISOLTO)

Messaggioda percoco2000 » mar lug 31, 2012 8:32

Bene, perfetto. A volte la mano umana e' meglio dei vari HAL, UDEV.......
Avatar utente
percoco2000
Linux 2.6
Linux 2.6
 
Messaggi: 613
Iscritto il: mer lug 14, 2004 23:00
Località: Salerno
Slackware: 12.2
Kernel: 2.6.27
Desktop: mate - fluxbox
Distribuzione: mint 13 / slackware


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti