Repository 32bit  Forum
Repository 64bit  Wiki

Anomalia slapt-get

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Anomalia slapt-get

Messaggioda Draven94 » sab ago 04, 2012 10:51

Come da titolo, ho notato nel mio caso un'anomalia sul funzionamento di slapt-get. Infatti ieri mi sono dovuto costretto ad installare il pacchetto "arandr" presente sul repo di slacky per la gestione di monitor esterni. Tuttavia, procedendo con slapt-get* il pacchetto non mi viene trovato e devo procedere al download e all'installazione da locale seppur il repo è presente nella sua configurazione. Perchè questo comportamento di slapt-get? :?:




*slapt-get è stato configurato in modo tale da includere anche il repo di slacky.eu
Acer Aspire 5920 (T5450, 2GB DDR2, WD 160GB, Intel GMA X3100)
Avatar utente
Draven94
Linux 1.0
Linux 1.0
 
Messaggi: 22
Iscritto il: mar lug 24, 2012 14:33
Slackware: 13.37 (x64)
Kernel: 2.6.37.6
Desktop: XFCE 4.6.2

Re: Anomalia slapt-get

Messaggioda miklos » sab ago 04, 2012 11:36

slapt-get si comporta correttamente nel senso che controllando ho notato che fisicamente nel repo il pacchetto ci sta, ma nei meta-dati generali non è menzionato.
per questo poi slapt-get non te lo trova.

apri una segnalazione a questa url in modo da tenere traccia del problema e provvedere alla sua correzione.

ciau
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1222
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: Anomalia slapt-get

Messaggioda targzeta » sab ago 04, 2012 11:54

@miklos
Cosa intendi con "metadati generali"?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6176
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Anomalia slapt-get

Messaggioda Draven94 » sab ago 04, 2012 12:01

miklos ha scritto:slapt-get si comporta correttamente nel senso che controllando ho notato che fisicamente nel repo il pacchetto ci sta, ma nei meta-dati generali non è menzionato.
per questo poi slapt-get non te lo trova.

apri una segnalazione a questa url in modo da tenere traccia del problema e provvedere alla sua correzione.

ciau

Ho fatto la segnalazione, vediamo un pò cosa esce fuori :)
Acer Aspire 5920 (T5450, 2GB DDR2, WD 160GB, Intel GMA X3100)
Avatar utente
Draven94
Linux 1.0
Linux 1.0
 
Messaggi: 22
Iscritto il: mar lug 24, 2012 14:33
Slackware: 13.37 (x64)
Kernel: 2.6.37.6
Desktop: XFCE 4.6.2

Re: Anomalia slapt-get

Messaggioda miklos » sab ago 04, 2012 17:44

spina ha scritto:Cosa intendi con "metadati generali"?
il file PACKAGES.TXT
in questo caso non contiene il pacchetto arandr quindi slapt-get quando aggiorna la sua cache locale non lo include.
comunque non è la prima volta che noto una cosa del genere, di solito 'risolvo' ricommittando il pacchetto... anche se questo pacchetto è vecchiotto quindi forse bisognerebbe indagare un po' e capire cosa accade quando viene aggiornato il repository.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1222
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti