Repository 32bit  Forum
Repository 64bit  Wiki

nvidia + flash

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

nvidia + flash

Messaggioda ZeroUno » sab ago 18, 2012 17:12

Ormai è una cosa nota che i driver proprietari nvidia cozzano con l'accelerazione hardware di flash player.

E' il classico effetto puffo che viene visto su youtube da chi ha una scheda nvidia e usa i driver propietari (chissà perchè poi solo per i video di youtube).

Mi sono ritrovato con un altro problema, stessa combinazione nvidia+accelerazione flash, su un altro sito in flash.
E' uno di quei giochi flash.

Lo avvio e va piuttosto bene, l'accelerazione fa il suo dovere (è alquanto pesante), ma se per caso lo schermo si spenge (standby, chiusura portatile, ctrl+alt+f1 ...) alla sua accenzione l'applicazione continua a funzionare ma non refresha lo schermo e quindi si vede l'ultima immagine che c'era. L'applicazione funziona perchè il sonoro si sente e se clicco su qualche ipotetico bottone (che so che c'è perchè conosco l'applicazione perchè in verità l'immagine è statica) questo fa il suo effetto (cambiano i suoni ecc).

se invece disattivo l'accelerazione non ho problemi.

In verità questo prima succedeva anche se cambiavo luminosità allo schermo, ora no.

Secondo voi c'è qualche impostazione di xorg.conf.d che posso mettere per ovviare?

almomento:
Codice: Seleziona tutto
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option "DPMS" "1"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "RegistryDwords" "EnableBrightnessControl=1"
    Option "TripleBuffer" "True"
    Option         "OnDemandVBlankInterrupts" "1"
EndSection

driver 295.59
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda navajo » sab ago 18, 2012 17:21

Io ne ho provate tante.. facendo in questo modo:

Codice: Seleziona tutto
 
# mkdir /etc/adobe
# echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | tee /etc/adobe/mms.cfg > /dev/null

sembra funzionare, anche con l accelerazione attivata.
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3782
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: nvidia + flash

Messaggioda ZeroUno » sab ago 18, 2012 19:24

ma che razza di sintassi hai trovato!!!
> /etc/adobe/mms.cfg
soltanto non ti piaceva?

comunque grazie.
youtube è risolto, ma il problema all'applicazione rimane.

cercando quei due parametri ho trovato uno che si è fatto una tabella di quello che funziona e non con varie combinazioni.
http://r3dux.org/2011/12/how-to-partial ... -on-linux/

Sarebbe da provare google-chrome; è probabile che monti flash-player 11.3 (ma non ne sono sicuro)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda navajo » sab ago 18, 2012 21:00

dicono di si. ma io voglio continuare ad usare chomium.
altrimenti cè da provare con firefox un estensione che ora non ricordo :roll:
ps quel comando lo trovai tempo fa, e c era anche una spiegazione del /dev/null ma non mi ricordo ..
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3782
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: nvidia + flash

Messaggioda ZeroUno » sab ago 18, 2012 23:32

Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda navajo » lun ago 20, 2012 8:42

appena posso lo provo. Grazie
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3782
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: nvidia + flash

Messaggioda ZeroUno » lun ago 27, 2012 12:07

http://www.nvidia.it/Download/Find.aspx?lang=it

Linux x64 (AMD64/EM64T) Display Driver Raccomandata da NVIDIA 304.43 :
- Risolto un problema che provocava la sospensione di VDPAU durante l'espansione del lettore Flash di YouTube.


Lo sto pacchettizzando. Appena ho fatto lo provo e vi faccio sapere.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda ZeroUno » lun ago 27, 2012 15:05

Il problema con l'effetto puffo non è risolto (se non mettendo quelle due righe in mms.cfg).
Le altre cose non le ho testate.


Comunque la 304 è uscita dalla beta, quindi pacchettizzare per la 295 non ha più senso.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda ricciare » lun ago 27, 2012 16:56

ZeroUno ha scritto:Il problema con l'effetto puffo non è risolto (se non mettendo quelle due righe in mms.cfg).
Le altre cose non le ho testate.


Comunque la 304 è uscita dalla beta, quindi pacchettizzare per la 295 non ha più senso.


Visto che ho fatto un bell'aggiornamento di kde ne ho approfittato anche per aggiornare il driver nvidia ... ho capito, terrò gelosamente custodito al sicuro flashplayer 11.1.102.55, tipo la "Numero 1" di Zio Paperone, visto che con accelerazione hardware abilitata e senza inserire alcun comando non fa effetto puffo. :lol:
Avatar utente
ricciare
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: mer feb 27, 2008 15:50
Località: Pescia
Nome Cognome: Nicola
Slackware: current 64bit
Kernel: 3.14.1
Desktop: fluxbox + kde4.10.5

Re: nvidia + flash

Messaggioda ZeroUno » lun ago 27, 2012 19:07

ma siamo sicuri che con la 11.1 l'accellerazione sia vera e buona? Io ho una applicazione che con la 11.1 e accelerazione attiva funziona coma con la 11.2 con accelerazione disattivata, cioé da schifo.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda ricciare » lun ago 27, 2012 21:23

ZeroUno ha scritto:ma siamo sicuri che con la 11.1 l'accellerazione sia vera e buona? Io ho una applicazione che con la 11.1 e accelerazione attiva funziona coma con la 11.2 con accelerazione disattivata, cioé da schifo.


con la versione 11.2 son subito apparsi i puffi blu e sono tornato a boma alla versione 11.1 ..e li' mi son fermato. Avevo notato che disabilitando l'accelerazione tornava a vedersi bene ma non mi sono messo a fare dei confronti.
Avatar utente
ricciare
Linux 1.0
Linux 1.0
 
Messaggi: 70
Iscritto il: mer feb 27, 2008 15:50
Località: Pescia
Nome Cognome: Nicola
Slackware: current 64bit
Kernel: 3.14.1
Desktop: fluxbox + kde4.10.5

Re: nvidia + flash

Messaggioda ZeroUno » mar ago 28, 2012 10:20

Ecco i driver aggiornati.
http://www.z01.eu/repo-slack/slackware6 ... dia-linux/


Ho testato google-chrome con flash 11.3 e non c'è l'effetto puffo.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda tornadomig » gio ago 30, 2012 18:22

ho fatto qualche verifica per conto mio...


su youtube ho preso il film black hawk down ita (digitate cosi') e con google-chrome all'inizio l'introduzione e' puffata poi i colori ritornano normali

aggiornando flash alla versione di alienbob, la 11.2.202.238 al momento presente, con google-chrome si comporta allo stesso modo scritto sopra.

su firefox la stessa versione di alienbob mi inizia il film col giallo, penso sia il colore giusto infatti sono immagini del deserto poi puffa tutto. altri film su firefox presi a caso su youtube sono tutti puffati.

morale per me: rimetto flash di slackbuilds.org che avevo installato prima, cioe' 11.1.102.62 e buonanotte ancora.


ah, i driver nvidia installati sono gli ultimi, i 304.43
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: nvidia + flash

Messaggioda ZeroUno » gio ago 30, 2012 20:21

Quando usi google-chrome usi la 11.3, anche se hai installata la 11.2 o la 11.1

Quando vedi blu l'inizio di quel film non vedi un "puffato" ma vedi i colori giusti, ovvero il blu non di puffo ma di scuro notte (che nei film si traduce in un blu).

Quando vedi arancio allora è lì che stai vedendo puffato perchè se nell'effetto puffo il rosa diventa blu, il blu diventa arancio.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4398
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: nvidia + flash

Messaggioda tornadomig » ven ago 31, 2012 0:26

scusa intanto perche' non ti ho neanche salutato da un po' che non ci sentivamo/scrivevamo ;)

si diceva sull'effetto puffo...quindi con google-chrome siamo a cavallino rampante e con firefox no allora?
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Prossimo

Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron