Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Multilib problema

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]Multilib problema

Messaggioda RedSkull92 » lun ago 27, 2012 0:36

Provavo ad aggiornare le multilib ma qualcosa è andato storto con le glibc infatti il processo s'interrompe e dà miriadi di errori come:
Pre-installing package glibc-2.13_multilib-x86_64-5alien...
basename: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by basename)
rm: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by rm)
basename: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by basename)
cp: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by cp)
cp: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /lib64/libacl.so.1)


L'ho fatto 2 volte (risolvendo ogni volta il problema) e tutte e 2 le volte sono incappato in 'sto problema, quindi qualcosa mi porta a pensare che sia il pacchetto di alien danneggiato.
Qualcuno mi dà conferma ?
Ultima modifica di RedSkull92 il mar ago 28, 2012 19:08, modificato 1 volta in totale.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Multilib problema

Messaggioda Ansa89 » lun ago 27, 2012 9:14

Hai provato a riscaricare il pacchetto e/o controllare il checksum?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2621
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Multilib problema

Messaggioda ZeroUno » lun ago 27, 2012 9:52

Mi sembra abbastanza chiaro.
Tu stai installando glibc 2.13 mentre i comandi 'rm' 'cp' ecc vogliono almeno le 2.14

Ormai il danno è fatto.
Prendi il pacchetto multilib aggiornato (o temporaneamente quello non multilib) e installalo facendo il boot da cdrom.

Considera che l'attuale current ha le 2.15
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4386
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Multilib problema

Messaggioda RedSkull92 » lun ago 27, 2012 13:02

Riparare il danno è facile, basta seguire questa guida: https://redskull92.wordpress.com/2012/0 ... -le-glibc/
Ho già ripetuto la procedura 2 volte scaricando i pacchetti di alien di sempre.
Tutte e 2 le volte è successo 'sto macello, che ho dovuto riparare.
Voi non avete alcun problema ?
Con le glibc della current vado benissimo e funziona tutto.
Sono le glibc-multilib che distruggono tutto.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Multilib problema

Messaggioda conraid » lun ago 27, 2012 13:51

http://alien.slackbook.org/blog/

segui gli aggiornamenti di alien, e non aggiornare la current fino a che alien non aggiorna i suoi pacchetti. Se aggiorni la current e metti i pacchetti non aggiornati per forza succede caos
Se poi anche quelli aggiornati non vanno mandagli una mail o scrivi nel blog
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Multilib problema

Messaggioda RedSkull92 » lun ago 27, 2012 18:11

Ho fatto l'aggiornamento alla current il 24 ma ancora non erano presenti le multilib quini ho aspettato e lui il 25 ha aggiornato i pacchetti multilib per la nuova current http://slackware.org.uk/people/alien/multilib/current/
Quindi DOPO aver finito l'aggiornamento alla current -che ripeto, va alla grande- ho fatto l'upgrade dei pacchetti multilib (che avevo comunque installato precedentemente e che funzionavano perfettamente) ma ad un certo punto il nuovo pacchetto fa qualcosa di strano e rompe tutto.
Le vecchie multilib andavano benone, solo queste nuove mi hanno creato problemi.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Multilib problema

Messaggioda conraid » mar ago 28, 2012 13:51

No, dal tuo primo messaggi si evince che tu cercavi di installare pacchetti non recenti, cioè le glibc 2.13 e non le 2.15
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12002
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Multilib problema

Messaggioda RedSkull92 » mar ago 28, 2012 15:56

Ci ho fatto caso solo ora, ma come è possibile ?
Ho scaricato l'intera directory, magari non tutte erano aggiornate e causavano questo errore.
Ora riprovo e vi faccio sapere.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Multilib problema

Messaggioda RedSkull92 » mar ago 28, 2012 19:08

EDIT: Ora funziona tutto PERFETTAMENTE.
Come diamine è possibile ?
Mah, alien magari aveva dimenticato qualcosa.
RISOLTO!
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: [RISOLTO]Multilib problema

Messaggioda ZeroUno » mar ago 28, 2012 22:39

O forse semplicemente hai scaricato mentre alien stava caricando!

Quando li hai scaricati ESATTAMENTE ?
Alien il ha caricati il 25/08/12 00:54:00 GMT
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4386
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLTO]Multilib problema

Messaggioda RedSkull92 » mar ago 28, 2012 23:39

Esattamente non so dirlo, però ricordo bene che era il giorno dopo dell'uscita della current, infatti appena ho aggiornato sono andato a vedere le multilib che avevano ancora la data del 24, il giorno dopo lessi 25 ed installai incappando nell'errore.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: [RISOLTO]Multilib problema

Messaggioda ZeroUno » mer ago 29, 2012 9:15

Dal blog su citato
AlienBob ha scritto:Slackware 14 is getting ever closer upon us. Yesterday, the third release candidate was made public:
...
I had not paid good attention, so it took me a few seconds to realize that a rebuild of the glibc package was mentioned there.

Quindi ha ritardato un po' :-)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4386
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Packages

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 2 ospiti