Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLOTO]Aggiornare pacchetti slackware.

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda escher » lun set 24, 2012 19:56

Ciao a tutti, arrivo subito al dunque. Volevo chiedervi come posso aggiornare determinati pacchetti da shell?

So che devo dare shell , ad esempio se volessi aggiornare firefox alla versione più recente.

Codice: Seleziona tutto
slackpkg upgrade mozilla-firefox


Ma due sono le domande:

0) Il nome del pacchetto, quale devo mettere? Ad esempio per firefox devo scrivere "mozilla-firefox", come scopro il "vero" nome del pacchetto? Avrei potuto mettere solamente "firefox" e forse avrei sbagliato.

1) Devo decommentare un mirror in
Codice: Seleziona tutto
/etc/slackpkg/mirrors
e poi dare
Codice: Seleziona tutto
slackpkg update
. Quale mi consigliate di decommentare?

Grazie per le eventuali risposte ! :)
Ultima modifica di escher il mer set 26, 2012 18:13, modificato 1 volta in totale.
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: Aggiornare pacchetti slackware.

Messaggioda tornadomig » lun set 24, 2012 21:08

ciao e benvenuto! :)

non e' difficile, abbiamo anche un wiki ben fatto che ti puo' illustrare al meglio l'argomento che chiedi
http://www.slacky.eu/wikislack/index.php?title=Slackpkg

e poi anche diversi threads puoi trovare nel forum...
Codice: Seleziona tutto
# nano /etc/slackpkg/mirrors

comunque per prima cosa si decommenta uno e uno solo dei mirrors della tua slackware installata, lo vedi sull'elenco
poi salvi ctrl+o, enter e ctrl+x, poi
Codice: Seleziona tutto
# slackpkg update gpg
e aggiorni la public key, poi
Codice: Seleziona tutto
# slackpkg update
poi
Codice: Seleziona tutto
# slackpkg install-new
per vedere se ci sono pacchetti nuovi aggiunti, poi ancora un bel
Codice: Seleziona tutto
# slackpkg upgrade-all
e dovresti essere a posto

di solito fai cosi' dopo che hai creato il tuo utente, adesso hai la slack aggiornata

se ti serve altro, fai un fischio. segui i wiki che ti saranno molto utili e qui ne trovi a bizzeffe! :roll:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 508
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Aggiornare pacchetti slackware.

Messaggioda tornadomig » lun set 24, 2012 21:56

dimenticavo, per i server di solito becco uno svizzero o austriaco ;)
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 508
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: Aggiornare pacchetti slackware.

Messaggioda Blallo » mar set 25, 2012 1:00

Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3244
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Aggiornare pacchetti slackware.

Messaggioda escher » mar set 25, 2012 11:00

Prefetto grazie mille delle risposte :)
I server italiani me li sconsigliate =P

Ps: l'unica cosa che non mi è chiara è il comando:

Codice: Seleziona tutto
# slackpkg upgrade-all


Mi restituisce:
Codice: Seleziona tutto
You have a broken /var/log/packages - with two versions of the same package.
The list of packages duplicated in your machine are shown below, but don't
worry about this list - when you select your action, slackpkg will show a
better list:

flash-player-plugin-10.0.45.2-i386-1sl
flash-player-plugin-10.2.159.1-i386-1sl
fluxbox-1.0rc3-i486-1_slack11.0
fluxbox-1.1.1-i486-2
imlib2-1.4.2-i486-4sl
imlib2-1.4.4-i486-1sl
irssi-0.8.15-i486-1
irssi-0.8.15-i486-1_slack13.0
moc-2.4.3-i486-1bj
moc-2.5.0_alpha4-i486-1_SBo
wicd-1.6.2-i486-1_rlw
wicd-1.7.0-i486-2


Poi mi dice:
Codice: Seleziona tutto
You can (B)lacklist, (R)emove, or (I)gnore these packages.


Se premo B che succede?
R = mi rimuove il "duplicato" del pacchetto?

Grazie :)
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: Aggiornare pacchetti slackware.

Messaggioda hashbang » mer set 26, 2012 17:15

slackpkg ti sta dicendo che hai dei duplicati (che sono quelli elencati) e pertanto vuole sapere se desideri metterli in blacklist (in modo da non aggiornarli più alle versioni ufficiali e mantenere quelli esterni) oppure di rimuoverne uno.

Meglio se scegli la rimozione. Avere due pacchetti uguali non è una cosa molto pulita.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1842
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Aggiornare pacchetti slackware.

Messaggioda escher » mer set 26, 2012 18:12

Ok perfetto non sapevo cos'era la blacklist :)

Grazie mille !:)
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda escher » mer set 26, 2012 20:21

Riapro un attimo. Non so perchè volendo eliminare il pacchetto "doppio" del flash mi ha cancellato molti altri pacchetti, tra cui fluxbox e irssi e delle librerie.
Sapete spiegarmi il perchè?
Ho dovuto installare di nuovo tutto, e ora nemmeno è tutto come prima.
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda ZeroUno » mer set 26, 2012 22:37

che comando hai dato?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda escher » gio set 27, 2012 10:49

Ho dato:
Codice: Seleziona tutto
slackpkg upgrade-all


E' comparsa la lista:
Codice: Seleziona tutto
You have a broken /var/log/packages - with two versions of the same package.
The list of packages duplicated in your machine are shown below, but don't
worry about this list - when you select your action, slackpkg will show a
better list:

flash-player-plugin-10.0.45.2-i386-1sl
flash-player-plugin-10.2.159.1-i386-1sl
fluxbox-1.0rc3-i486-1_slack11.0
fluxbox-1.1.1-i486-2
imlib2-1.4.2-i486-4sl
imlib2-1.4.4-i486-1sl
irssi-0.8.15-i486-1
irssi-0.8.15-i486-1_slack13.0
moc-2.4.3-i486-1bj
moc-2.5.0_alpha4-i486-1_SBo
wicd-1.6.2-i486-1_rlw
wicd-1.7.0-i486-2

You can (B)lacklist, (R)emove, or (I)gnore these packages.


Ho premuto R e ho selezionato il pacchetto "duplicato" da rimuovere ossia il flash player. Ho dato invio e ha iniziato a cancellare tutto il resto che non c'entrava nulla. Non so spiegarmela questa cosa.

Ho visto in
Codice: Seleziona tutto
/var/log/removed_packeges
e questi sono i pacchetti eliminati:

Codice: Seleziona tutto
compiz-0.8.6-i486-1
ekiga-3.2.7-i486-1sl
flash-player-plugin-10.0.45.2-i386-1sl
flash-player-plugin-10.2.159.1-i386-1sl
fluxbox-1.0rc3-i486-1_slack11.0
fluxbox-1.1.1-i486-2
gcc-4.4.4-i486-1
gcc-g++-4.4.4-i486-1
imlib2-1.4.2-i486-4sl
imlib2-1.4.4-i486-1sl
irssi-0.8.15-i486-1
javacc-5.0-noarch-1_SBo
jre-6u20-i586-1
kdeaccessibility-4.4.3-i486-1
kdeedu-4.4.3-i486-1
kdemultimedia-4.4.3-i486-1
madplay-0.15.2b-i486-2
mailx-12.4-i486-1
metamail-2.7-i486-3
mozilla-firefox-l10n-it-4.0.1-i686-2sl
openoffice-autobuilder-multilang-3.2.1-noarch-23sm
openoffice-it-3.2.1-i586-23sl
openoffice-it-3.2.1-i586-23sl-upgraded-2010-09-25,21:34:37
openoffice.org-3.2.1_en_US-i586-1_SBo
openoffice.org-l10n-es-3.2.1-i486-1mfb
pyloris-3.2
tor-0.2.1.26-i486-1_SBo
tor-0.2.1.30-i486-1_SBo
unrar-4.0.3-i486-1_SBo


Di Compiz non mi interessa non so che funzione abbia in fluxbox. Di ekiga nemmeno. Gcc e G++ c'è quello integrato che non l'ha eliminato.Questi pacchetti: kdeaccessibility,kdeedu,kdemultimedia,madplay,mailx,metamail e tutti quelli di openoffice, li avevo eliminati io tempo fa. Tor funziona ancora.

Ho reinstallato:
Codice: Seleziona tutto
flash-player-plugin-10.2.159.1-i386-1sl
fluxbox-1.1.1-i486-2
irssi-0.8.15-i486-1
jre-6u20-i586-1


Non so quel sia la differenza tra:
Codice: Seleziona tutto
0) fluxbox-1.1.1-i486-2 (quello che ho installato di nuovo)
1) fluxbox-1.0rc3-i486-1_slack11.0


Fluxbox è un po' diverso ma nulla di preoccupante.

Anche firefox è un po' diverso questa che ho ora è la versione 3.6.4 forse devo installare di nuovo il pacchetto eliminato:

Codice: Seleziona tutto
mozilla-firefox-l10n-it-4.0.1-i686-2sl



Dovrei anche installare la librerie: (non saprei come fare):
Codice: Seleziona tutto
imlib2-1.4.4-i486-1sl


Grazie delle risposte, mi sembra strano che abbia fatto questo casino.
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda ZeroUno » gio set 27, 2012 11:03

ha tolto tutto quello che è estraneo a slackware (i pacchetti scaricati da repository di terzi)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda escher » gio set 27, 2012 11:17

Va bene grazie, almeno ho capito cosa ha fatto. :)
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda ZeroUno » gio set 27, 2012 12:24

in questi casi comunque removepkg è molto più sicuro.

slackpkg serve a semplificare il calcolo di quali sono i pacchetti da aggiornare, ma mi guarderei bene da fargli fare operazioni, per quanto sia un tool ufficiale, un po' più avanzate.
"Slackpkg DOESN'T replace pkgtool."
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: [RISOLOTO]Aggiornare pacchetti slackware.

Messaggioda escher » gio set 27, 2012 12:36

Grazie mille ancora..terrò a mente la frase :)
escher
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: lun set 24, 2012 18:08
Slackware: 13.1
Kernel: 2.6
Desktop: fluxbox


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti