Repository 32bit  Forum
Repository 64bit  Wiki

Android SDK problema emulatore

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Android SDK problema emulatore

Messaggioda RedSkull92 » lun set 24, 2012 14:32

Ho appena finito d'installare l'sdk android.
Ho eclipse con il plugin e ho creato il device virtuale con android 4.1
Ma appena cerco di avviare l'emulatore non succede niente.
Cioè il caricamento per l'avvio viene completato ma l'emulatore non si decide a partire e non ricevo nessun errore né niente.

Ho una current 64 bit multilib.

Quale potrebbe essere il problema ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Android SDK problema emulatore

Messaggioda RedSkull92 » lun set 24, 2012 17:57

Ho letto in giro che forse è un problema di multilib, nessuno con la 64 bit ha riscontrato problemi ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Android SDK problema emulatore

Messaggioda puzuma » mar set 25, 2012 14:34

purtroppo non ti so aiutare con le multilib, comunque tieni presente che l'emulatore ci mette una vita a partire (e poi comunque è lentissimo).

Io mi trovo bene ad usare come emulatore il porting non ufficiale per x86 di android. In particolare con le immagini precompilate che trovi qui :

http://home.comcast.net/~rbg.tabletsx86/rc2-armadd.htm

in particolare io uso la versione eth0-gen che in virtual box va benissimo. Rispetto all'emulatore è un altro pianeta come velocità di esecuzione (e quindi debug, testing, ...). In rete trovi molte risorse su come configurare il tutto (non è difficile).
The quiet ones are the ones who change the world. The loud ones only take the credit.
Avatar utente
puzuma
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: mar lug 04, 2006 16:14
Località: Udine
Nome Cognome: Stefano Salvador
Slackware: current
Kernel: 2.6.32.2
Desktop: KDE 4.4.0

Re: Android SDK problema emulatore

Messaggioda -sf » mar set 25, 2012 16:02

Io ho installato l'SDK ma senza il plugin per eclipse e, a parte la lentezza generale dell'emulatore, tutto funziona regolarmente.
Utilizzo una slack 13.37 64bit con le multilib di alien.

Non ho fatto molti test perche' ti passa la voglia per quanto e' lento :| , anche se probabilmente basta configurarlo un po' meglio di quanto abbia fatto io.

Ti consiglio anche io il porting x86!
Avatar utente
-sf
Linux 2.4
Linux 2.4
 
Messaggi: 209
Iscritto il: ven lug 15, 2011 0:20
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE

Re: Android SDK problema emulatore

Messaggioda RedSkull92 » mer set 26, 2012 0:58

Ho messo le swf nella directory tools ed è partito.
In effetti è qualcosa di allucinante, troppo lento!
Quindi dite che con la virtual box e il porting x86 va meglio ?
In pratica cosa dovrei fare per passare le app dal mio sistema al sistema android ?
Compilo direttamente sulla macchina virtuale ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Android SDK problema emulatore

Messaggioda puzuma » gio set 27, 2012 7:14

RedSkull92 ha scritto:In pratica cosa dovrei fare per passare le app dal mio sistema al sistema android ?


questa è una buona guida:

http://brunocosta.com/blog/2011/11/02/speeding-up-android-development-with-android-x86-and-virtualbox/

in pratica la macchina virtuale viene vista come un device reale a cui ti colleghi tramite rete. Poi gestisci tutto da eclipse come e meglio dell'emulatore.
The quiet ones are the ones who change the world. The loud ones only take the credit.
Avatar utente
puzuma
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: mar lug 04, 2006 16:14
Località: Udine
Nome Cognome: Stefano Salvador
Slackware: current
Kernel: 2.6.32.2
Desktop: KDE 4.4.0

Re: Android SDK problema emulatore

Messaggioda lennynero » mar ott 02, 2012 20:13

RedSkull92 ha scritto:Ho messo le swf nella directory tools ed è partito.

Cosa sono le swf?
Avatar utente
lennynero
Linux 2.6
Linux 2.6
 
Messaggi: 566
Iscritto il: dom mag 02, 2004 23:00
Località: Salerno
Slackware: 14.1-x64
Kernel: 3.10.17
Desktop: xfce-4.10


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite