Repository 32bit  Forum
Repository 64bit  Wiki

Ancora con la stampante Samsung ML-1640

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Ancora con la stampante Samsung ML-1640

Messaggioda ginoza » lun ott 08, 2012 5:10

Chiedo scusa se ancora una volta vengo a proporre il problema della mia stamapnte: Samsung Laser ML-1640. Sono mortificato per non avere ancora risolto il problema e questa richiesta di aiuto è l'ultimo tentativo prima di cedere le armi!
Dunque ho reinstallato Slackware 14 x32 bit e tutto è andato bene tranne che la stamapnete in questione non stampa, cioè il programma la vede, la stampante parte e fa uscire la pagina ma senza scritto sopra un bel niente: foglio in bianco!
Avrò fatto una decina di volte i vari tentativi suggeritemi in google e nel forum, ma senza successo. Non capisco dove sbaglio e sono in confusione.
Chiedo la cortesia di una guida ben chiara per risolvere il problema prima di abbandonare, scoraggiato, definitivamente slackware!
Grazie.
Gino
ginoza
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: lun mar 17, 2008 17:30

Re: Ancora con la stampante Samsung ML-1640

Messaggioda 414N » lun ott 08, 2012 8:54

Ho letto il tuo precedente thread (potevi continuare là, tra l'altro...) e ho visto che hai provato ad installare i driver splix. Come li hai installati sulla Slackware? Hai convertito il .deb o .rpm in tgz e installato quello? O hai scaricato lo SlackBuild da slackbuilds.org e creato un pacchetto Slackware? Hai installato anche jbigkit, come suggerito su SBo? CUPS riporta errori nel suo log quando "stampa" una pagina bianca?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ancora con la stampante Samsung ML-1640

Messaggioda ginoza » lun ott 08, 2012 9:49

Grazie della risposta, 414N. Allora ho scaricato e provata ad installare 'splix' in questo modo:
bash-4.2# rpm --nodeps -ivh openprinting-splix-2.0.0-2lsb3.2.i486.rpm
Preparing... ################################# [100%]
package openprinting-splix-2.0.0-2lsb3.2.i486 is already installed
Mi dice che è già installato, ma la stampante non scrive..., parte e butta fuori il foglio in bianco!
Il pacchetto "jbigkit" non l'ho installato. Cups non mi riporta alcun errore quando stampa la pagina in bianco.
Io le ho provate tutte..., provato tanti suggerimenti...forse ( di certo) sbaglio in qualcosa. Ma non so dove e come sbaglio.
Vorrei un preciso e chiaro suggerimento per risolvere definitivamente questo problema, che per me ormai è una ossessione oltre che una mortificazione per non essere ancora stato capace di risolvere.
Grazie.
Gino
ginoza
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: lun mar 17, 2008 17:30

Re: Ancora con la stampante Samsung ML-1640

Messaggioda 414N » lun ott 08, 2012 9:59

Primo suggerimento: non usare pacchetti "alieni" alla distribuzione che stai usando (Slackware). rpm non è usato da Slackware per la gestione dei pacchetti e lo trovi installato solo per la conversione da rpm a tgz, qualora servisse (quasi mai).
Io procederei così:
  1. Disinstalla tutto quello che hai installato per far funzionare la stampante (per rimuovere gli rpm, usa "rpm -e nome_pacchetto"), compreso cups con un bel
    Codice: Seleziona tutto
    removepkg cups
    Se durante la disinstallazione di cups compaiono messaggi del tipo "Directory /pinco/pallo contains new file, will not be removed", riportale in un post che controlliamo insieme se sono da rimuovere o meno
  2. Reinstalla cups con
    Codice: Seleziona tutto
    slackpkg install cups
    e assicurati che non ci sia nessuna stampante già installata (nel caso rimuovila)
  3. Crea il pacchetto per jbigkit ed installalo (usa lo SlackBuild su SBo)
  4. Crea il pacchetto per splix ed installalo (usa lo SlackBuild su SBo anche qua)
  5. Riavvia cups con
    Codice: Seleziona tutto
    /etc/rc.d/rc.cups restart
    e prova ad eseguire una nuova installazione per la tua stampante andando su localhost:631 col tuo browser di fiducia.
Se qualcosa non ti torna in uno di questi passaggi, fermati subito e riporta i dubbi/messaggi/errori comparsi a video prima di proseguire coi passaggi successivi
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ancora con la stampante Samsung ML-1640

Messaggioda ginoza » lun ott 08, 2012 10:19

Susa la mia ignoranza. Vorrei capire meglio i N° 3 e 4 del tuo messaggio. Come faccio io a creare il pacchetto "jbigkit"? e non capisco cosa vuol dire quello scritto tra parentesi: (usa lo SlackBuild su SBo).
Così pure cosa si intende: Crea il pacchetto per splix?
Sono sempre alle prime armi con la guerra in Slackware: per me è una vera guerra! Non ho mai fatto così tanta fatica in altre distro linux come con slackware: mi pare perfino impossibile.
Se risolvo il problema con la stamapnte poi il resto va bene e mi posso dedicare a conoscere meglio slack.
Grazie.
Gino
ginoza
Linux 1.0
Linux 1.0
 
Messaggi: 94
Iscritto il: lun mar 17, 2008 17:30

Re: Ancora con la stampante Samsung ML-1640

Messaggioda 414N » lun ott 08, 2012 10:41

La creazione di pacchetti Slackware è solitamente automatizzata per mezzo di script chiamati SlackBuild. Si tratta di script per la shell che automatizzano la preparazione di un pacchetto Slackware per il programma che ti interessa. Una volta ottenuto il pacchetto per il programma che ti interessa, sarà più agevole installare e disinstallare tale programma su Slackware
Slackbuilds.org (SBo in breve) è un sito che contiene una raccolta di SlackBuild per una serie di programmi non inclusi in Slackware, tra i quali proprio splix e jbigkit (che è una dipendenza di splix). Tutto quello che devi fare consiste solo in:
  1. Scaricare l'archivio contenente lo SlackBuild (e qualche file di contorno) che su SBo trovi subito sotto la dicitura "Download SlackBuild"
  2. Estrarre l'archivio dello SlackBuild
  3. Scaricare i sorgenti del programma indicati nella pagina sotto la dicitura "Source downloads" (sempre su SBo). Il codice che compare a fianco è l'MD5 dei sorgenti, da controllare nel caso ti venisse il dubbio che l'archivio scaricato sia corrotto.
  4. Piazzare l'archivio dei sorgenti (senza estrarlo) all'interno nella stessa directory contenente lo SlackBuild
  5. Lanciare lo SlackBuild come root, per esempio tramite
    Codice: Seleziona tutto
    su -c ./nomeProg.SlackBuild
  6. Attendere la fine del processo di creazione del pacchetto (dovrebbe comparire un messaggio del tipo "Slackware package for XXX created in YYY") ed installare il pacchetto creato (solitamente posto in /tmp) con installpkg
Tutto questo può anche essere svolto automaticamente con l'ausilio di sbopkg, che però non ho mai usato e sul quale posso dirti molto poco.
Per saperne di più sugli SlackBuild ti consiglio vivamente di leggere l'Howto su slackbuilds.org stesso o, in alternativa, questa introduzione in italiano.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ancora con la stampante Samsung ML-1640

Messaggioda pino » lun ott 08, 2012 17:24

Siamo sicuri che la stampante funziona?
Io questa stessa stampante, la ho installata su una 12.1 coi drive scaricati da samsung e hanno funzionato subito
pino
Linux 2.4
Linux 2.4
 
Messaggi: 481
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde


Torna a Slackware

Chi c’è in linea

Visitano il forum: Google [Bot], Yahoo [Bot] e 3 ospiti