Repository 32bit  Forum
Repository 64bit  Wiki

driver nvidia

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

driver nvidia

Messaggioda erio » mar ott 09, 2012 19:01

ciao nessuno ha avuto problemi ad installare i driver nvidia nella 14 32 bit?
119.857264] nvidia: version magic '3.2.29-smp SMP mod_unload PENTIUMIII ' should be '3.2.29 mod_unload 486 '
ERROR: Installation has failed. Please see the file '/var/log/nvidia-installer.log' for details. You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.
questo e' il finale del log,ma premetto che le prove le ho fatte con huge, huge-smp,generic con initrd,succede solo a me?
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1088
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: driver nvidia

Messaggioda uboot » mar ott 09, 2012 20:33

Sinceramente mi trovo bene con i driver "nouveau" mi evitano ogni volta che ricompilo di dover reinstallare i driver proprietari.
sembra che il modulo sia compilato per i386 , mentre dovrebbe essere per i486
hai i sorgenti del kernel in /usr/src ed il link linux ->linux-3.x.x ?
#bash NVIDIA-Linux-x86-xxxxx-pkg1.run --kernel-source-path=/pathto/linux-source
prova ......
Avatar utente
uboot
Linux 1.0
Linux 1.0
 
Messaggi: 12
Iscritto il: lun dic 24, 2007 20:17
Località: Attimis
Slackware: 14
Kernel: 3.0.0
Desktop: KDE 4.8.5

Re: driver nvidia

Messaggioda erio » mar ott 09, 2012 20:39

la cosa strana e' che i noveau sono disabilitati,ma ho uno pseudo composito,questa cosa la fa con tutti i kernel della 14,anche generic con l'initrd,non ho altri kernel in /usr/src solo il default,mi sa che metto su un'altro kernel.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1088
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: driver nvidia

Messaggioda Rama » mar ott 09, 2012 21:29

erio ha scritto:ciao nessuno ha avuto problemi ad installare i driver nvidia nella 14 32 bit?

uso la Slack a 64 ma anch'io non sono riuscito a farli andare -non ricordo bene ma mi sembra che non segnalassero errori ma non c'era verso di applicare gli effetti spezziali;
comunque i nouveau vanno ottimamente, fino alla 13.37 era il contrario: i nouveau non andavano e quelli proprietari sì;
spero che non arrivi mai il giorno in cui non funzionassero entrambi;

r
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.16.3 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: driver nvidia

Messaggioda guybrush.d » mar ott 09, 2012 23:41

Ciao,
io ho appena installato su slackware x86 gli nvidia ufficiali versione 304.43 e va tutto senza problemi, l'installer NVIDIA la prima volta,
ha rilevato i nuveau e mi ha blacklistato il modulo in automatico, dopo il riavvio ho effettuato si nuovo l'installazione
è ora funziona senza problemi! :D
Avatar utente
guybrush.d
Linux 2.0
Linux 2.0
 
Messaggi: 155
Iscritto il: lun apr 26, 2010 23:04
Località: Varie
Nome Cognome: Diego
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: Xfce 4.10

Re: driver nvidia

Messaggioda drumslack » mer ott 10, 2012 9:29

Ciao a tutti, io invece ho installato i driver nvidia (V. 304.51) usando il suo installer su Slackware 14 32bit e non ho incontrato problemi. In realtà funzionava bene anche con i nouveau, infatti sull'altra macchina con la Slackware x86_64 mi sa che tengo i nouveau, ma ho voluto fare questa prova sulla i486.
Ora Slackware 14 mi funziona bene con entrambi i driver e posso scegliere se usare nvidia e nouveau, invece sulla 13,37 con i nouveau andava un po a scatti.
In certi ambiti, le cose semplici sono le più facili da imparare, e spesso, è più difficile capire una cosa facile perchè rendendola tale si è dovuto complicarla.
~/ = 'sono a casa'
drumslack
Linux 1.0
Linux 1.0
 
Messaggi: 39
Iscritto il: sab mag 05, 2012 1:03
Località: San Bonifacio (VR)
Nome Cognome: Gianluca Pernigotto
Slackware: 13.37 32/64bit
Kernel: 2.6.37.6-smp
Desktop: Kde
Distribuzione: Debian

Re: driver nvidia

Messaggioda Plaoo » mer ott 10, 2012 10:11

@erio prova i driver beta
Il canale ufficiale di slacky.eu si trova sui server irc.syrolnet.org canale #slackware
Avatar utente
Plaoo
Linux 2.6
Linux 2.6
 
Messaggi: 809
Iscritto il: gio apr 10, 2008 16:40
Località: Ittiri (SS)
Slackware: 14 64
Kernel: 3.2.9
Desktop: KDE

Re: driver nvidia

Messaggioda erio » mer ott 10, 2012 10:22

i driver nvidia sono i 304.51,installazione della 14 da dvd, partizione nuova,penso piu' a un problema di configure del kernel,con il 3.5.5 nessun problema ho i driver installati.per la 64 bit invece tutto liscio,nessun problema.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1088
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: driver nvidia

Messaggioda pino » mer ott 10, 2012 15:14

erio ha scritto:i driver nvidia sono i 304.51

Da me questi stessi drive sulla 14 32 bit funzionano senza problemi.
pino
Linux 2.4
Linux 2.4
 
Messaggi: 489
Iscritto il: ven gen 18, 2008 15:34
Località: Torino
Nome Cognome: Pino
Slackware: 14
Desktop: kde

Re: driver nvidia

Messaggioda unonessuno » mer ott 10, 2012 23:35

Ciao a tutti.
Ho installato i driver propietari, su Slackware 14.0 a 32 bit con XFCE4.10, scaricandoli dal sito della Nvidia, iquesti:
Codice: Seleziona tutto
NVIDIA-Linux-x86-304.51.run

Nessun problema, tutto funziona, l'eseguibile disattiva e blacklista i driver Nouveau durante l'installazzione.
L'unico problema nel mio caso consite nel fatto che non riesco a fargli salvare la configurazione di:" nvidia-settings" nel senso che non mi scrive i nuovi settaggi nel file:"nvidia-settings-rc" nemmeno avviando l'interfaccia grafica da root.
Ho editato e configurato il predetto file manualmente e poi ho dato prima da root e poi come utente normale i seguenti comandi:
Codice: Seleziona tutto
nvidia-settings --load-config-only &  nvidia-settings

Tutto come al solito, mi prende la configurazione, ma se riavvio l'interfaccia grafica (nvidia-settings) sovrascrive il file di configurazione azzerando tutti i parametri.

Qualcuno sa se esiste un modo per ovviare a questo problema ??

PS- Con Slack. 13.0 con XFCE il tutto funzionava .

Ciao e grazie.
Avatar utente
unonessuno
Linux 2.0
Linux 2.0
 
Messaggi: 137
Iscritto il: dom giu 27, 2010 2:59
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: XFCE4.10

Re: driver nvidia

Messaggioda Rama » gio ott 11, 2012 11:44

puoi provare a togliere i permessi di scrittura al file;

r
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 254
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.16.3 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti