Problemi con lettore DVD-ROM

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
sbabaro
Packager
Packager
Messaggi: 388
Iscritto il: ven set 09, 2005 0:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: Problemi con lettore DVD-ROM

Messaggioda sbabaro » ven ott 12, 2012 9:57

Direi che è rotto

A questo punto hai due possibilità: installare exnovo o fare un upgrade alla nuova slackware

Dò per scontato che il pc è in rete

Per l'upgrade, monta il dvd su un'altra macchina, copia i file in locale ed esegui l'upgrade

Per reinstallare, hai bisogno di fare il boot da cd, e quindi la cosa migliore è scaricarti il cd1, poi in fase di installazione monti il dvd remoto e installi

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » ven ott 12, 2012 10:13

Il problema è che il PC non è in rete e per collegarlo al mio portatile servirebbe un cavo di rete incrociato che purtroppo non ho...

Pensavo di fare come ho già fatto per l'installazione della 13.37.

Ovvero avevo diviso l'HD del vecchio PC in due partizioni. Una l'ho utilizzata come target dell'installazione, l'altra come stoccaggio dei files di slackware.
Poi ho scaricato il CD1 di slack 13.37 e ho avviato con quello l'installazione.
Quando mi ha chiesto cosa usare come sources device dei pacchetti, ho scelto la partizione di stoccaggio precedentemente riempita col contenuto del dvd.

Quindi questa soluzione so che funziona.
Il problema è che al momento ho il dvd della 14.0, ma non ho il CD1 della stessa per avviare il PC e l'installazione.
Siccome poi ho una connessione via cellulare che va a 15KB/s, capirai bene quanto impiego a scaricare il CD1.

Mi chiedevo allora se non ci fosse un modo per crearmi il CD1 o qualcsoa di simile a aprtire dal DVD.
Ne sapete nulla?

sbabaro
Packager
Packager
Messaggi: 388
Iscritto il: ven set 09, 2005 0:00
Slackware: slack 12.1
Kernel: 2.6.26 ricompilato
Desktop: gslacky

Re: Problemi con lettore DVD-ROM

Messaggioda sbabaro » ven ott 12, 2012 10:23

Se guardi nel dvd, dentro isolinux è descritto come creare il cd di boot.
Puoi anche saltare la fase di creazione dei tree separati, tanto tu i dati non li metti sul cd ma su hd

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4944
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Problemi con lettore DVD-ROM

Messaggioda ZeroUno » ven ott 12, 2012 10:26

joe ha scritto:Mi chiedevo allora se non ci fosse un modo per crearmi il CD1 o qualcsoa di simile a aprtire dal DVD.

http://slackware.osuosl.org/slackware-1 ... README.TXT
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
waka_jawaka
Linux 2.6
Linux 2.6
Messaggi: 779
Iscritto il: mer ago 10, 2005 0:00
Nome Cognome: Alberto Palillo
Kernel: 2.6.35
Desktop: KDE 4.5
Distribuzione: Archlinux

Re: Problemi con lettore DVD-ROM

Messaggioda waka_jawaka » ven ott 12, 2012 10:41

Perso per perso puoi provare a pulire la lentina del lettore. A volte può essere un semplice problema di lente sporca (decisamente a volte).
Nel caso tu abbia tempo (ce ne vuole poco) e soprattutto voglia ti conviene usare un cotton fioc: ne "sgrani" un'estremità per renderla più morbida, la bagni con acqua (possibilmente distillata ma ASSOLUTAMENTE no alcool) e strofini delicatamente la lente.
Ciao

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » ven ott 12, 2012 11:24

La prova pulizia posso sempre farla, anche in futuro prima di riconsegnare il cassone. Il problema è che la lente non è a vista come nel dvd-rw del mio portatile. Per raggiungerla mi sa che devo smontare tutto e non l'ho mai fatto, probabilmente è una sciocchezza ma mi ci vuole sicuramente più tempo che non a crearmi il CD1 immagino. Quindi rimando l'operazione... Cosa ne dici waka?

Vado dunque a leggere le info per creare il CD di boot. Grazie del link gente!
Vi faccio sapere se riesco o se incontro ostacoli.

Arrileggerci! :D

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » ven ott 12, 2012 12:53

Mmm...
Dunque da quanto capisco basterebbe nel mio caso mettere in una directory temporanea le dir:
- isolinux
- kernels
In teoria servirebbe anche al dir slackware ma al limite io la metto vuota tanto poi i pacchetti li prendo da HD...
Provo usando un CD-RW. Vediamo cosa ne esce...

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » ven ott 12, 2012 14:14

Sembra funzionare.
Ho creato una dir temporanea contenente le dir:
- isolinux copiata dal tree della 14.0
- kernels copiata dal tree della 14.0
- slackware creata vuota (non si sa mai che serva a qualcosa... magari il programma d'installazione la richiede... non so)

Poi ho creato la iso come descritto nel README di isolinux.

Poi l'ho masterizzata su un CD-RW.

Infine ho fatto partire il PC con questo simil CD1-slackware-14.0
Il programma d'installazione sembra funzionare, però non l'ho testato fino in fondo perchè non avevo ancora copiato il tree della 14.0 nella seconda partizione dell'hd del PC. Operazione che ho appena lanciato e si preannuncia piuttosto lunga.

Infatti ho dovuto passare i files (il tree e anche la iso del dvd della 14) su una chiavetta usb. Da lì poi li sto copiando nell'HD del vecchio PC da sistemare.

Vi farò sapere come và a finire.

Avatar utente
ZeroUno
Staff
Staff
Messaggi: 4944
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

Re: Problemi con lettore DVD-ROM

Messaggioda ZeroUno » ven ott 12, 2012 15:29

e perchè li copi su harddisk? lasciali su chiavetta no?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » ven ott 12, 2012 16:36

Hai ragione anche te...
è più veloce dici eh...

Avatar utente
joe
Iper Master
Iper Master
Messaggi: 2509
Iscritto il: ven apr 27, 2007 11:21
Slackware: 14.0
Kernel: 3.19.4-hb_smp
Desktop: KDE-4.8.5

Re: Problemi con lettore DVD-ROM

Messaggioda joe » sab ott 13, 2012 11:46

Ok gente!
Installazione completata, utente semplice creato.... KDE avviato senza problemi. Con la 13.37 avevo dovuto mettere mano alla configurazione di kde per farlo partire, altrimenti dava problemi, immagino con la scheda video...

Devo dire che esteticamente l'icona della directory in stile oxygen mi piaceva di più nella versione di kde della 13.37. Questa sembra molto più anni 90... :(
Ora però devo mettervi mano per rendere kde un po' più "leggero", vado a ripescare qualche mio vecchio topic.

Per quanto riguarda il DVD si potrebbe dare un'occhiata sotto il cofano ma mi affiderò a un amico più esperto di me in fatto di hardware e smanettamenti a cacciavite! Grazie ad ogni modo.
Alla prossima! :D
Alla prossima.


Torna a “Gnu/Linux in genere”

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti