Repository 32bit  Forum
Repository 64bit  Wiki

kde dopo il comando startx da errore e non si apre

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

kde dopo il comando startx da errore e non si apre

Messaggioda binkoza » mer ott 17, 2012 18:52

Buonasera,
mi chiamo andrea e sono uno studente che utilizza uno slackware 13.37 a 64 bit..
L'ho installato di recente sul mio nuovo netbook asus.
L'installazione e' stata effettuata senza alcun problema ma quando do il comando startx per
lanciare kde essa crashia e mi da un errore strano.
Il mio insegnate dice che probabilmente c'è un problema con l'accellerometro della scheda video.
Voi sapete come posso risolvere il mio porblema ?
Grazie per il vostro aiuto e buona serata.
Binkoza
binkoza
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mer ott 17, 2012 18:44

Re: kde dopo il comando startx da errore e non si apre

Messaggioda Rama » mer ott 17, 2012 22:08

che errore?
probabilmente si tratta di installare i driver proprietari, che scheda hai?
hai provato con un'altra interfaccia? mi sembra che KDE abbia bisogno dell'accelerazione mentre altre, tipo Fluxbox, no -almeno, così mi è capitato di recente con la scheda nvidia;
scheda che con la 13.37 crashava con i driver open, tanto che instalalndo la 14 ho messo quelli proprietari prima di avviare la grafica, nat. è andata in crash: per questo giro la scheda gradisce i driver open e non i proprietari ;-P

r
Un Minuto Per Favore: http://www.umpf.net
Home Page, The Pentangle, I Salon di Baudelaire
Avatar utente
Rama
Linux 2.4
Linux 2.4
 
Messaggi: 248
Iscritto il: sab mar 29, 2008 12:18
Località: Novara, provincia
Slackware: 14.1 64bit
Kernel: 3.12.6 preemptive
Desktop: KDE 4.10.5
Distribuzione: Debian testing

Re: kde dopo il comando startx da errore e non si apre

Messaggioda darkstaring » mer ott 17, 2012 22:26

Sicuramente in "/var/log/Xorg.0.log" trovi i dettagli...

prova a leggerlo con
less /var/log/Xorg.0.log
e posta gli errori
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 366
Iscritto il: mer ott 13, 2010 12:55
Desktop: xfce
Distribuzione: Kali Linux

Re: kde dopo il comando startx da errore e non si apre

Messaggioda binkoza » gio ott 18, 2012 10:39

ho una radeon HD 6320 , l'interfaccia che lancio con startxfce4 parte senza problemi ...
quando lancio il comando less /var/log/Xorg.0.log mi da 2800 righi e non posso postarveli per ora perche ancora non ho installato wicd ...
Non c'è un modo per scaricare i miei driver mancanti o per lo meno disattivare l'accelerometro ?
binkoza
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: mer ott 17, 2012 18:44

Re: kde dopo il comando startx da errore e non si apre

Messaggioda lablinux » gio ott 18, 2012 13:14

a me succedeva, con la 13.37 con una scheda nvidia. xfce e fluxbox andavano senza problemi, kde no. Ho installato i driver nvidia, scaricandoli dal sito del produttore e tutto si è risilto.
Ora, con la 14, non ho dovuto installare nessun driver e kde va benone. Probabilmente i nuovi noveau (si scrive cosi?) gestiscono la mia scheda. Oppure è qualche miglioria in kwin, boh? sta di fatto che funziona out of the box.
Detto questo. Fosse in te, prima cosa passerei alla 14, e poi, se la radeon insiste a non voler funzionare, proverei con i dirver close, ma prima una prova con la 14 la farei.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 753
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: kde dopo il comando startx da errore e non si apre

Messaggioda darkstaring » gio ott 18, 2012 19:15

binkoza ha scritto:ho una radeon HD 6320 , l'interfaccia che lancio con startxfce4 parte senza problemi ...
..Non c'è un modo per scaricare i miei driver mancanti o per lo meno disattivare l'accelerometro ?

Strano che parta solo xfce..
io ho una ati hd un pò più vecchia della tua e con i driver inclusi nel kernel và alla grande :D ...

prova ad avviare il comando
X -configure
e ad avviare kde.. se non và
potresti provare ad utilizzare il driver vesa.. così dovrebbe partire al 99% credo :)..
Devi copiare il file Xorg-vesa.conf o qualcosa del genere in /etc/X11/xorg.conf.d/,
è nella directory /etc/X11, non sono davanti al mio pc ora ma vedi lì...
darkstaring
Linux 2.4
Linux 2.4
 
Messaggi: 366
Iscritto il: mer ott 13, 2010 12:55
Desktop: xfce
Distribuzione: Kali Linux

Re: kde dopo il comando startx da errore e non si apre

Messaggioda rik70 » gio ott 18, 2012 19:35

Prova a creare con un editor di testo il file /etc/X11/xorg.conf.d/90-extensions.conf e mettici dentro questo:

Codice: Seleziona tutto
Section "Extensions"
   Option "Composite" "Disable"
EndSection
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1241
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron