Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] flash in blu (driver nvidia proprietari)

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: flash in blu

Messaggioda tornadomig » sab ott 20, 2012 0:36

al momento su youtube non ho video puffati con firefox ultimo. sono slack 14 stable
nvidia 304.60 presi e compilati dal tuo repo
flashplayer-plugin-11.2.202.243-x86_64-1alien compilato
libvdpau-0.4.1-x86_64-1ponce preso da slackbuilds.org

altro non e' stato toccato

sul gioco da te postato anche se non mi piace :roll: va tutto senza blu e per ora e' cosi'. domani ti confermo se rimane tale. anzi se vuoi suggerirmi tu altri test, basta dirlo
Ultima modifica di tornadomig il sab ott 20, 2012 8:39, modificato 2 volte in totale.
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 508
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: flash in blu

Messaggioda ZeroUno » sab ott 20, 2012 0:52

Il gioco non ha il problema del blu ma della lentezza (o meglio, lampeggio di alcune sezioni che non fanno un buon rendering)

Hai file quali /etc/adobe/mms.cfg o /etc/vdpau_wrapper.cfg ? sono loro che eliminano l'effetto puffo.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda Trotto@81 » sab ott 20, 2012 7:23

Lo vedo bene quel gioco, ed è pure fluido.
Senza pacchetto esterno a te viene visualizzato meglio oppure carica di meno la cpu?
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3032
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: flash in blu

Messaggioda tornadomig » sab ott 20, 2012 8:41

@ZeroUno

altro non e' stato toccato
nessuna modifica al file menzionato

poi guardo ancora quel giochetto...
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 508
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: flash in blu

Messaggioda ZeroUno » sab ott 20, 2012 21:22

Ho caricato tutto su slacky (saranno su domattina)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda ZeroUno » dom ott 21, 2012 18:25

mmm. Da quando ho messo i 304.60 non mi funziona più la gestione della luminosità dello scrermo sul portatile via software (cioè dall'icona della batteria) e se stacco l'alimentatore quindi non varia la luminosità.
Se invece uso i pulsanti Fn+F4/F5 funziona.

Il changelog riporta:
Fixed a bug that caused the X server to crash if a display was put into DPMS off mode and subsequently reenabled while screen transformations are in use.

Added support for the "Backlight" RandR output property for configuring the brightness of some notebook internal panels.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda Trotto@81 » mer ott 24, 2012 20:12

Hanno fixato e non ti funziona più?
Purtroppo non ho un portatile per darti il mio risconto.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3032
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: flash in blu

Messaggioda ZeroUno » mer ott 24, 2012 20:42

fixato?
Prima funzionava, ora no.
Non mi sembra una granfix ;)

appena posso faccio il downgrade così scopro se il problema rimane (magari ho sbagliato la configurazione, ma non mi sembra di averla toccata.
Comunque la fix era sul crash di X e a me non ha mai crashato.


Domanda.. Flash in blu é solo a 64bit o anche a 32?
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda boh » mer ott 24, 2012 20:44

A me capita solo nel sistema a 64bit.
Però il sistema a 32bit non ha una scheda grafica nvidia.

EDIT: come feedback, volevo dire che ho installato i driver nvidia 304.60 (con il loro installer, non il pacchetto di ZeroUno) e l'effetto puffo era presente. Successivamente ho installato le libvdpau 0.5 e l'effetto è svanito! Il tutto con accelerazione hardware attiva :D
"Be yourself. Everyone else is already taken." ~ Oscar Wilde
Avatar utente
boh
Linux 2.6
Linux 2.6
 
Messaggi: 964
Iscritto il: gio set 15, 2005 23:00
Località: Milano
Slackware: 14.1 (x64)
Kernel: 3.14.1
Desktop: KDE 4.13.3

Re: flash in blu

Messaggioda ZeroUno » mer ott 24, 2012 21:51

come feedback, volevo dire che ho installato i driver nvidia 304.60 (con il loro installer, non il pacchetto di ZeroUno) e l'effetto puffo era presente. Successivamente ho installato le libvdpau 0.5 e l'effetto è svanito! Il tutto con accelerazione hardware attiva :D

Si, è ormai un dato di fatto (v. qualche pagina indietro) che l'ultima versione di libvdpau risolve il problema, mentre il vdpau di nvidia (pacchetto o installer che sia) no.
Io al momento mantengo quelle di nvidia perchè qualche problema con l'accelerazione ce l'ho.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda ZeroUno » mer ott 24, 2012 22:09

ZeroUno ha scritto:appena posso faccio il downgrade così scopro se il problema rimane (magari ho sbagliato la configurazione, ma non mi sembra di averla toccata.
Comunque la fix era sul crash di X e a me non ha mai crashato.

Confermo. Ho downgradato a 304.51 ed ora se stacco il cavo di alimentazione la luminosità varia (pur non avendo toccato la configurazione).
A meno che la 304.60 non abbia introdotto una nuova entry da dover configurare per attivare la gestione della luminosità.

Per ora mi tengo questa (con nvidia-vdpau, poi la provo anche con libvdpau 0.5) finchè nvidia non tira fuori un'altra fix o scopro l'arcano.

Purtroppo non posso fare troppi reboot al giorno (per lavorare tengo aperte 100 finestre, tra multiple login ssh, pagine web e documenti che non sono convenienti chiudere)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda ZeroUno » gio ott 25, 2012 9:11

http://www.nvidia.com/object/linux-disp ... river.html

Implemented workarounds for two Adobe Flash bugs by applying libvdpau commit ca9e637c61e80145f0625a590c91429db67d0a40 to the version of libvdpau shipped with the NVIDIA driver.


wow, li provo subito, e chissenefrega che sono beta, se è vero.


edit: questo credo che dimostri che le api (gli header) di nvidia-vdpau e libvdpau siano compatibili se non gli stessi. Il che significa che se rifaccio il pacchetto nvidia-vdpau posso anche fare un merge con libvdpau.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda Trotto@81 » gio ott 25, 2012 9:18

Attendo sviluppi per fare un upgrade del tuo pacchetto nvidia 304.43 che uso con le libvdpau esterne.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3032
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: flash in blu

Messaggioda ZeroUno » gio ott 25, 2012 9:23

le vdpau esterne le ho messe sul 304.60
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4414
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: flash in blu

Messaggioda Trotto@81 » gio ott 25, 2012 9:31

Hanno gli header per compilare MPlayer con il supporto a vdpau?
La cosa che mi da fastidio è che sulle animazioni o video in flash ho l'effetto scia durante lo scrolling.
Ho tolto le due opzioni dal file nvidia.conf perchè mi rallentavano molto.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 3032
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

PrecedenteProssimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti