Repository 32bit  Forum
Repository 64bit  Wiki

Installazione Driver ATI proprietari

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » lun dic 03, 2012 0:01

premetto di aver creato /etc/modprobe/blacklist.conf
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Installazione Driver ATI proprietari

Messaggioda 414N » lun dic 03, 2012 8:48

Posso darti un consiglio spassionato? Dimenticati xorgsetup, per il momento...
Torniamo da capo:
  1. avvia il sistema e verifica, tramite lsmod che il modulo radeon non sia stato caricato mentre fglrx sì
  2. ricrea il file xorg.conf tramite "aticonfig --initial" (o rimetti quello che hai salvato nella tua home) e poi prova ad avviare X
  3. se si pianta con una schermata nera, passa ad un'altra tty (tramite CTRL+ALT+F1/4), loggati come root e salvati il log attuale di X (che è /var/log/Xorg.0.log e non /var/log/Xorg.0.log.old)
  4. posta quel log relativo al solo fglrx, così vediamo di capirci qualcosa una volta per tutte
Per curiosità, quali driver Catalyst hai installato?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione Driver ATI proprietari

Messaggioda Amrod » lun dic 03, 2012 19:39

DarkNeo ha scritto:premetto di aver creato /etc/modprobe/blacklist.conf


/etc/modprobe invece di /etc/modprobe.d è solo un refuso?
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » lun dic 03, 2012 23:36

@Amrod è stato un errore di battitura è /etc/modprobe.d/blacklist.conf

@414N c'è un dettaglio che stiamo trascurando, se io do, come ho gia provato, solo aticonfig --initial mi crea un xorg.conf che non mi fa partire la grafica e mi da la schermata nera. Per tanto questo errore non solo fa vedere nero ma disabilita anche l'uso di tastiera e mouse e mi risulta impossibile tornare alla console con CTRL+ALT+F1/4
questo è il file che ho scaricato:
amd-driver-installer-12.6-legacy-x86.x86_64.zip mi ha creato questo pacchetto:
fglrx-8.97.100.3-x86_64-1.tgz
Ripeto che la mia è una ATI RADEON HD4200
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Installazione Driver ATI proprietari

Messaggioda 414N » mar dic 04, 2012 14:52

Premendo CTRL+ALT+BACKSPACE il server X viene "ammazzato", permettendoti di tornare ad una console testuale?
Hai verificato che radeon non sia caricato in lsmod?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » mar dic 04, 2012 16:43

Radeon non viene caricato ma con xorg.conf minimale di aticonfig non mi carica ne il mouse ne la tastiera quindi qualsiasi tipo di CTRL+ALT non funZiona
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Installazione Driver ATI proprietari

Messaggioda rik70 » mar dic 04, 2012 18:23

Fai questo tentativo:

1 - elimina/rinomina tutti file di configurazione di Xorg creati in precedenza;

2 - crea il file ''/etc/X11/xorg.conf.d/90-card.conf" e incollaci dentro:

Codice: Seleziona tutto
Section "Device"
        Identifier "Card0"
        Driver  "fglrx"
EndSection


3 - Da Init 3 fai un bel startx e vedi se salta fuori qualcosa di utile. Magari fai in modo che venga avviata una sessione grafica tipo Xfce/fluxbox... insomma... niente KDE per il momento.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1277
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Installazione Driver ATI proprietari

Messaggioda Amrod » mar dic 04, 2012 19:50

DarkNeo ha scritto:amd-driver-installer-12.6-legacy-x86.x86_64.zip mi ha creato questo pacchetto:
fglrx-8.97.100.3-x86_64-1.tgz
Ripeto che la mia è una ATI RADEON HD4200


Dovendo usare i legacy l'unica cosa che mi viene in mente è che siano incompatibili con la versione di xorg che hai in uso.
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Installazione Driver ATI proprietari

Messaggioda 414N » mar dic 04, 2012 20:00

Amrod ha scritto:Dovendo usare i legacy l'unica cosa che mi viene in mente è che siano incompatibili con la versione di xorg che hai in uso.

In realtà, nella pagina di download di quei driver legacy è riportato:
Codice: Seleziona tutto
Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

percui non dovrebbero esserci problemi con il Xserver di Slackware 14 (1.12.3)...
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione Driver ATI proprietari

Messaggioda Amrod » mar dic 04, 2012 20:59

414N ha scritto:In realtà, nella pagina di download di quei driver legacy è riportato:
Codice: Seleziona tutto
Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

percui non dovrebbero esserci problemi con il Xserver di Slackware 14 (1.12.3)...


Non avevo controllato i requisiti perche' mi sembrava lo stesso errore che mi era capitato quando, nella current, era
stato aggiornato X e i driver non erano compatibili.
Altre possibili cause non me ne vengono in mente.
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Installazione Driver ATI proprietari

Messaggioda 414N » mar dic 04, 2012 21:14

@DarkNeo: alla peggio, hai a disposizione un altro PC nella stesse rete di quello problematico dal quale poter fare login con ssh, in modo da vedere cosa succede quando lo schermo diventa nero?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » mar dic 04, 2012 22:21

si mo posto tutto
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » mar dic 04, 2012 22:32

ecco cosa succede
Codice: Seleziona tutto
root@Neo:~# startx :0.0
xauth:  file /root/.serverauth.2097 does not exist


X.Org X Server 1.12.3
Release Date: 2012-07-09
X Protocol Version 11, Revision 0
Build Operating System: Slackware 14.0 Slackware Linux Project
Current Operating System: Linux Neo 3.2.29 #2 SMP Mon Sep 17 14:19:22 CDT 2012 x                                             86_64
Kernel command line: BOOT_IMAGE=Linux ro root=803 vt.default_utf8=0
Build Date: 23 August 2012  02:03:27PM

Current version of pixman: 0.26.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  4 22:31:14 2012
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:17:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:18:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:1) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:19:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:0) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:2) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:3) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@0:20:4) found
(WW) fglrx: No matching Device section for instance (BusID PCI:0@1:5:1) found
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Installazione Driver ATI proprietari

Messaggioda 414N » mar dic 04, 2012 22:52

Sembra che il blocco di X impedisca anche il completamento della scrittura sul log: infatti, come si può notare, il log è troncato e riporta solo dei warning (che anche altri utenti hanno) che non dovrebbero precludere il funzionamento del sistema.
Potresti riprovare dando un "sync" mentre sei connesso tramite ssh e hai già dato startx sulla macchina con la scheda ATI/AMD, per vedere se vengono scritte altre righe utili nel log.
Altra cosa, hai notato qualche messaggio di errore nelle ultime righe di dmesg dopo aver lanciato startx?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installazione Driver ATI proprietari

Messaggioda DarkNeo » mar dic 04, 2012 23:12

Io sono connesso da ssh do startx su :0.0 chee è il monitor del portatile, dopo quella riga di log io vengo buttato fuori dall'ssh non posso fare piu nulla da remoto
questo è dmesg relativo a fgrlx
Codice: Seleziona tutto
[   12.108273] [fglrx] Maximum main memory to use for locked dma buffers: 3534 M                                             Bytes.
[   12.108360] [fglrx]   vendor: 1002 device: 9712 count: 1
[   12.108996] [fglrx] ioport: bar 1, base 0x9000, size: 0x100
[   12.109022] pci 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[   12.109028] pci 0000:01:05.0: setting latency timer to 64
[   12.109455] [fglrx] Kernel PAT support is enabled
[   12.109478] [fglrx] module loaded - fglrx 8.97.2 [Jul  4 2012] with 1 minors
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite