Repository 32bit  Forum
Repository 64bit  Wiki

Cloud9 IDE

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Cloud9 IDE

Messaggioda RedSkull92 » mar dic 04, 2012 13:31

Ho scoperto da qualche tempo questo IDE che online (https://c9.io/) mi è sembrato più che portentoso e mi è venuta l'idea di usare la versione offline.

Purtroppo per usarlo bisogna installare Node.Js e NPM (https://github.com/ajaxorg/cloud9), roba che non sono riuscito a trovare già pacchettizzata.

Ho trovato uno slackbuild che però mi richiede wscript più altra roba.
Oscurità totale per NPM.

Qualcuno ha qualche consiglio/pacchetto per riuscire ad avere il tutto ?

Chissà, magari potrebbe essere utile avere NodeJs e Cloud9 qui su Slacky.

Aspetto vostre notizie, grazie! :D
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Cloud9 IDE

Messaggioda lablinux » mar dic 04, 2012 16:23

node.js l'ho installato (non da pacchetti, ma dai sorgenti) NPM non ho proprio idea di cosa possa essere. Sul sito, cliccando su download ti rimanda al download di nodejs, non è che NPM sia una parte di nodejs?
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 752
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Cloud9 IDE

Messaggioda RedSkull92 » mar dic 04, 2012 18:29

Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Cloud9 IDE

Messaggioda lablinux » mer dic 05, 2012 0:24

nmp, sembra il gestore di pacchetti (plugins) di node.js
Se segui il link home, ti porta alla home di node.js, idem se vai sul download, ti scarica node.js.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 752
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Cloud9 IDE

Messaggioda RedSkull92 » mer dic 05, 2012 0:28

Quindi l'unico modo è installare da sorgenti ?
Non esiste qualcosa di precompilato o uno slackbuild che funzioni ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Cloud9 IDE

Messaggioda lablinux » mer dic 05, 2012 0:31

confermo npm serve per installare pezzi di codice. Carino froyo, un framework web https://npmjs.org/package/froyo
Installando nodejs, mi son trovato anche npm.
ti dirò la verità, pensavo di fare un pacchetto, ma il tempo è tiranno. Se hai urgenza, installalo dai sorgenti, altrimenti abbi pazienza.... molta pazienza.
Avatar utente
lablinux
Linux 2.6
Linux 2.6
 
Messaggi: 752
Iscritto il: gio nov 27, 2008 12:23
Località: Rho
Slackware: 14 64bit
Desktop: kde4

Re: Cloud9 IDE

Messaggioda ponce » mer dic 05, 2012 6:19

Avatar utente
ponce
Master
Master
 
Messaggi: 1500
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: Cloud9 IDE

Messaggioda RedSkull92 » mer dic 05, 2012 7:57

Avevo già visto quello slackbuild ma non mi partiva causa mancanza di wscript (che non sono riuscito a trovare)
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Cloud9 IDE

Messaggioda ponce » mer dic 05, 2012 9:48

il file wscript e' l'equivalente del Makefile pero' per waf, che e' nella directory tools dei sorgenti di node (wscript invece e' nella directory principale).

ho appena fatto un pacchetto su slackware64-14.0 facendo girare quello slackbuild.
Avatar utente
ponce
Master
Master
 
Messaggi: 1500
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: Cloud9 IDE

Messaggioda RedSkull92 » mer dic 05, 2012 14:44

Ma a me una volta fatto partire lo slackbuild mi estrae l'archivio (versione 0.8.15) e mi si ferma con
sed: can't read wscript: No such file or directory
EDIT: con la versione 0.6.17 sono riuscito a creare il pacchetto ma per avere una versione un po' più aggiornata ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Cloud9 IDE

Messaggioda ponce » mer dic 05, 2012 19:05

penso che tu debba sentire il maintainer dello script: e' probabile che lo usi in produzione e per qualche ragione abbia valutato che sia meglio tenere quella versione, davvero non saprei dirti (non lo uso)...
non gira cloud9 con quella versione di node?
Avatar utente
ponce
Master
Master
 
Messaggi: 1500
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: Cloud9 IDE

Messaggioda RedSkull92 » mer dic 05, 2012 20:23

Sì gira ma bisogna editare jsftp perché cloud9 funziona con una versione superiore non supportata per la versione 0.6.17, bisogna un po' prenderlo in giro ma alla fine son riuscito a farlo partire.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 553
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti