Repository 32bit  Forum
Repository 64bit  Wiki

RISOLTO problema funzionamento tasti rapiti Terminal 0.4.8

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

RISOLTO problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 08, 2012 22:51

ho slackware64 versione 14 che utilizza Terminal 0.4.8 Xfce Terminal Emulator

obiettivo: usare i tasti rapidi e impostare crtl e freccia dx -> per eseguire la tabulazione alla parola successiva.

provandolo sul terminale non fa niente, sta impiantato senza muoversi...

come posso fare?

Invece su questo forum come o in altri programmi se provo a fare ctrl con freccia a dx si sposta.

grazie
Ultima modifica di kshitigharba il lun dic 17, 2012 12:38, modificato 2 volte in totale.
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » sab dic 08, 2012 23:37

su xfce 4.10 le combinazioni sul terminale funzionano bene..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » mar dic 11, 2012 15:45

Se premi ctrl e freccia a dx si sposta?

può essere un problema di settaggio del tipo di keyboard?
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » mar dic 11, 2012 18:46

questa cosa non mi torna... perché su firefox openoffice funziona e solo sul terminal no?
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » ven dic 14, 2012 19:17

Non avrai mica selezionato le due selezioni a spunta appena sotto i tasti di scelta rapida?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 10:16

no , se ti riferisci a "desable all meny access key" e l'altra vote.

se può essere di aiuto quando faccio ctrl -> mi scrive 5C se faccio ctrl <- mi scrive 5D
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » sab dic 15, 2012 17:54

Quelle scritte a me appaiono se i tasti non sono stati impostati, ma una volta fattolo, ed aperte almeno 2 schede funziona bene..
tra l'altro proprio un paio d'ore fa ho installato una stable a 32bit sul fisso con tastiera generica ed anche lì funziona bene..

non so da cosa potrebbe dipendere.. da quanto deduco dai tuoi messaggi hai X in lingua inglese, giusto? La tastiera invece l'hai impostata su italiano?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 18:22

come fai a impostarli?

ho impostato una microsoft natural. layout italian (eliminate dead keys)

la tastiera che uso è questa ibm Modello 1393395 ID142 la trovi a questo sito una sua immagine
http://www.retrocomputing.net/parts/ibm ... s/docs.htm
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » sab dic 15, 2012 18:46

La tastiera la scegli da Tastiera / Keyboard dal tab Mappatura / Keybinding (dovrebbe essere così in inglese)

Ma hai X in inglese?? se si come mai?

EDIT: scusa se dici che la tastiera la hai impostata ed anche la mappatura italiana.. cosa vuoi sapere come impostare?? mi stai confondendo.. :(
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 18:54

ho scaricato questa versione da http://www.slackware.com/ forse durante l'installazione ho dato l'ok per l'inglese boo...
tanto se devo compilare o lanciare comandi son tutti in inglese

in layout trovo
keyboard model e layout ne trovo 4( georgian/ macintosh /uk with italian letter /e quella che uso ora senza dead keys)
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » sab dic 15, 2012 19:10

Devi lasciare il primo quello Italiano e basta.

Per la lingua italiana in X basta editare come utente root i file
Codice: Seleziona tutto
/etc/profile.d/lang.sh

ed anche
Codice: Seleziona tutto
/etc/profile.d/lang.csh


ed alla prima riga che incontri export eccetera.. cambi en_US con it_IT
lascia tutto il resto così com'è, modifichi solo questa riga.. in entrambi i file, anche se nel secondo è meno necessario perché sono sicuro che utilizzi sh come bash.. comunque sono modifiche semplici, non rischi nulla..

Codice: Seleziona tutto
# en_US is the Slackware default locale:
export LANG=it_IT


Il file lang.csh è leggermente diverso, quindi ti riporto la riga da modificare..
Codice: Seleziona tutto
# en_US is the Slackware default locale:
setenv LANG it_IT

Riavvi X et voilà.. ;)
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 19:39

provo subito
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 19:46

ora è tutto in lingua italianaaaa ;) ho riavviato il pc

ma il ctrl -> non funziona fa sempre come prima...
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda kshitigharba » sab dic 15, 2012 19:57

per caso c'è un file di configurazione di terminal che puoi postare qui?
kshitigharba
 

Re: problema funzionamento tasti rapiti Terminal 0.4.8

Messaggioda brainvision » sab dic 15, 2012 20:01

Ma non c'entra il file di conf, se fai le cose per bene dovrebbe andare.. mi fai uno screenshot del tab dei tasti rapidi del terminale?
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite