Repository 32bit  Forum
Repository 64bit  Wiki

Problema sospensione/ibernazione/spegnimento

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema sospensione/ibernazione/spegnimento

Messaggioda Paolo_lav » mer dic 12, 2012 15:19

Salve a tutti, sono nuovo di questo forum ma non di Slackware e di GNU/Linux in generale :) Oggi ho deciso di reinstallare una distro linux (e non una qualsiasi :) ) sul mio portatile del 2006 (Packard Bell EasyNote MV85-004) sperando che, dopo oltre un anno, nuovi kernel ecc avessero risolto il mio stranissimo (e assurdo) problema con il risparmio energetico: praticamente non riesco a spegnere/ibernare/sospendere il PC, o meglio credo che il sistema non riesca a dire al PC di spegnersi (si avvia il processo di sospensione/ecc.., si spegne lo schermo ma il computer resta acceso). Ecco ora il fatto stranissimo e assurdo: se mando in ibernazione il PC questa fallisce, il tutto si pianta e devo spegnere il portatile tenendo premuto il tasto di spegnimento; riavvio il pc e che succede? Tutto funziona ma solo fino al prossimo riavvio! :shock: Questo è un problema che ho avuto più di un anno fa sia con ArchLinux che con Ubuntu e che mi ha costretto a tornare all'uso di Windows :(

QUESTO è il link alla discussione sul forum di ArchLinux che potrebbe magari fornire qualche idea/info aggiuntiva.

Naturalmente allego nuovi log della mia Slack 14. Grazie mille, spero di riuscire a risolvere tale mistero grazie a questa stupenda comunità :)

P.S. Precisazioni /var/log/messages: LINK
Dec 12 14:25:07 riavvio dopo ibernazione fallita (e spegnimento dal pulsante), in seguito ho effettuato una sospensione che è andata a buon fine.

EDIT: Ho scoperto che andando in ibernazione con Windows 7 (va a buon fine) al successivo riavvio con Slackware tutto funziona, ma solo fino al riavvio successivo :shock:
Allegati
pm-powersave.log
(1.87 KiB) Scaricato 91 volte
pm-suspend-success.log
Sospensione avvenuta con successo
(6.68 KiB) Scaricato 90 volte
pm-suspend.log
Sospensione fallita
(5 KiB) Scaricato 84 volte
Paolo_lav
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: ven dic 07, 2012 10:04

Re: Problema sospensione/ibernazione/spegnimento

Messaggioda amevolley » mar dic 18, 2012 0:24

Caro PAolo,
visto che non ci sono risposte provo a dire la mia, magari ti do' qualche spunto.
Innanzitutto non e' strano che sotto Linux non riesci a fare la sospensione, purtroppo ad alcuni laptop questa funzionalita' riesce bene solo sotto Windows.
Io ho un HP e devo dire che con Slackware 14 finalmente il suspend mi funziona direttamente dopo un fresh install, senza fare strani magheggi (script suspend ecc).
Sulla stessa macchina precedentemente usavo slack12.2 che riuscivo a sospendere manualmente con il comando:
"s2ram fps" e sono andato avanti per parecchio tempo con questo sistema.
Magari prova anche tu! Il suspend to RAM e' sicuramente meno invasivo dell'ibernazione e, se il portatile e' ben progettato, ha un consumo di corrente infimo ed il vantaggio di un piu' rapido resume.
amevolley
Linux 1.0
Linux 1.0
 
Messaggi: 55
Iscritto il: gio nov 16, 2006 18:50
Località: bologna

Re: Problema sospensione/ibernazione/spegnimento

Messaggioda Paolo_lav » mar dic 18, 2012 15:05

amevolley ha scritto:Caro PAolo,
visto che non ci sono risposte provo a dire la mia, magari ti do' qualche spunto.
Innanzitutto non e' strano che sotto Linux non riesci a fare la sospensione, purtroppo ad alcuni laptop questa funzionalita' riesce bene solo sotto Windows.
Io ho un HP e devo dire che con Slackware 14 finalmente il suspend mi funziona direttamente dopo un fresh install, senza fare strani magheggi (script suspend ecc).
Sulla stessa macchina precedentemente usavo slack12.2 che riuscivo a sospendere manualmente con il comando:
"s2ram fps" e sono andato avanti per parecchio tempo con questo sistema.
Magari prova anche tu! Il suspend to RAM e' sicuramente meno invasivo dell'ibernazione e, se il portatile e' ben progettato, ha un consumo di corrente infimo ed il vantaggio di un piu' rapido resume.

Innanzi tutto grazie mille per la risposta :) la cosa assurda con questo portatile è che l'Ibernazione (non iberna ma credo spenga normalmente perchè all'avvio non c'è nessun messaggio di ripristino dell'immagine dall'hd) fallisce la prima volta, poi, dopo aver spento dal tasto hardware, tutto funziona perfettamente al successivo riavvio (e per sempre patto di continuare a "spegnere ibernando"), anche la sospensione e i tasti hardware per la regolazione della luminosità dello schermo :doubt:
Paolo_lav
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: ven dic 07, 2012 10:04

Re: Problema sospensione/ibernazione/spegnimento

Messaggioda 414N » dom dic 23, 2012 14:22

Tanto per escludere dimenticanze imbarazzanti: l'hai impostato un adeguato spazio di swap (partizione o file) nel quale porre i dati durante l'ibernazione, vero?
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2878
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problema sospensione/ibernazione/spegnimento

Messaggioda slux » dom dic 23, 2012 15:41

Ulteriore dimenticanza che può sfuggire: hai controllato se esiste un firmware più aggiornato?
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Problema sospensione/ibernazione/spegnimento

Messaggioda Paolo_lav » sab dic 29, 2012 1:22

414N ha scritto:Tanto per escludere dimenticanze imbarazzanti: l'hai impostato un adeguato spazio di swap (partizione o file) nel quale porre i dati durante l'ibernazione, vero?

Si ho 1 GB di RAM e 1,5 di swap. Il problema risiede nell'ACPI, ho decompilato la tavola dsdt e ricompilandola sono uscite fuori decine di errori (che non so come risolvere). Nonostante questo sui sistemi Windows il tutto viene gestito correttamente; ho provato anche con le varie opzioni "*osi=*" in grub ma niente da fare.

slux ha scritto:Ulteriore dimenticanza che può sfuggire: hai controllato se esiste un firmware più aggiornato?

Il mio BIOS è sicuramente buggato, ma è quella che ho l'ultima versione :(

Ho inolte trovato il BUG relativo su kernel.org (LINK), è stato contrassegnato come risolto, ma quell' "OBSOLETE" mi fa pensare che abbiano lasciato perdere: ho compilato infatti il kernel 3.7.1, rilasciato dopo il mark "resolved", ma i problemi restano gli stessi. :(
Paolo_lav
Linux 1.0
Linux 1.0
 
Messaggi: 3
Iscritto il: ven dic 07, 2012 10:04


Torna a Slackware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite