Repository 32bit  Forum
Repository 64bit  Wiki

Sparito audio cuffie

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Sparito audio cuffie

Messaggioda Eberoth » gio gen 17, 2013 2:00

Salve a tutti, oggi mi è successa una cosa davvero strana che spero proprio di riuscire a risolvere col vostro aiuto, anche perché è alquante seccante.
Per farla breve: mi è sparito l'audio dalle cuffie del portatile.

Sparito nel senso che ieri sera funzionava tutto alla perfezione quando ho spento il pc, mentre poco fa, aprendo un video su youtube, ho scoperto con orrore che l'uscita delle cuffie rimane muta. L'audio degli altoparlanti interni funziona, ed i livelli di alsamixer ( volti e mixer di xfce) sono al massimo, e del resto non ho cambiato nulla da ieri ad oggi, solo spento e riacceso il pc a qualche ora di distanza.
Sotto windows funziona tutto, quindi non è un problema hw...

Ho cercato in giro, notanto tra l'altro che i portatili asus sono inclini a fare scherzi con l'audio, ed ho trovato, qui su slackware, una discussione su un problema opposto al mio (andavano le cuffie ma non gli altoparlanti), in cui si suggeriva di modificare il file /etc/modprobe.d/alsa.conf aggiungento la riga:
Codice: Seleziona tutto
options snd-hda-intel model=auto position_fix=0


Tanto per provare l'ho fatto, ma al riavvio non è cambiato nulla. Ho provato a reinizializzare alsa (alsactl init) ma niente. Ho persino provato ad aggiornare il kernel da 3.7.1 a 3.7.2 senza ottenere nulla.
E dire che mi ero rallegrato perché finalmente avevo un portatile in cui funzionava il microfono integrato...

Vi posto qualche informazione sul mio hw, nella speranza che sappiate aiutarmi:

uname
Codice: Seleziona tutto
Linux dreamstorm 3.7.2 #1 SMP PREEMPT Thu Jan 17 01:38:39 CET 2013 x86_64 Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz GenuineIntel GNU/Linux


lspci:
Codice: Seleziona tutto
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation Device 0de9 (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5289 (rev 01)
04:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 0a)


alsamixer
Codice: Seleziona tutto
Card: HDA Intel PCH                                                                             F1:  Help               │
│ Chip: Intel PantherPoint HDMI                                                                   F2:  System information │
│ View: F3:[Playback] F4: Capture  F5: All                                                        F6:  Select sound card  │
│ Item: Master [dB gain: -6,00]                                                                   Esc: Exit               │
│                                                                                                                         │
│                                                                                                                         │
│    ┌──┐        ┌──┐        ┌──┐        ┌──┐        ┌──┐        ┌──┐                                ┌──┐        ┌──┐     │
│    │  │        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │  │        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │  │        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    │▒▒│        │▒▒│        │▒▒│        │▒▒│        │  │        │  │                                │  │        │▒▒│     │
│    ├──┤        ├──┤        ├──┤        └──┘        ├──┤        └──┘        ┌──┐       Enabled      ├──┤        └──┘     │
│    │OO│        │OO│        │OO│                    │MM│                    │OO│                    │MM│                 │
│    └──┘        └──┘        └──┘                    └──┘                    └──┘                    └──┘                 │
│     78       100<>100    100<>100    100<>100      0<>0        0<>0                                0<>0      100<>100   │
│<  Master   > Headphone    Speaker       PCM         Mic      Mic Boost    S/PDIF    Auto-Mute M Internal Mi Internal Mi │
│                                                                                                                         │
└─────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘


Se serve altro chiedete... se non riuscirò a risolvere tenterò di reinstallare tutto il sistema da zero, ma sinceramente vorrei evitarlo visto che ho passato gli ultimi 2 mesi a configurarlo...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » gio gen 17, 2013 10:27

Codice: Seleziona tutto
dmesg | grep -i hda_


Modello del PC- not(net)book?

Codice: Seleziona tutto
cat /proc/asound/card*/codec*/* | grep -i codec
(questo potrebbe essere sbagliato)

Ce la fai a postare un screen di alsamixer? Il diagramma sopra non è molto chiaro.

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » gio gen 17, 2013 13:47

allora, premesso che ho appena riacceso il pc e, questo è inquietante, ora le cuffie funzionano di nuovo ma alsamixer (e/o qualsiasi altro mixer) si rifiuta di partire:

Codice: Seleziona tutto
$ alsamixer
cannot open mixer: Nessun device corrisponde


Nonostante ciò, sono in grado di cambiare il volume usando i tasti multimediali della tastiera, sia quella usb che quella del notebook.

Comunque ecco le informazioni che mi avete chiesto:

Il notebook è un ASUS A55VM

dmesg | grep -i hda_
Codice: Seleziona tutto
snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X


Codice: Seleziona tutto
 $ cat /proc/asound/card0/codec#0 |grep -i codec
Codec: Realtek ALC270


Codice: Seleziona tutto
 $ cat /proc/asound/card0/codec#3 |grep -i codec
Codec: Intel PantherPoint HDMI
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » gio gen 17, 2013 14:14

Sembra il solito errore del kernel quando fa il "probe" della scheda Hda Intel:

a volte azzecca altre no.

Prima di tutto prova a postare anche:
Codice: Seleziona tutto
cat /proc/asound/cards


E rimuovi tutto quello che hai messo tu in modo da riportare tutto a default. In primis: /etc/modprobe.d/alsa.conf
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » gio gen 17, 2013 14:36

Io avevo aggiunto solo alsa.conf e quando ho visto che non cambiava nulla l'ho rinominato in alsa.conf-bk, comunque ora lo elimino del tutto.

Codice: Seleziona tutto
 # cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7a10000 irq 45
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » gio gen 17, 2013 15:05

Ok

Si tratta ora di provare alcuni parametri da passare al modulo snd-hda-intel.

Questi sono i principali:

model=
position_fix=
probe_mask=

Per non stare a riavviare ogni volta, rimuovi il modulo con
Codice: Seleziona tutto
rmmod -v snd-hda-intel

Poi lo ricarichi con modprobe + parametro[i].

Ad es:
Codice: Seleziona tutto
modprobe -v snd-hda-intel probe_mask=1 # oppure probe_mask=3


Ogni volta che carichi il modulo dai /etc/rc.d/rc.alsa per riportare i settaggi del mixer ai valori predefiniti e poi smanetti nei controlli.

Potresti provare ad es a mettere: model=asus, oppure: model=laptop-amic se il tuo netbook ha un ingresso analogico per il microfono.

Insomma... ci devi sbattere un pò il muso e andare a tentativi.

Una volta trovato il parametro che funziona, lo metti in /etc/modpbe.d/*.conf

Questa è la documentazione che ti potrebbe servire:
  1. /usr/src/linux/Documentation/sound/alsa/HD-Audio.txt
  2. /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt

Edit
Prima di rovistare con quella roba, controlla comunque i permessi di questi file:
Codice: Seleziona tutto
ls -l $(find /dev/snd/ -type c)

proprietario=root;
gruppo=audio; il tuo utente deve appartenere a questo gruppo.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » ven gen 18, 2013 18:47

I permessi ed i gruppi sono a posto. Del resto fino a 3 giorni fa tutto funzionava alla perfezione ed io di modifiche al sistema non ne ho fatte prima che si verificasse il problema.

Codice: Seleziona tutto
ls -l $(find /dev/snd -type c)
crw-rw---- 1 root audio 116,  1 gen 18  2013 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 gen 18 18:29 /dev/snd/timer


Codice: Seleziona tutto
wiseman>$ cat /etc/group | grep audio
audio:x:17:wiseman


Tra l'altro ho notato soloora che al boot, prima di passare in init4, ricevo il seguente messaggio da Alsa:

Codice: Seleziona tutto
Loading ALSA Mixer settings: /usr/sbin/alsactl restore
/usr/sbin/alsactl : set_control:1464 : cannot write control '3:3:0:Playback Channel Map :0' : File descriptor bad state


Ma mi era già capitato di vedere quel messaggio quando tutto funzionava, ed avevo pensato si riferisse alla mia porta hdmi "contesa" tra la scheda intel e l'nvidia.

Per quanto riguarda il resto, quando provo a rimuovere il modulo non mi permette di farlo perché è in uso. Così ho provato a forzarne la rimozione... e mi si pianta il terminale. Comunque, alla fine il modulo sparisce da lsmod, quindi do il comando:

Codice: Seleziona tutto
# modprobe -v snd-hda-intel probe_mask=1
insmod /lib/modules/3.7.2/kernel/sound/pci/hda/snd-hda-intel.ko probe_mask=1


ma quando vado a riavviare alsa:
Codice: Seleziona tutto
# /etc/rc.d/rc.alsa
Loading ALSA mixer settings:  /usr/sbin/alsactl restore
/usr/sbin/alsactl: load_state:1696: No soundcards found...


e mi ritrovo completamente senza audio. Ora provo a riavviare nella speranza di tornare a sentire qualcosa (preferisco stare senza mixer piuttosto che senza audio).

EDIT:
Al riavvio l'audio è tornato,ma secondo alsamixer e rc.alsa io non ho una scheda audio.
Visto che non mi lascia rimuovere il modulo, inserisco quelle opzioni in un /etc/modprobe.d/alsa.conf e faccio le prove riavviando?
Mi piacerebbe comunque capire perché sono passato da nessun problema a "nessuna scheda audio" semplicemente spegnento e riaccendendo il pc...

EDIT:
Per l'errore al boot ho trovato questo:
http://www.linuxquestions.org/questions/slackware-14/alsactl-error-with-kernel-3-7-1-on-slackware-current-4175443484/
Che sia responsabile anche di tutto il resto? Sembra strano però...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » ven gen 18, 2013 19:57

Eh si, qualche problema a monte c'è eccome.

Manca parecchia roba in dev/dev/snd. In particolare non hai:
Codice: Seleziona tutto
/dev/snd/controlC0
o qualcosa di simile.

Per questa ragione non hai nessun mixer audio.

Poi ci dovrebbe essere anche qualcosa tipo:
Codice: Seleziona tutto
/dev/snd/midiC0D0
/dev/snd/pcmC0D0c
/dev/snd/pcmC0D0p
/dev/snd/pcmC0D1p


Non è dunque un problema di modulo ed eventuali opzioni. Kernel? udev? Perché non provi a fare un downgrade del kernel?
Il 3.6.11 ad es.

Reinstallare udev?

Rimouovere
Codice: Seleziona tutto
/var/lib/alsa/asound.state
e riavviare?

Non mi viene in mente altro... (hai aggiunto qualche periferica rimovibile?)
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » sab gen 19, 2013 19:21

Ahem... a dire il vero tutta quella "roba" in /dev/snd ora c'è:

Codice: Seleziona tutto
$ ls -l /dev/snd
totale 0
drwxr-xr-x 2 root root       60 gen 19 16:10 by-path/
crw-rw---- 1 root audio 116,  7 gen 19 15:10 controlC0
crw-rw---- 1 root audio 116,  6 gen 19 15:10 hwC0D0
crw-rw---- 1 root audio 116,  5 gen 19 15:10 hwC0D3
crw-rw---- 1 root audio 116,  4 gen 19 15:10 pcmC0D0c
crw-rw---- 1 root audio 116,  3 gen 19 19:02 pcmC0D0p
crw-rw---- 1 root audio 116,  2 gen 19 15:10 pcmC0D3p
crw-rw---- 1 root audio 116,  1 gen 19 16:10 seq
crw-rw---- 1 root audio 116, 33 gen 19 15:10 timer


Era sparita dopo il primo riavvio e non ho idea di quando sia "riapparsa" (sto considerando di consultare un esorcista... o i ghostbusters..), forse quando l'uscita delle cuffie ha ricominciato a funzionare. Ciò nonostante il mixer continua a non funzionare (anche se, premendo i controlli sulla tastiera appare persino l'animazione di vomuled).

Ora provo a cancellare /var/lib/alsa/asound.state e riavviare.
EDIT:
Cancellando quel file, sparisce l'errore al boot, ma la situazione rimane invariata: l'audio sembra funzionare, così pure i controlli da tastiera, ma alsa ed alsamixer continuano a sostenere che la mia scheda audio non esiste... ghostbusters?
EDIT:
Ok, visto che era sparito l'errore ho pensato perché non fare un tentativo e iniziallizzare di nuovo alsa? Cos' ho dao un "alsactl init" e:
Codice: Seleziona tutto
 # alsactl init
Found hardware: "HDA-Intel" "Intel PantherPoint HDMI" "HDA:10ec0270,10431447,00100100 HDA:80862806,80860101,00100000" "0x1043" "0x1447"
Hardware is initialized using a generic method

Ahem...quindi ora sono passato dal non avere una sheda audio ad avere l'uscita HDMI come scheda audio...ok. La cosa diventa ancora più strana visto che, al riavvio, ottengo di nuovo l'errore al boot, ma i mixer grafici si avviano (se li lancio da shell o da menu) ma volti non compare sul pannello ed il plugin "volume" di xfce va in crash appena lo aggiungo...ed infine, alsamixer...beh:
Codice: Seleziona tutto
lsamixer
cannot open mixer: Nessun device corrisponde

Non è che alla fine si tratta davvero di alsa che confonde l'HDMI con la scheda audio? Nel caso, come faccio a farle trovare, ed utilizzare, la scheda giusta? (cosa che, tra l'altro, sembra poi fare lo stesso visto che in realtà l'audio ora funziona).

PS:
No, non ho aggiunto alcuna periferica/modificato il sistema in alcun modoche possa riguardare l'audio. Le uniche cose che ho fatto prima del famoso riavvio sono state:
1) Installare Audacious per tentare di compilare conky+lua (che tra parentesi è una cosa che non mi è mai riuscito di far funzionare, anche col pacchetto di slacky, ma è un'altra storia);
2) Installare hfsutils e ricompilare il kernel con il supporto al fs di casa apple come modulo, _senza_ modificare nient'altro nel .config;
3) Guardare una lunga serie di video su youtube, in cuffia, prima di spegnere il pc.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » sab gen 19, 2013 20:24

Prova a fare così:

avvia il pc sul runlevel 3: quindi niente desktop, sopratutto se kde.

Rimuovi il modulo snd-hda-intel come visto sopra oppure:
Codice: Seleziona tutto
modprobe -vr snd-hda-intel


Ora ricarica il modulo così:
Codice: Seleziona tutto
modprobe -v snd-hda-intel model=dell-m6


Elimina il file asound.state e dai
Codice: Seleziona tutto
/etc/rc.d/rc.alsa


Fatto questo, prova a lanciare alsamixer.

Se va, fai partire una sessione grafica e vedi se l'audio funziona.

Rimuovi sempre asound.state quando fai queste prove.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » dom gen 20, 2013 9:35

Sono passato a tty1, ho fatto il login da root ed ho dato "telinit 1" seguito da "telinit 3", tanto per essere sicuro di non lasciarmi dietro qualche processo scomodo. Ho fatto tutte le prove che mi hai suggerito, comprese quelle del post precedente, senza ottenere altri risultati: a volte rc.alsa non parte proprio dicendo che non trova nessuna scheda audio, altre volte parte, crea asound.state e poi mi dice: "cannot open mixer: Nessun device corrisponde" ... ovvero sempre la solita solfa.

L'unica differenza è che prima di queste prove, il mixer non andava, ma l'audio in cuffia funzionava benissimo (era riapparso all'avvio successivo la stesura del primo post), mentre ora è sparito di nuovo. In sostanza ho peggriorato la situazione: del mixer mi importava il giusto (visto che comunque i tasti multimediali ed il mixer grafico di xfce funzionano tuttora), ma senza audio in cuffia non posso andare avanti a lungo...

Ti ringrazio per il tuo aiuto rik70, ma comincio a disperare. Sopratutto ora che sono tornato alla situazione di partenza, abbandonandone una tutto sommato accettabile.

EDIT:
Ho dimenticato di aggiungere che, nel frattempo, ho aggiornato udev (sono in current) e con la scusa sono passato al kernel 3.7.3 (la terza versione che provo da quando è cominciato tutto 3.7.1->3.7.2->3.7.3). Ovviamente non ho risolto nulla. Ho pure provato un riavvio con il generic della 14.0 (3.2.29) senza alcun risultato. Comunque questo sistema ha sempre girato sul 3.7.1 e, fino all'altro giorno, non mi aveva dato problemi.

EDIT:
Chiedo scusa ma la situazione cambia ad ogni riavvio... ora l'uscita delle cuffie funziona di nuovo. Cosa ho fatto? Riavviato sotto windows e giocato per un'oretta a fallout3... mah...
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » dom gen 20, 2013 19:15

Se la situazione cambia ad ogni riavvio, allora è molto probabile che la questione sia dovuta proprio a cià che si diceva all'inizio: in assenza di parametri al modulo snd-hda-intel, il sistema non sa come inizializzare la scheda audio. A volta ci prende - o ci prende in parte - altre no.

Secodo me - escluso qualsiasi problema alla tua configurazione - l'unica cosa che puoi provare a fare è quella vista sopra, evitando così i riavvii frustranti:

1 - telinit 3 - in modo da disimpegnare il driver da qualsiasi applicazione;

2 - scaricare il driver:
Codice: Seleziona tutto
modprobe -vr snd-hda-intel


3 - ricaricarlo:
Codice: Seleziona tutto
modprobe -v snd-hda-intel index=0


4 - rimuovere eventuale asound.state e qualsiasi altra cosa in /etc/modprobe.d/ che si riferisca al modulo in questione (che hai aggiunto tu, s'intende);

5 - lanciare lo script:
Codice: Seleziona tutto
/etc/rc.d/rc.alsa


6 - alsamixer

In questo modo sei alle impostazioni di default.

Non succede nulla di che? Bene - anzi male.

Ripeti i punti 2-6 e prova a passare i famosi parametri al modulo.

Per esempio, prova questo (al punto 3):
Codice: Seleziona tutto
modprobe -v snd-hda-intel index=0 enable_msi=1 model=laptop-amic


Non va?
Bene - cioè male.

Prova allora a togliere 'model=laptop-amic' (o viceversa: enable_msi=1).

Fai sapere, perché secondo me a tentativi - ripeto, escludendo altri problemi - se ne deve uscire.

Ciao

------------------------

Edit
P.s.

Ogni volta che (ri)carichi il modulo, controlla che non ci siano errori. Dai anche un `dmesg` per vedere se viene riportato qualcosa di strano.

PP.SS
In base alla documentazione del kernel, questi sono i "model" che puoi provare:

    laptop-amic - Laptops with analog-mic input
    laptop-dmic - Laptops with digital-mic input
Questi sotto probabilmente non vanno bene, ma - lenovo a parte - tentare ....

    alc269-dmic - Enable ALC269(VA) digital mic workaround
    alc271-dmic - Enable ALC271X digital mic workaround
    inv-dmic - Inverted internal mic workaround
    lenovo-dock - Enables docking station I/O for some Lenovos
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » lun gen 21, 2013 15:03

Continuo però a chiedermi perché per i primi due mesi tutto ha funzionato senza problemi.
Comunque, avevo visto i modelli disponibili e ne avevo già tentati un paio...senza successo, ma ho visto che hai usato qualche altro parametro negli esempi e appena ho un attimo di tempo farò altre prove...

grazie per la pazienza.
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Re: Sparito audio cuffie

Messaggioda rik70 » lun gen 21, 2013 15:51

Eberoth ha scritto:Continuo però a chiedermi perché per i primi due mesi tutto ha funzionato senza problemi.

Questa è la domanda delle cento pistole: stiamo ipotizzando che il problema sia legato ad alcuni parametri del modulo, ma....

..se tu hai controlC0 in /dev/snd/ e il mixer non funziona nemmeno sul runlevel 3, allora penso anch'io che qualcosa stia andato storto.
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1253
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Sparito audio cuffie

Messaggioda Eberoth » mer mar 13, 2013 10:25

Ok, lo so che è passato diverso tempo, ma visto che il problema è ancora irrisolto, ed io ho finalmente trovato un attimo di tempo per metterci mano, mi permetto di aggiornare questa discussione:

Un'oretta fa ho aggiornato il kernel, passando dalla 3.7.3 alla 3.8.2 e... beh, al riavvio sembrava tutto come prima, se non che, dopo un paio di prove, ora TUTTE le applicazioni vedono correttamente la mia scheda audio (da vlc a skype passando per volti ed il mixer di xfce) e la fanno funzionare perfettamente, microfono interno incluso... tutte tranne alsamixer e compagnia che, invece, continua a sostenere:
Codice: Seleziona tutto
$ alsamixer
cannot open mixer: Nessun device corrisponde
Avatar utente
Eberoth
Linux 2.4
Linux 2.4
 
Messaggi: 379
Iscritto il: lun ago 24, 2009 8:22
Slackware: -current
Kernel: 3.13.6
Desktop: KDE4
Distribuzione: Slackel64

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron