Repository 32bit  Forum
Repository 64bit  Wiki

Ubuntu 12.10 Vs Ati catalist 12.6

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda 414N » mar gen 15, 2013 22:43

Anche a me pare strana la tua situazione (d'altronde non esisterebbe quel repository di terze parti per fglrx-legacy se questi non funzionasse su Ubuntu 12.10 per nessuno), ma non sei solo su questa barca (guarda qui e qui).
Purtroppo AMD non si prodiga più di tanto nello sviluppo dei suoi driver proprietari per Linux, probabilmente confidando che i driver open prima o poi raggiungano un livello prestazionale simile a quelli closed e si autogestiscano da lì in poi. AMD ha anche contribuito in tal senso non poco in questi ultimi 4/5 anni rilasciando apertamente un po' di documentazione tecnica sui propri chip, aiutando un po' gli sviluppatori di driver open.
Offtopic: Ovviamente l'apertura non è stata totale e, sempre ovviamente, tutta la parte relativa all'accelerazione video H264 ecc. è rimasta chiusa peggio di Fort Knox, mentre la concorrenza viaggia opensource (Intel) oppure con un'ottima implementazione closed (VDPAU Nvidia)
Secondo me, finché AMD non se ne uscirà con una versione aggiornata di fglrx-legacy (se mai lo farà), ti conviene non arrovellartici troppo sopra e passare ai driver open (mesa + xf86-video-ati). Mesa ha finalmente cominciato a "sconfinare" nell'universo di OpenGL 3.0 con la release 9.0 e, su git, ultimamente sono state pubblicate diverse patch che implementano diverse migliorie per il driver r600 (quello che gestisce tutto le schede radeon HD2000/6000).
Con ogni probabilità, la prossima release stabile di mesa (presumibilmente la 9.1), unita alle ultima novità nei nuovi kernel (il 3.8 dovrebbe presentare varie migliorie per il sottosistema DRM), permetterà di avere qualche prestazione in più sul fronte radeon rispetto ad adesso.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda DarkNeo » mer gen 16, 2013 0:46

che brutta notizia che mi hai dato...
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda rik70 » mer gen 16, 2013 11:18

A sentire quello che si legge in rete, sembra che i problemi con quei driver ci siano anche con xorg 1.12.4. Pare che l'unica versione su cui girano sia la 1.12.3. Non capisco perché il tizio abbia messo nel ppa la versione + problematica. Ma non gli si può rimproverare nulla.

Comunque non è il caso di disperarsi: bisogna fare i conti con queste cose. I legacy sono driver che non vengono + sviluppati, ma solo "mantenuti". E se girano non rimane che stappare una bottiglia e accontentarsi di come lo fanno.

Oramai bisogna puntare sull'open: il modo con cui nvidia supprta Xorg è a dir poco esilarante. Intel è la strada da seguire. O i driver open per le schede AMD, ma per questi ci vuole tempo.

Piuttosto una curiosità:

ma coi driver radeon come va la questione? Perché vuoi per forza usare i proprietari?
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1202
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda DarkNeo » mer gen 16, 2013 15:54

Ormai più che altro è una questione di principio, odio vedere che quando sposto le finestre cè un po di lag e soprattutto se un driver cè e lo dichiarano valido per la scheda in qualche modo deve pur funzionare.
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda 414N » mer gen 16, 2013 15:57

Hai scelto il produttore di hardware grafico sbagliato per farne una questione di principio ;)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda DarkNeo » mer gen 16, 2013 17:34

ahahah, è capitato, non l'ho messa io la scheda grafica nel portatile!! Userò i radeon.
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda 414N » mar gen 22, 2013 9:41

Buone nuove!
AMD ha rilasciato i driver legacy 13.1 per Radeon HD2xxx/4xxx, con supporto a Xorg 1.13 (non serve più quindi effettuare un downgrade di X su Ubuntu) e altre migliorie. Ti consiglio di rimuovere quel repository esterno e di riaggiornare il sistema (in modo da tornare alla versione "standard" di X) prima di procedere.
Si possono scaricare qui (in alto è ancora riportato 12.6, ma il link di download in basso è per i 13.1)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda DarkNeo » mer gen 23, 2013 23:01

Grazie, ora provo e ti dico.
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda DarkNeo » mer gen 23, 2013 23:50

Ho provado sia con sh amd...run che sh amd...run --buildpkg && dpkg -i *.deb ma il risultato è sempre lo stesso.
Codice: Seleziona tutto
root@DarkNeo:/home/neo/Scaricati# modprobe fglrx
FATAL: Module fglrx not found.

ho sia gli headers che i source installati
DarkNeo
Linux 3.x
Linux 3.x
 
Messaggi: 1071
Iscritto il: ven giu 03, 2005 23:00
Località: Matrix
Nome Cognome: Stefano Arbitrio
Slackware: Slackware64 14
Kernel: 3.2.X
Desktop: KDE

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda rik70 » gio gen 24, 2013 9:29

kernel?

Innanzitutto prova a vedere se compila il modulo. Questo metodo permette di testare la compilazione senza installare nulla:

Codice: Seleziona tutto
sh amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run --extract fglrx


Entra nella directory fglrx appena creata e:

Codice: Seleziona tutto
cd common/lib/modules/fglrx/build_mod/2.6.x/


Poi:
Codice: Seleziona tutto
ln -sv ../../../../../../arch/x86/lib/modules/fglrx/build_mod/libfglrx_ip.a

Sostituisci x86 con 'x86_64' se sei su un sistema a 64-bit.

Infine:
Codice: Seleziona tutto
make


Se da errore, serve questa patch:
http://sources.gentoo.org/cgi-bin/viewv ... vision=1.1

Ciao
rik70
Linux 3.x
Linux 3.x
 
Messaggi: 1202
Iscritto il: gio mar 10, 2011 9:21
Slackware: 14.1
Kernel: generic-smp
Desktop: Xfce

Re: Ubuntu 12.10 Vs Ati catalist 12.6

Messaggioda 414N » gio gen 24, 2013 10:14

DarkNeo ha scritto:Ho provado sia con sh amd...run che sh amd...run --buildpkg && dpkg -i *.deb ma il risultato è sempre lo stesso.
Codice: Seleziona tutto
root@DarkNeo:/home/neo/Scaricati# modprobe fglrx
FATAL: Module fglrx not found.

ho sia gli headers che i source installati

Beh, mi sembra ovvio che il modulo del kernel non ci sia...
Dovresti controllare l'output dell'installer nel momento che tenta di compilare il modulo del kernel.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2881
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Precedente

Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite