Repository 32bit  Forum
Repository 64bit  Wiki

alsa dopo upgrade del kernel per -current

Se avete problemi con l'installazione e la configurazione di Slackware postate qui. Non usate questo forum per argomenti generali... per quelli usate Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware, se l'argomento è generale usate il forum Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

alsa dopo upgrade del kernel per -current

Messaggioda tornadomig » ven gen 25, 2013 18:46

Codice: Seleziona tutto
/usr/bin/alsactl: set_control:1464: Cannot write control '3:3:0:Playback Channel Map:0 File descriptor in bad state'


ciao a tutti!

ora che ho un attimo di tempo, mi son deciso a postare quello che vedete sopra. prima di fare il solito login compare quella scritta. anzi piu' di una. mi devo preoccupare? e' successo dopo che ho upgradato il kernel da 3.2.29 a 3.7.1 con slackpkg. evidentemente qualche collegamento e' andato farsi benedire chissa' dove. googlando per slackware -current non ho trovato niente per questo issue ma per ubuntu e arch linux si'. qui pero' mi fermo. ad altri e' capitato lo stesso ? faccio presente che l'audio mi va per fortuna.

grazie ed happy slack ;)
Ultima modifica di tornadomig il ven gen 25, 2013 20:03, modificato 1 volta in totale.
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: alsa dopo upgrade del kernel per -current

Messaggioda brainvision » ven gen 25, 2013 19:16

questo avviso vien fuori quasi sempre quando si aggiornano alcuni pacchetti, è abbastanza normale e la soluzione è molto semplice, anche se non me la ricordo.. :)
mi pare però che dovrebbe bastare, da root, eseguire
Codice: Seleziona tutto
alsactl sore
altrimenti prova anche eliminare il file
Codice: Seleziona tutto
/etc/asound.state
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: alsa dopo upgrade del kernel per -current

Messaggioda tornadomig » ven gen 25, 2013 20:08

Codice: Seleziona tutto
alsactl store


con questo comando avevo gia' provato. non l'ho detto prima. mi scuso. ho riprovato ma non funzia. nemmeno eliminando il file /etc/asound.state. tutto come prima.

questo fatto e' capitato sia con l'upgrade del kernel di pat usando slackpkg sia con l'installazione pulita da iso scaricata da slackware.no della -current. per essere certo ho voluto fare anche questo tentativo e dare un elemento in piu' per dipanare la matassa :roll:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: alsa dopo upgrade del kernel per -current

Messaggioda brainvision » ven gen 25, 2013 21:00

ah bene..

comunque davvero, è una cosa da nulla, capitava spesso anche a me ed è anche capitato ieri quando ho aggiornato il kernel.. però poi al ravvio successivo non dovrebbe più darti quell'avviso..

prova anche a riavviare il demone di alsa con restart, chissà..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: alsa dopo upgrade del kernel per -current

Messaggioda Amrod » mar gen 29, 2013 13:15

Avevo anch'io lo stesso problema e aggiornando il kernel alla versione 3.7.5 sembra che si sia risolto tutto.
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox


Torna a Slackware

Chi c’è in linea

Visitano il forum: fenics e 3 ospiti