Repository 32bit  Forum
Repository 64bit  Wiki

bootp lentoooo

Postate qui per tutte le discussioni legate a Linux in generale.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Gnu/Linux in genere, se l'argomento è specifico alla Slackware usate uno dei forum Slackware o Slackware64.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

bootp lentoooo

Messaggioda Meskalamdug » lun feb 11, 2013 17:47

in.tftpd -s /tftpboot -B 1468

Quando i client pxe caricano le immagini ci mette circa 5-6 minuti(da chiavetta usb 1 minuto,da cd 10 secondi)
come mai?
La rete non è congestionata.
Grazie a chi mi aiuterà
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: bootp lentoooo

Messaggioda joseph » lun feb 11, 2013 22:16

Hai provato a monitorare la connessione lan?
Avatar utente
joseph
Linux 2.4
Linux 2.4
 
Messaggi: 205
Iscritto il: lun giu 14, 2010 22:50
Località: Salerno
Slackware: 13.37
Kernel: 3.2.9
Desktop: xfce

Re: bootp lentoooo

Messaggioda Meskalamdug » lun feb 11, 2013 22:50

joseph ha scritto:Hai provato a monitorare la connessione lan?

Proverò con wireshark.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: bootp lentoooo

Messaggioda zoros » mar feb 12, 2013 0:31

Meskalamdug ha scritto:in.tftpd -s /tftpboot -B 1468
...

immagino ti riferisca alla voce in /etc/inetd.conf ...

prova:
Codice: Seleziona tutto
tftp   dgram   udp    wait    root    /usr/sbin/tcpd  in.tftpd -s /tftpboot -r blksize


riavviando il servizio, ovviamente ;)
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)

Re: bootp lentoooo

Messaggioda Meskalamdug » mar feb 12, 2013 12:26

zoros ha scritto:
Meskalamdug ha scritto:in.tftpd -s /tftpboot -B 1468
...

immagino ti riferisca alla voce in /etc/inetd.conf ...

prova:
Codice: Seleziona tutto
tftp   dgram   udp    wait    root    /usr/sbin/tcpd  in.tftpd -s /tftpboot -r blksize


riavviando il servizio, ovviamente ;)

Si blocca all'avvio e da opentimemout
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: bootp lentoooo

Messaggioda zoros » mar feb 12, 2013 16:31

Meskalamdug ha scritto:...
Si blocca all'avvio e da opentime out

potrebbe mancare la voce "next-server" in dhcpd.conf, lo spiegano anche QUI ...

questo l' /etc/dhcpd.conf che uso io:
Codice: Seleziona tutto
#------ /etc/dhcpd.conf (Remix4 default) ------
ddns-update-style none;
allow booting;
allow bootp;
default-lease-time -1;
max-lease-time 7200;
authoritative;
#
# default gateway
option routers 192.168.0.200;
#
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option domain-name-servers 208.67.222.222;
#option domain-name "RemiX-domain";
server-name "RemiX-server";
#
subnet 192.168.0.0 netmask 255.255.255.0
{
 #If set "auto" in Config this is the remote desktop server
 next-server 192.168.0.1;
 #
 #Used in both PXEclient and gPXE as default
 filename "/gpxelinux.0";
 #
 range dynamic-bootp 192.168.0.128 192.168.0.248;
 option host-name "RemiX";
 #
 if exists user-class and option user-class = "gPXE"
 {
  filename "/gpxelinux.0";
 }
 #
 group customIP
 {
  host pc-01  { hardware ethernet 00:11:22:33:44:55 ; fixed-address 192.168.0.11 ; }
 }
}

ma usi PXE o gPXE?
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)

Re: bootp lentoooo

Messaggioda Meskalamdug » mar feb 12, 2013 16:35

zoros ha scritto:
Meskalamdug ha scritto:...
Si blocca all'avvio e da opentime out

potrebbe mancare la voce "next-server" in dhcpd.conf, lo spiegano anche QUI ...

questo l' /etc/dhcpd.conf che uso io:
Codice: Seleziona tutto
#------ /etc/dhcpd.conf (Remix4 default) ------
ddns-update-style none;
allow booting;
allow bootp;
default-lease-time -1;
max-lease-time 7200;
authoritative;
#
# default gateway
option routers 192.168.0.200;
#
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.0.255;
option domain-name-servers 208.67.222.222;
#option domain-name "RemiX-domain";
server-name "RemiX-server";
#
subnet 192.168.0.0 netmask 255.255.255.0
{
 #If set "auto" in Config this is the remote desktop server
 next-server 192.168.0.1;
 #
 #Used in both PXEclient and gPXE as default
 filename "/gpxelinux.0";
 #
 range dynamic-bootp 192.168.0.128 192.168.0.248;
 option host-name "RemiX";
 #
 if exists user-class and option user-class = "gPXE"
 {
  filename "/gpxelinux.0";
 }
 #
 group customIP
 {
  host pc-01  { hardware ethernet 00:11:22:33:44:55 ; fixed-address 192.168.0.11 ; }
 }
}

ma usi PXE o gPXE?

PXE,e la voce next server è presente
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: bootp lentoooo

Messaggioda zoros » mar feb 12, 2013 22:02

Meskalamdug ha scritto:
zoros ha scritto:ma usi PXE o gPXE?

PXE,e la voce next server è presente

ok,
per me è chiusa qui ... sono l'unico a mettere dei feedback (diversi da sì o no) ... direi, dati insufficienti ;) ...
vorrei riavere le mie firme ...
Avatar utente
zoros
Linux 3.x
Linux 3.x
 
Messaggi: 1307
Iscritto il: lun mag 28, 2007 21:51
Località: Gorizia
Nome Cognome: Fabio∙Zorba
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)


Torna a Gnu/Linux in genere

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron